summaryrefslogtreecommitdiff
path: root/dev-python/rich
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-12-31 08:19:20 +0000
committerV3n3RiX <venerix@koprulu.sector>2022-12-31 08:19:20 +0000
commit6989a301768c924a6014fdce19b28de541ad557a (patch)
tree48fc14349566cfd64cf81015dcbfbfe5c4360186 /dev-python/rich
parentd897af505afa85942967dd218e3005a4ad906e5a (diff)
gentoo auto-resync : 31:12:2022 - 08:19:20
Diffstat (limited to 'dev-python/rich')
-rw-r--r--dev-python/rich/Manifest2
-rw-r--r--dev-python/rich/rich-13.0.0.ebuild48
2 files changed, 50 insertions, 0 deletions
diff --git a/dev-python/rich/Manifest b/dev-python/rich/Manifest
index dbd9da7edc9f..5edcfd9f2c2f 100644
--- a/dev-python/rich/Manifest
+++ b/dev-python/rich/Manifest
@@ -1,3 +1,5 @@
DIST rich-12.6.0.gh.tar.gz 15056457 BLAKE2B 58367ef0acb61d68931ea0394ea458e29b3bb59726c6b95d4b179553183c5cef2766484e0d040203181aad927add70198fb3483bfe6113e20851db141de3a867 SHA512 e05a0ad1d6b4f1e4f7e5e3d09c70d5892a618707ae0952e34274c5ffb18a833fe85a4ac15024cc34915515b63059c02f0df32a6c97cbe91e9ac96928c7134fb0
+DIST rich-13.0.0.gh.tar.gz 15065008 BLAKE2B b2b323b633e6600dd1595c1769daf3659b2d7cf6f98fe91ca9e083c24bc3de9de79b27de08144ab7acaa3634cc588f1548d73536555a06f1b4832f91c978ab9a SHA512 6837aad1015318c0a017000ba60cea0b4b06e85b7fb9650e90ed87ca8dedd3bf3369c5520571661123aee099380445eefa6b30002f0290c2160540a49433bb91
EBUILD rich-12.6.0.ebuild 1566 BLAKE2B b94f72c62cc0f9fa817457124f92ddf4afa1a476fdcb71e255cb84ace59d057f98781c8eb7199c4bb71377068f8a7f1dbb609d4632e20c545669dc43c1130e69 SHA512 4ae59947e8f807511653a5a334f85377327d388475385161e89c1275a261ffe6364e1bf51e4b63088e39889f448238fcead2e26864479d9af87baf91ae2636dc
+EBUILD rich-13.0.0.ebuild 1189 BLAKE2B befb7416aac279d8d03c54c40430643a882294f60d07d578e9304b10766051e22e207a79196941d0caae6251db2dd7ae380bb048fb39c4cb6cc7b236060df7f4 SHA512 7a8ac0592d4ef7403a368a0fccbd6771bd3c828451dc45144686a2a430004ac40eab22caa0702e7bca542da7ec24fe2af10eb590068a681f1afa8b56ca71ee24
MISC metadata.xml 387 BLAKE2B 049491e034ba233f33c76dc5e3f1b887ba5d2da9d65b09bda51a7cf4eb30a9c66f3ddf714f52407a73e51da78523084064bccd4fc687e0bc0fc2b32dbb4c513b SHA512 448ce879331748e3166f670981a27ee5c3ef20b51af442ccc684cb6514c0d6a0d4e433a8bc1ddb3bdf68c734bac013c1ba04d38adf90644b062231ab1c1d2c0b
diff --git a/dev-python/rich/rich-13.0.0.ebuild b/dev-python/rich/rich-13.0.0.ebuild
new file mode 100644
index 000000000000..5f6ee739ea12
--- /dev/null
+++ b/dev-python/rich/rich-13.0.0.ebuild
@@ -0,0 +1,48 @@
+# Copyright 2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=poetry
+PYTHON_COMPAT=( python3_{8..11} pypy3 )
+
+inherit distutils-r1 optfeature
+
+DESCRIPTION="Python library for rendering rich text, tables, etc. to the terminal"
+HOMEPAGE="
+ https://github.com/Textualize/rich/
+ https://pypi.org/project/rich/
+"
+SRC_URI="
+ https://github.com/Textualize/rich/archive/v${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
+
+RDEPEND="
+ dev-python/colorama[${PYTHON_USEDEP}]
+ dev-python/commonmark[${PYTHON_USEDEP}]
+ dev-python/pygments[${PYTHON_USEDEP}]
+ $(python_gen_cond_dep '
+ dev-python/typing-extensions[${PYTHON_USEDEP}]
+ ' 3.8)
+"
+
+distutils_enable_tests pytest
+
+python_test() {
+ local -x COLUMNS=80
+ local EPYTEST_DESELECT=(
+ # TODO
+ tests/test_console.py::test_size_can_fall_back_to_std_descriptors
+ tests/test_inspect.py::test_inspect_integer_with_methods_python38_and_python39
+ )
+ epytest -p no:pytest-qt
+}
+
+pkg_postinst() {
+ optfeature "integration with HTML widgets for Jupyter" dev-python/ipywidgets
+}