summaryrefslogtreecommitdiff
path: root/dev-python/rich
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2024-02-29 05:41:15 +0000
committerV3n3RiX <venerix@koprulu.sector>2024-02-29 05:41:15 +0000
commit48f3e81fd35a18cd49f8b8d6a041f33ad88f9c89 (patch)
tree21e7be95bcd3ec7cc6c71b3fea560ea936ddef82 /dev-python/rich
parentcb7e4377c338fd6cd2fb4fc22d64eef88e390161 (diff)
gentoo auto-resync : 29:02:2024 - 05:41:15
Diffstat (limited to 'dev-python/rich')
-rw-r--r--dev-python/rich/Manifest2
-rw-r--r--dev-python/rich/rich-13.7.1.ebuild57
2 files changed, 59 insertions, 0 deletions
diff --git a/dev-python/rich/Manifest b/dev-python/rich/Manifest
index 8db9b1559ab9..fe206c6f49f4 100644
--- a/dev-python/rich/Manifest
+++ b/dev-python/rich/Manifest
@@ -1,6 +1,8 @@
AUX rich-13.7.0-nocolor.patch 1570 BLAKE2B a8842324bdcf457356c2fb14a5fc6dfb7825fde1fcce84e362e50fd0deff3ccb5eeca9b7fe6ae3a45b9ea0d8ca3a73a06c0eba7dad4612cf986f81821d883f8c SHA512 7893b9142a89b6bf5ce4fb15ba82a65fdae52c44e6dd99240a6bd169327fe3d94c7a7c9dbaec0b001c2dcaedec743111a849ce9c607e67440dd9b64caae62885
DIST rich-13.4.2.gh.tar.gz 15063000 BLAKE2B f65079440bc7d89a3ff03be01fa71e076493ae50f22ae8781be2448a7ff2769c174d6654db3a835d34720c34cd8cbecfdd6b13e3064cf7fdcade71806563309d SHA512 17052a9fb0e1d89b31a00d8a719214719891d048fd805185b2d4258c8766130f44bf2280c9567bc162f3b34d9bf2eb7d747d6a37d910c81cd53d3003b51f70bd
DIST rich-13.7.0.gh.tar.gz 15057791 BLAKE2B d474b5817c0e64143313a1d0b66ef0953990196ecef6b0fd62d82828902008fa7293290c7f43c605a0c897ecebecb84e816583da8921cd31fc56c902ead2f5c9 SHA512 c5c432bd73b0c28d9585bce2e122d6b9da0a0744ea7824b4682948f11e153dfc615f5ed94d9531ced422298d352371fba5f25ddf16ca7a1d669f799ab361d984
+DIST rich-13.7.1.gh.tar.gz 15058064 BLAKE2B 6fad18bf0a4e4f72e530c78db7a498f27dd8c9a7b9b17ca5ef12a94bbe513857f3c42d4903f8ebbfe8907727cddaf290f08862c27efb29db8aaf70c7bcb13ace SHA512 0c69101bc6c2a238a4c516812cda08299115b903b8282ee348b45b212a88fcbfbf69d11a3705a97bdb6192988ee3047804bb5b52b7950d860542cde8ce2d4bd2
EBUILD rich-13.4.2.ebuild 1818 BLAKE2B 100be0b0f6d3f00a867be57b132e05bc831a283373ebb46b92afd2d6cfd6b636b82b2e91ff956787dd18d6d115293f1b65d8ba2f12e6206ebbd2376286942a71 SHA512 162391cb1f36d42388e95f51dea9c0a5f499cb0bba2659444c15aba84971dc8a4324aa4dafa3ca31c8eb4d92e223fd5a4c71b858933f536b99633608c32b3464
EBUILD rich-13.7.0.ebuild 1487 BLAKE2B 424f2523e12a4869a002a30e64cb42cb3de7fee24e4f0bc269be7afe44c58f58793f96febc84901095dfbc0a597dc7e7a2097a2db6f151f42c965c3ceb5078ee SHA512 d879b0df4e21f6b4ba4ddcf548f854d0de2e599d8fe125d955f580d2973e0bb37e40919c8c83f35ad34e5f04a46212b9763d24d1e362a63a477c98cbf8091f5d
+EBUILD rich-13.7.1.ebuild 1400 BLAKE2B d1a698d58f2e69d002ca4fb0a011e287010c7b67fa20c6eb8c8ebe0f25465f27db266a748695752848de188f54ef396fbd8211265a22ef59a5f57e1bfbcd30c8 SHA512 dee1414aa8085eb32aef054b6d204db9181b8b1563accec0ce421b4e53c124b6825d959a304a51877f14f9c130894dcee6c8e2b35fba45deda3750ee4e2dcb30
MISC metadata.xml 387 BLAKE2B 049491e034ba233f33c76dc5e3f1b887ba5d2da9d65b09bda51a7cf4eb30a9c66f3ddf714f52407a73e51da78523084064bccd4fc687e0bc0fc2b32dbb4c513b SHA512 448ce879331748e3166f670981a27ee5c3ef20b51af442ccc684cb6514c0d6a0d4e433a8bc1ddb3bdf68c734bac013c1ba04d38adf90644b062231ab1c1d2c0b
diff --git a/dev-python/rich/rich-13.7.1.ebuild b/dev-python/rich/rich-13.7.1.ebuild
new file mode 100644
index 000000000000..d16b3c600af9
--- /dev/null
+++ b/dev-python/rich/rich-13.7.1.ebuild
@@ -0,0 +1,57 @@
+# Copyright 2022-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=poetry
+PYTHON_COMPAT=( python3_{10..12} pypy3 )
+
+inherit distutils-r1 optfeature
+
+DESCRIPTION="Python library for rendering rich text, tables, etc. to the terminal"
+HOMEPAGE="
+ https://github.com/Textualize/rich/
+ https://pypi.org/project/rich/
+"
+SRC_URI="
+ https://github.com/Textualize/rich/archive/v${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
+
+RDEPEND="
+ dev-python/colorama[${PYTHON_USEDEP}]
+ >=dev-python/markdown-it-py-2.2.0[${PYTHON_USEDEP}]
+ >=dev-python/pygments-2.13.0[${PYTHON_USEDEP}]
+"
+
+distutils_enable_tests pytest
+
+python_test() {
+ local EPYTEST_DESELECT=(
+ # TODO
+ tests/test_console.py::test_size_can_fall_back_to_std_descriptors
+ # TODO: segfault in recursion (PyQt6 interfering?)
+ tests/test_traceback.py::test_recursive
+ )
+ # version-specific output -- the usual deal
+ case ${EPYTHON} in
+ pypy3)
+ EPYTEST_DESELECT+=(
+ # pypy3.10, to be more precise
+ tests/test_inspect.py::test_inspect_integer_with_methods_python310only
+ )
+ ;;
+ esac
+
+ local -x COLUMNS=80
+ local -x PYTEST_DISABLE_PLUGIN_AUTOLOAD=1
+ epytest
+}
+
+pkg_postinst() {
+ optfeature "integration with HTML widgets for Jupyter" dev-python/ipywidgets
+}