summaryrefslogtreecommitdiff
path: root/dev-python/rich
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-03-28 09:49:11 +0100
committerV3n3RiX <venerix@koprulu.sector>2023-03-28 09:49:11 +0100
commit115dcc7054f5934a2c8e26fd8a8eed5f3e29e9ce (patch)
treec31afe35699960753f76770d6b0b4ea48af9f686 /dev-python/rich
parente292b671b113c2cc012beddad93a3df4f9410698 (diff)
gentoo auto-resync : 28:03:2023 - 09:49:10
Diffstat (limited to 'dev-python/rich')
-rw-r--r--dev-python/rich/Manifest2
-rw-r--r--dev-python/rich/rich-13.3.3.ebuild52
2 files changed, 54 insertions, 0 deletions
diff --git a/dev-python/rich/Manifest b/dev-python/rich/Manifest
index 50b5d985fbf8..725b78277e51 100644
--- a/dev-python/rich/Manifest
+++ b/dev-python/rich/Manifest
@@ -1,5 +1,7 @@
DIST rich-13.3.1.gh.tar.gz 15055408 BLAKE2B 79713ee232bc1c990c1432f7966cffd69b8ffef9ad8a562339d62b03fbab4620040c5ae1d735d3084d71f32581955f0ea5fad113ff992dcddb2dd0e20465484e SHA512 a3b5bef2183bbb888f0ef5a90b35fdb1ed7ef6103dfea01a5efa441ce8d1769b53d7888684e3b5cd76bcacf3768835d918d9fbb7801eab57c04d1412f129f6bb
DIST rich-13.3.2.gh.tar.gz 15060707 BLAKE2B fbee6e01b60a18cb32a7f86fa41d621d2cb895e5602f23ed85e7338788f4fbab401fe0a8c2b2bb3a1975c40ebeaaf4d013e50a6d6e5cad6324a14acea21d48dc SHA512 9f33658d8dfa5c22fd92ca83690628ded12d428777d6cd7752afc35c36481d46df1766841eaf003917ec6da932d6f29981c779846d4c14a95e2738e74ec20b2c
+DIST rich-13.3.3.gh.tar.gz 15060927 BLAKE2B 2d4aaca6dd18b7f3dd6267b3ead09ece8e2edc2ed050c137a93618915f6cd999744957d6925da90446a5b3a46ef871561145d5c2c27ff2722afac24090cf1064 SHA512 049b5145685509f722d744e5b7e2703bf14e5449da02f24e92ac856552bddeef96777760ead4e1e0f6599cc1b13cc424dc558a20c426dcbd7d4230322226832c
EBUILD rich-13.3.1.ebuild 1395 BLAKE2B c42544ea594e54bf6293bf52911f9f853a86794784892403847114be767c2860c4c653de1278a9f4e7bcc72619bdcac569bcbdff5bce755c66abdc5c51ceec89 SHA512 75968a1bc7f4f96e5fde2b045437c793ab1cf44df6c857dc6315c93a4931252a578edb898f4354d36d7dfab2d027b0edf8a4bb82996e5c16c4687a784b4def90
EBUILD rich-13.3.2.ebuild 1409 BLAKE2B c61286fb5f7abe780dae8b7333935b22323fd0333eb4ee4d4524a859066548f93cd8a767d578c74ff7e533125e426115b56589d4ad0d8c4809b299508a963833 SHA512 d7a7ef1a51747775b944735ab0af8e5c7912fdb92c05dd2d286db52b1a49dd2c0f87e5cd30f7fce2ec597110200faf8dc24b8342ab28d37b08acf721cfa251e6
+EBUILD rich-13.3.3.ebuild 1409 BLAKE2B c61286fb5f7abe780dae8b7333935b22323fd0333eb4ee4d4524a859066548f93cd8a767d578c74ff7e533125e426115b56589d4ad0d8c4809b299508a963833 SHA512 d7a7ef1a51747775b944735ab0af8e5c7912fdb92c05dd2d286db52b1a49dd2c0f87e5cd30f7fce2ec597110200faf8dc24b8342ab28d37b08acf721cfa251e6
MISC metadata.xml 387 BLAKE2B 049491e034ba233f33c76dc5e3f1b887ba5d2da9d65b09bda51a7cf4eb30a9c66f3ddf714f52407a73e51da78523084064bccd4fc687e0bc0fc2b32dbb4c513b SHA512 448ce879331748e3166f670981a27ee5c3ef20b51af442ccc684cb6514c0d6a0d4e433a8bc1ddb3bdf68c734bac013c1ba04d38adf90644b062231ab1c1d2c0b
diff --git a/dev-python/rich/rich-13.3.3.ebuild b/dev-python/rich/rich-13.3.3.ebuild
new file mode 100644
index 000000000000..dcd6ae234066
--- /dev/null
+++ b/dev-python/rich/rich-13.3.3.ebuild
@@ -0,0 +1,52 @@
+# Copyright 2022-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=poetry
+PYTHON_COMPAT=( python3_{9..11} pypy3 )
+
+inherit distutils-r1 optfeature
+
+DESCRIPTION="Python library for rendering rich text, tables, etc. to the terminal"
+HOMEPAGE="
+ https://github.com/Textualize/rich/
+ https://pypi.org/project/rich/
+"
+SRC_URI="
+ https://github.com/Textualize/rich/archive/v${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
+
+RDEPEND="
+ dev-python/colorama[${PYTHON_USEDEP}]
+ <dev-python/markdown-it-py-3[${PYTHON_USEDEP}]
+ >=dev-python/markdown-it-py-2.2.0[${PYTHON_USEDEP}]
+ >=dev-python/pygments-2.13.0[${PYTHON_USEDEP}]
+ $(python_gen_cond_dep '
+ dev-python/typing-extensions[${PYTHON_USEDEP}]
+ ' 3.8)
+"
+
+distutils_enable_tests pytest
+
+python_test() {
+ local -x COLUMNS=80
+ local EPYTEST_DESELECT=(
+ # TODO
+ tests/test_console.py::test_size_can_fall_back_to_std_descriptors
+ tests/test_inspect.py::test_inspect_integer_with_methods_python38_and_python39
+ # pygments?
+ tests/test_syntax.py::test_python_render_simple_indent_guides
+ tests/test_syntax.py::test_python_render_line_range_indent_guides
+ )
+ epytest -p no:pytest-qt
+}
+
+pkg_postinst() {
+ optfeature "integration with HTML widgets for Jupyter" dev-python/ipywidgets
+}