summaryrefslogtreecommitdiff
path: root/dev-python/riak-python-client
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 20:57:42 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 20:57:42 +0100
commit1798c4aeca70ac8d0a243684d6a798fbc65735f8 (patch)
treee48e19cb6fa03de18e1c63e1a93371b7ebc4eb56 /dev-python/riak-python-client
parentd87262dd706fec50cd150aab3e93883b6337466d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'dev-python/riak-python-client')
-rw-r--r--dev-python/riak-python-client/Manifest3
-rw-r--r--dev-python/riak-python-client/metadata.xml11
-rw-r--r--dev-python/riak-python-client/riak-python-client-2.7.0-r1.ebuild39
3 files changed, 0 insertions, 53 deletions
diff --git a/dev-python/riak-python-client/Manifest b/dev-python/riak-python-client/Manifest
deleted file mode 100644
index 5df357a45c98..000000000000
--- a/dev-python/riak-python-client/Manifest
+++ /dev/null
@@ -1,3 +0,0 @@
-DIST riak-python-client-2.7.0.tar.gz 194141 BLAKE2B ae94f64ea71d253885053ea8207bc1b2a51433d2293f76bb172f5f85529c1d9196663ad3f760a58f3742158c8d0b32076c3aa32734e1bc228af22619662f54e9 SHA512 d63d031fb4b3598176480a3f1419158437ea814b46623a9a69e9105ced4172a1609d731bd163dd258c9301fa3b3c406a81f4c1068460b0ea397046fa6a1863e8
-EBUILD riak-python-client-2.7.0-r1.ebuild 927 BLAKE2B 8cff37f25b64bcda6c17e6f0347b245d1fadf7cdba48bef9f5b215533525c1d27a9e98875196ff7411fa27b69ceecbfec4d0b58d00cc07d0052c784a98265c9b SHA512 ff9c3d18ff58b6337d4b83222041107e8d2c4ced5fd46384bd8d4431fd493efe28d1ec534222cec8196b9597aaf52a7a669d0143977c6ae136555d0538af5368
-MISC metadata.xml 349 BLAKE2B caffd4d446589b6b2ab2ba81f9eda1313d9138d8cb2a8ee33a21d3a43d9db251bd3d6c7fc7935174663be8a27d2557b94c169317bf34043cecee86e141414add SHA512 613f92f27e8ac63fca2634eb9b058a30c26da6ba8751043ac3d107b5bf7bcf6d9af7d6b9bcf95a8a32158b5bcd0d32fef8ad43ee6d03656f94ee067411c48043
diff --git a/dev-python/riak-python-client/metadata.xml b/dev-python/riak-python-client/metadata.xml
deleted file mode 100644
index 6a8aecae126a..000000000000
--- a/dev-python/riak-python-client/metadata.xml
+++ /dev/null
@@ -1,11 +0,0 @@
-<?xml version="1.0" encoding="UTF-8"?>
-<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
-<pkgmetadata>
- <upstream>
- <remote-id type="pypi">riak</remote-id>
- <remote-id type="github">basho/riak-python-client</remote-id>
- </upstream>
- <maintainer type="person">
- <email>zmedico@gentoo.org</email>
- </maintainer>
-</pkgmetadata>
diff --git a/dev-python/riak-python-client/riak-python-client-2.7.0-r1.ebuild b/dev-python/riak-python-client/riak-python-client-2.7.0-r1.ebuild
deleted file mode 100644
index 1ddd41aaf6e5..000000000000
--- a/dev-python/riak-python-client/riak-python-client-2.7.0-r1.ebuild
+++ /dev/null
@@ -1,39 +0,0 @@
-# Copyright 1999-2017 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-PYTHON_COMPAT=( python2_7 python3_{4,5,6} )
-
-inherit distutils-r1
-
-DESCRIPTION="The Riak client for Python."
-HOMEPAGE="https://github.com/basho/riak-python-client/"
-MY_PN=${PN%%-*}
-MY_P=${MY_PN}-${PV}
-SRC_URI="mirror://pypi/${MY_PN:0:1}/${MY_PN}/${MY_P}.tar.gz -> ${P}.tar.gz"
-
-LICENSE="Apache-2.0"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-IUSE=""
-
-RDEPEND="dev-python/basho-erlastic[${PYTHON_USEDEP}]
- dev-python/protobuf-python[${PYTHON_USEDEP}]
- >=dev-python/six-1.8[${PYTHON_USEDEP}]"
-DEPEND="${RDEPEND}
- dev-python/setuptools[${PYTHON_USEDEP}]"
-
-S=${WORKDIR}/${MY_P}
-
-src_prepare() {
- default
- # delete protobuf requirements that only work for pip
- sed '17,22d' -i setup.py || die
- sed -e "s:'\\\\n\\\\027:b\\0:" \
- -e "s:serialized_pb=:\\0b:" \
- -i riak/pb/*.py || die
-}
-
-python_test() {
- esetup.py test || die
-}