summaryrefslogtreecommitdiff
path: root/dev-python/rfc3987
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /dev-python/rfc3987
reinit the tree, so we can have metadata
Diffstat (limited to 'dev-python/rfc3987')
-rw-r--r--dev-python/rfc3987/Manifest4
-rw-r--r--dev-python/rfc3987/metadata.xml17
-rw-r--r--dev-python/rfc3987/rfc3987-1.3.7.ebuild27
3 files changed, 48 insertions, 0 deletions
diff --git a/dev-python/rfc3987/Manifest b/dev-python/rfc3987/Manifest
new file mode 100644
index 000000000000..3f2084e6c7f8
--- /dev/null
+++ b/dev-python/rfc3987/Manifest
@@ -0,0 +1,4 @@
+DIST rfc3987-1.3.7.tar.gz 20701 SHA256 91a7826b0a26c246a5a91bef09c2c0809c713a689be689b9571e78a13f6557a4 SHA512 c5fa8eb36358f7f42d12adc305031bfff7bd77e83316ad4458ed07acc6094c7d9109b95848b9296dcbc6677ce34aa59b1be8fd57dfcdc6be47eb92aeda51c518 WHIRLPOOL 5c4051d3192edb8124e0350c9cd489f74ec88929f1447c533a5ba6f3105fa937b9b789776a43e762ae4373a83cf92a114bd7f54d970bda2fe72b3ed61c724c1a
+EBUILD rfc3987-1.3.7.ebuild 784 SHA256 43f34471f1f1f54d8c2adaf913ecf87d5a1807566b03c067b5dc2aee9e3fb59a SHA512 b3f6fad4e446f6c4bb1be2ff85ce992d6b9c352101edcceaca6a74482bd125c5e9bfbe0288df7dcd51c407302ed0ecac79002569a49117f42b674f92e42df96c WHIRLPOOL 5e3e6e95895c935cf0285e7b4118109a04bd9841942c5ce653ad22462be67bfa4426941b4f1392be66f8717234782bfbf142e6891f3e7669391b87da87ce4e55
+MISC ChangeLog 933 SHA256 b9e4ff4d24d82d8108b893930ac5378b289d4ce6d5582d98a81ec36a6010ac05 SHA512 5c0a551af59112c3be583b5bc438d1ff22f9cfcac318504aef88fbba64bc24ba98429c41369ae7729de7e95b032d3c87e67db0b21801c4747898b4cc2fb66b86 WHIRLPOOL 9e5b37ee73f4396e4e84d0329506bdebfc549ddab3ef722014dbff6b9299d0537527c0d6f1b0f9ca41e06da11553e9131f56c18407254e9ea655e6d637828660
+MISC metadata.xml 571 SHA256 f10d8fde42286646139b0a1e144d2deb9c0f0e58f3ab56c73e5e25cdc9e12014 SHA512 2ced33f8245fc320ca1795072d9e63b5cc910b90f368306112316dcb444ee24f292e39ff76dfb027edcaf2c7a6dbfa636414ab8f9cfe777b0a2aeed17143e8c0 WHIRLPOOL 5c817ff5a38a933f7634c0e78eb59b96e45ff5e3c60f7e2ff6d4f51dd8ce2d1a98371cc38d05c9691bbdd7cc386717d2149021d7e3867c69964b3927e100725d
diff --git a/dev-python/rfc3987/metadata.xml b/dev-python/rfc3987/metadata.xml
new file mode 100644
index 000000000000..ed37dd5132a7
--- /dev/null
+++ b/dev-python/rfc3987/metadata.xml
@@ -0,0 +1,17 @@
+<?xml version='1.0' encoding='UTF-8'?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>aballier@gentoo.org</email>
+ <name>Alexis Ballier</name>
+ <description>Python team can take the package if they wish.</description>
+ </maintainer>
+ <maintainer type="project">
+ <email>python@gentoo.org</email>
+ <name>Python</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="pypi">rfc3987</remote-id>
+ <remote-id type="github">dgerber/rfc3987</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-python/rfc3987/rfc3987-1.3.7.ebuild b/dev-python/rfc3987/rfc3987-1.3.7.ebuild
new file mode 100644
index 000000000000..6697e1a9c082
--- /dev/null
+++ b/dev-python/rfc3987/rfc3987-1.3.7.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+PYTHON_COMPAT=( python2_7 python3_{4,5,6} pypy pypy3 )
+
+inherit distutils-r1
+
+DESCRIPTION="Parsing and validation of URIs (RFC 3986) and IRIs (RFC 3987)"
+HOMEPAGE="https://github.com/dgerber/rfc3987 https://pypi.python.org/pypi/rfc3987"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~alpha amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ppc ppc64 ~s390 ~sh ~sparc x86 ~amd64-linux ~x86-linux"
+IUSE=""
+
+RDEPEND="$(python_gen_cond_dep \
+ 'dev-python/regex[${PYTHON_USEDEP}]' python2_7 'python3*' pypy)"
+DEPEND="${RDEPEND}
+ dev-python/setuptools[${PYTHON_USEDEP}]
+"
+
+python_test() {
+ ${EPYTHON} -m doctest -v "${S}/${PN}.py" || die
+}