summaryrefslogtreecommitdiff
path: root/dev-python/rfc3986
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2021-05-11 19:55:43 +0100
committerV3n3RiX <venerix@redcorelinux.org>2021-05-11 19:55:43 +0100
commit185fa19bbf68a4d4dca534d2b46729207a177f16 (patch)
treea8a537b82fda83a0799c2ca9887f212558363aa7 /dev-python/rfc3986
parentc8fd0d84af0bfd1949542adc2cbb735b1d28f9ed (diff)
gentoo resync : 11.05.2021
Diffstat (limited to 'dev-python/rfc3986')
-rw-r--r--dev-python/rfc3986/Manifest4
-rw-r--r--dev-python/rfc3986/rfc3986-1.4.0.ebuild4
-rw-r--r--dev-python/rfc3986/rfc3986-1.5.0.ebuild27
3 files changed, 32 insertions, 3 deletions
diff --git a/dev-python/rfc3986/Manifest b/dev-python/rfc3986/Manifest
index e5d564083646..064cd895b932 100644
--- a/dev-python/rfc3986/Manifest
+++ b/dev-python/rfc3986/Manifest
@@ -1,3 +1,5 @@
DIST rfc3986-1.4.0.tar.gz 44912 BLAKE2B 595a644f8f92823ad31113ce88218cb30d16b37ec7303c0d8e89d2d2b1e18448d99003e95d61dcf09cb64aae517037bae798d1e89c74b652d517a648e80856e8 SHA512 dbcddc09331b794eafed8c2d7b81b7b632ba5cae2741e33ad12e781bc923427a05febd2f2715d037f35769b18c8d790546dfd4bbebe6e71d35777745e446888b
-EBUILD rfc3986-1.4.0.ebuild 675 BLAKE2B 7c5099ce6955087e43054c0fada62e231bebcea47e62c2bcdaf7885a642cdcc266cb2554e19caf03fbdde6f4d0da08abfafbdd58d85c78ca592ce7e270ea0d89 SHA512 829de39363cb92621b2213f532a373deca6d95b0716ad08666e1802b5aa6f51f9d16db7c27648e5dfea17dcddcd0923393ff84a7442ec57272114e4db09aba41
+DIST rfc3986-1.5.0.tar.gz 49378 BLAKE2B f5ef923626fdcbe4d13729a5599012a8a93d234eef7f9ac9dc61620320062a69646f810a8f0ea04f371b9c423850982685e68201f08ba96ad9ead3ab11a9b40d SHA512 b291b88b6890f8c9fcfc353e05d1b8c0435be62f22768568ecf714af083b3c51d7a9b301fc9196d37ad4e6eeb8c6a237ba40914098e755b4ccdf36b7df7906c2
+EBUILD rfc3986-1.4.0.ebuild 676 BLAKE2B daf4a3ec5f79890d8aca2a3d51771516ce3d1140b17b5c39106374dc0ddcb1c876b4380078e9d12bcd9c12f821db6dd1bc10aa1ca25b33ac962b101bbc9e3ea1 SHA512 53d5ab9961f21fe91cd5091353d1a0f1969c79d8538a5bf917fd08d1bdcda5e0605dc707878419921cdbd80da3fad927466dcd20a3333f425c05f5754cd5498a
+EBUILD rfc3986-1.5.0.ebuild 683 BLAKE2B 973d77a0b6e68718dc4fe5cb62ef7378d05d15378b8f375ad4def5df862a9b3092f45b930eed9ae386a1921e0d145192392c688586bc463b6ecdd16ade58e223 SHA512 f3de983ef343c133525c1299d45304ca396f38444dc20c140d19c7b5c63223deea6b29ae58a196d84c95b83ef333530aeff7ad1d94b51a67fc3a62542a8c487f
MISC metadata.xml 740 BLAKE2B ad52fb6e822fe4ab8e910af9f4896079209f0704c649d240464eb283c9796f5bead9303b7bb02f5db5049b9afa430bd190871c1bc391a21647eceb0d353c02c0 SHA512 3b74fb8b21300169b3d9da6c8a14bcd950d277c56ea242a73fc56637d853cba64de931567b19c0cd8b9acd6f7b8e486fb9e1ce0716b1c291669e6588caf6611c
diff --git a/dev-python/rfc3986/rfc3986-1.4.0.ebuild b/dev-python/rfc3986/rfc3986-1.4.0.ebuild
index f168d7d7db1f..f57899e0bdd3 100644
--- a/dev-python/rfc3986/rfc3986-1.4.0.ebuild
+++ b/dev-python/rfc3986/rfc3986-1.4.0.ebuild
@@ -1,8 +1,8 @@
-# Copyright 1999-2020 Gentoo Authors
+# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
-PYTHON_COMPAT=( python3_{7..9} pypy3)
+PYTHON_COMPAT=( python3_{7..10} pypy3)
inherit distutils-r1
diff --git a/dev-python/rfc3986/rfc3986-1.5.0.ebuild b/dev-python/rfc3986/rfc3986-1.5.0.ebuild
new file mode 100644
index 000000000000..0ce7eca0ae96
--- /dev/null
+++ b/dev-python/rfc3986/rfc3986-1.5.0.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+PYTHON_COMPAT=( python3_{7..9} pypy3)
+
+inherit distutils-r1
+
+DESCRIPTION="Validating URI References per RFC 3986"
+HOMEPAGE="https://tools.ietf.org/html/rfc3986
+ https://github.com/python-hyper/rfc3986
+ https://rfc3986.rtfd.org"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sparc ~x86 ~x64-macos"
+IUSE="idna"
+
+RDEPEND="
+ idna? ( dev-python/idna[${PYTHON_USEDEP}] )
+"
+BDEPEND="
+ test? ( dev-python/idna[${PYTHON_USEDEP}] )
+"
+
+distutils_enable_tests pytest