summaryrefslogtreecommitdiff
path: root/dev-python/rfc3986-validator/rfc3986-validator-0.1.1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2021-06-15 14:57:03 +0100
committerV3n3RiX <venerix@redcorelinux.org>2021-06-15 14:57:03 +0100
commitd18bf1e01b65ee4bf0c804e2843b282d3d4e5d7c (patch)
tree4a95cbc6ffdf13bad6ecbc7f8d5af99631984123 /dev-python/rfc3986-validator/rfc3986-validator-0.1.1.ebuild
parente748ba9741f6540f4675c23e3e37b73e822c13a4 (diff)
gentoo resync : 15.06.2021
Diffstat (limited to 'dev-python/rfc3986-validator/rfc3986-validator-0.1.1.ebuild')
-rw-r--r--dev-python/rfc3986-validator/rfc3986-validator-0.1.1.ebuild5
1 files changed, 2 insertions, 3 deletions
diff --git a/dev-python/rfc3986-validator/rfc3986-validator-0.1.1.ebuild b/dev-python/rfc3986-validator/rfc3986-validator-0.1.1.ebuild
index 7e4e0d71a72f..e3f747530485 100644
--- a/dev-python/rfc3986-validator/rfc3986-validator-0.1.1.ebuild
+++ b/dev-python/rfc3986-validator/rfc3986-validator-0.1.1.ebuild
@@ -2,7 +2,7 @@
# Distributed under the terms of the GNU General Public License v2
EAPI=7
-PYTHON_COMPAT=( python3_{7..9} )
+PYTHON_COMPAT=( python3_{8..10} )
inherit distutils-r1
@@ -14,6 +14,7 @@ MY_P="${MY_PN}-${PV}"
DESCRIPTION="Pure python RFC3986 validator"
HOMEPAGE="https://pypi.org/project/rfc3986-validator/ https://github.com/naimetti/rfc3986-validator"
SRC_URI="mirror://pypi/${MY_PN:0:1}/${MY_PN}/${MY_P}.tar.gz"
+S=${WORKDIR}/${MY_P}
LICENSE="MIT"
SLOT="0"
@@ -22,8 +23,6 @@ KEYWORDS="~alpha amd64 arm arm64 ~hppa ~ia64 ~mips ppc ppc64 ~s390 sparc x86"
RDEPEND="dev-python/rfc3987[${PYTHON_USEDEP}]"
BDEPEND="test? ( dev-python/hypothesis[${PYTHON_USEDEP}] )"
-S="${WORKDIR}/${MY_P}"
-
distutils_enable_tests pytest
python_prepare_all() {