summaryrefslogtreecommitdiff
path: root/dev-python/respx
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2024-03-29 19:13:18 +0000
committerV3n3RiX <venerix@koprulu.sector>2024-03-29 19:13:18 +0000
commit62090949b4fde34bbcbb4bd770a9635c6ac0c55e (patch)
tree2af5001a82f05c858f1e80e2231929c173a8bb55 /dev-python/respx
parent04a447f4f2679e9687093f49d8a9ea911fac9a9b (diff)
gentoo auto-resync : 29:03:2024 - 19:13:18
Diffstat (limited to 'dev-python/respx')
-rw-r--r--dev-python/respx/Manifest3
-rw-r--r--dev-python/respx/metadata.xml20
-rw-r--r--dev-python/respx/respx-0.21.1.ebuild43
3 files changed, 66 insertions, 0 deletions
diff --git a/dev-python/respx/Manifest b/dev-python/respx/Manifest
new file mode 100644
index 000000000000..00f41cb05d63
--- /dev/null
+++ b/dev-python/respx/Manifest
@@ -0,0 +1,3 @@
+DIST respx-0.21.1.gh.tar.gz 432341 BLAKE2B b375e8bc9370e13855197487e1e8139cf3fede0f03d7ad034ef2c78bce5ad95d3cb8cc7440c2566d188a98a52d0068c13288c7d4ec802e04d2f269a64e1ce326 SHA512 156f34f4635012230b68812f24978136f37f96dc0cf0ea9e80ed2d6a3e0639eb7591ed34933f75d5cda32993852aa034b22389af0fed341ab4ad1002482f2e9c
+EBUILD respx-0.21.1.ebuild 869 BLAKE2B d1f8742231293c814f2bfc209aaf573c9b945533d07f23cb9ea5ea10b9c545598502b9f73c83fe1a18148750c5bbf0e81e7234c547b88b388047e27c5db5f9a8 SHA512 6a2cf2c5a10eb68858f11c6895b3ea711aa4d377e602d2215adf99bf523b4df12c40b0415f8cc30193fb2ffd67ea05bf600afd7759723a76605a95905bce5070
+MISC metadata.xml 610 BLAKE2B 3e77efa934fcb00a190e062741e0233a1c9f99619c612efa02e797f133661523b408fec5bda914a6180808370faec6e8928c2c77aa71ed9d4124b8933f7a62e8 SHA512 9fdc4f2a5f0fd9e6095123729fc030ed2baeafd975094a0fc24baae33dcddc08cd59f8ece99196a0fb64a2cad4bbf898a4817a0126d08e3d2b5309fc13d9ca7e
diff --git a/dev-python/respx/metadata.xml b/dev-python/respx/metadata.xml
new file mode 100644
index 000000000000..75a5ff3e72ad
--- /dev/null
+++ b/dev-python/respx/metadata.xml
@@ -0,0 +1,20 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>python@gentoo.org</email>
+ </maintainer>
+ <maintainer type="person">
+ <email>parona@protonmail.com</email>
+ <name>Alfred Wingate</name>
+ </maintainer>
+ <maintainer type="project" proxied="proxy">
+ <email>proxy-maint@gentoo.org</email>
+ <name>Proxy Maintainers</name>
+ </maintainer>
+ <stabilize-allarches/>
+ <upstream>
+ <remote-id type="pypi">respx</remote-id>
+ <remote-id type="github">lundberg/respx</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-python/respx/respx-0.21.1.ebuild b/dev-python/respx/respx-0.21.1.ebuild
new file mode 100644
index 000000000000..398d107c282b
--- /dev/null
+++ b/dev-python/respx/respx-0.21.1.ebuild
@@ -0,0 +1,43 @@
+# Copyright 2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{11..12} )
+
+inherit distutils-r1
+
+DESCRIPTION="Mock HTTPX with awesome request patterns and response side effects"
+HOMEPAGE="
+ https://lundberg.github.io/respx/
+ https://pypi.org/project/respx/
+ https://github.com/lundberg/respx/
+"
+# no tests in pypi sdist
+SRC_URI="
+ https://github.com/lundberg/respx/archive/refs/tags/${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64"
+
+RDEPEND="
+ dev-python/httpx[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ dev-python/flask[${PYTHON_USEDEP}]
+ dev-python/httpcore[${PYTHON_USEDEP}]
+ dev-python/starlette[${PYTHON_USEDEP}]
+ dev-python/trio[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+python_test() {
+ epytest -p 'no:*' -o addopts=
+}