summaryrefslogtreecommitdiff
path: root/dev-python/resolvelib
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2021-06-15 14:57:03 +0100
committerV3n3RiX <venerix@redcorelinux.org>2021-06-15 14:57:03 +0100
commitd18bf1e01b65ee4bf0c804e2843b282d3d4e5d7c (patch)
tree4a95cbc6ffdf13bad6ecbc7f8d5af99631984123 /dev-python/resolvelib
parente748ba9741f6540f4675c23e3e37b73e822c13a4 (diff)
gentoo resync : 15.06.2021
Diffstat (limited to 'dev-python/resolvelib')
-rw-r--r--dev-python/resolvelib/Manifest3
-rw-r--r--dev-python/resolvelib/metadata.xml19
-rw-r--r--dev-python/resolvelib/resolvelib-0.7.0.ebuild20
3 files changed, 42 insertions, 0 deletions
diff --git a/dev-python/resolvelib/Manifest b/dev-python/resolvelib/Manifest
new file mode 100644
index 000000000000..ca3cb06e1936
--- /dev/null
+++ b/dev-python/resolvelib/Manifest
@@ -0,0 +1,3 @@
+DIST resolvelib-0.7.0.tar.gz 16439 BLAKE2B 5e48f3b5618b84498ec5646e4ef502c9cf1ba6ec720ea450064983d26c8890a6399839261f92a471bb5f235c6c7d976bd7a1c0e2ccc29ba51c0fdb740ce607a6 SHA512 4cfc4ca58c3308209b4fc5c96e8e379a3ec897943493478cdd5b63a6edc21c7c416877eb3ce12954be98131e5f37a9727d753347414790c625284a8e9dc393ea
+EBUILD resolvelib-0.7.0.ebuild 514 BLAKE2B ddc301b7c8b2e4f0a8a6b9ffa5fd6491fffffa7a156f98968c560e4b86c044c4c07b75c3cd61eb5f088987d1e0255dd40edf07ca76db86b619cc311590be75a4 SHA512 6cc501ae8d9dc932dd90fa6da5e45f2395291c525b7f4df7ba9c6b9042d4a10dbe0e7c28150abb745508819318b6bedcc937cf50a4813589290ff2c9593b364c
+MISC metadata.xml 746 BLAKE2B 0a3ef5d793c24d91afe9bdbfb7337ebd1653d4d7e281197f66eaac8b934bbceab74e54964feddd2a1d63c56b9c65d19634828cc26bd1be23f533965d646f8db0 SHA512 9062907f4295661308d4a7754aa430ea8f4a1e850d29efe62653615ee91deb4c2cb65c246b16b1032da119e78717684c88aeabd812fc20b2297283ed076e5f0a
diff --git a/dev-python/resolvelib/metadata.xml b/dev-python/resolvelib/metadata.xml
new file mode 100644
index 000000000000..f7e853ec0571
--- /dev/null
+++ b/dev-python/resolvelib/metadata.xml
@@ -0,0 +1,19 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>prometheanfire@gentoo.org</email>
+ <name>Matthew Thode</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="pypi">resolvelib</remote-id>
+ <remote-id type="github">sarugaku/resolvelib</remote-id>
+ <bugs-to>https://github.com/sarugaku/resolvelib/issues</bugs-to>
+ </upstream>
+ <longdescription lang="en">
+ResolveLib at the highest level provides a Resolver class that includes
+dependency resolution logic. You give it some things, and a little
+information on how it should interact with them, and it will spit out
+a resolution result.
+</longdescription>
+</pkgmetadata>
diff --git a/dev-python/resolvelib/resolvelib-0.7.0.ebuild b/dev-python/resolvelib/resolvelib-0.7.0.ebuild
new file mode 100644
index 000000000000..2535428a3c16
--- /dev/null
+++ b/dev-python/resolvelib/resolvelib-0.7.0.ebuild
@@ -0,0 +1,20 @@
+# Copyright 2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_7 python3_8 python3_9 )
+DISTUTILS_USE_SETUPTOOLS=bdepend
+inherit distutils-r1
+
+DESCRIPTION="provides a Resolver class that includes dependency resolution logic"
+HOMEPAGE="https://github.com/sarugaku/resolvelib"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="ISC"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc64 ~x86 ~x64-macos"
+
+DEPEND=""
+RDEPEND="${DEPEND}"
+BDEPEND=""