summaryrefslogtreecommitdiff
path: root/dev-python/resolvelib/resolvelib-0.7.1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2021-06-29 10:15:54 +0100
committerV3n3RiX <venerix@redcorelinux.org>2021-06-29 10:15:54 +0100
commit9aa80713372911cec499b3adb2cd746790920916 (patch)
treeb8e99dc5dd60ac2094a27cc52f74aada8df38f05 /dev-python/resolvelib/resolvelib-0.7.1.ebuild
parentb4d43e8c611df4a8061b6f88d9e9f6b1e3c83903 (diff)
gentoo resync : 29.06.2021
Diffstat (limited to 'dev-python/resolvelib/resolvelib-0.7.1.ebuild')
-rw-r--r--dev-python/resolvelib/resolvelib-0.7.1.ebuild25
1 files changed, 25 insertions, 0 deletions
diff --git a/dev-python/resolvelib/resolvelib-0.7.1.ebuild b/dev-python/resolvelib/resolvelib-0.7.1.ebuild
new file mode 100644
index 000000000000..c9746c36a67b
--- /dev/null
+++ b/dev-python/resolvelib/resolvelib-0.7.1.ebuild
@@ -0,0 +1,25 @@
+# Copyright 2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{8..9} )
+inherit distutils-r1
+
+DESCRIPTION="provides a Resolver class that includes dependency resolution logic"
+HOMEPAGE="https://github.com/sarugaku/resolvelib/"
+SRC_URI="
+ https://github.com/sarugaku/resolvelib/archive/${PV}.tar.gz
+ -> ${P}.gh.tar.gz"
+
+LICENSE="ISC"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+BDEPEND="
+ test? (
+ dev-python/commentjson[${PYTHON_USEDEP}]
+ dev-python/packaging[${PYTHON_USEDEP}]
+ )"
+
+distutils_enable_tests pytest