summaryrefslogtreecommitdiff
path: root/dev-python/requests_download
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2019-12-15 18:09:03 +0000
committerV3n3RiX <venerix@redcorelinux.org>2019-12-15 18:09:03 +0000
commit7bc9c63c9da678a7e6fceb095d56c634afd22c56 (patch)
tree4a67d50a439e9af63947e5f8b6ba3719af98b6c9 /dev-python/requests_download
parentb284a3168fa91a038925d2ecf5e4791011ea5e7d (diff)
gentoo resync : 15.12.2019
Diffstat (limited to 'dev-python/requests_download')
-rw-r--r--dev-python/requests_download/Manifest3
-rw-r--r--dev-python/requests_download/metadata.xml12
-rw-r--r--dev-python/requests_download/requests_download-0.1.2.ebuild30
3 files changed, 45 insertions, 0 deletions
diff --git a/dev-python/requests_download/Manifest b/dev-python/requests_download/Manifest
new file mode 100644
index 000000000000..7077928da80b
--- /dev/null
+++ b/dev-python/requests_download/Manifest
@@ -0,0 +1,3 @@
+DIST requests_download-0.1.2.tar.gz 2584 BLAKE2B c6f2eb7a182e0f42ccb7b603dec47a077b1b946bfa93968972dce5267c7c51fa8c4158e15cd35621cbe229e12f6644db9734e52439796d8d8411be16a38e1e9a SHA512 99d4b275200c88befd2730d17a3329c8cbb155fa5cf9600a7466e8ab109f999a9fc9b8c668aa3b389bc2a3deb33b8a3fd390270d71f04bb0a8f998da67cfde82
+EBUILD requests_download-0.1.2.ebuild 823 BLAKE2B ff681fd7e8080cbb641ee57e6091fe9c73597b51103c3dbcf7f762f11afa5f453733ac0c8183bf6366be3208cf24ee59c37e405fcf4d47abd2041ec115347be1 SHA512 8af5d5204729443b13586fd2c7c0eb45d759708760da472a35919646eaf7eb69e5e8bcca1ab8e97c153b4379bf91841fa24e71a8f4eb7aace4b8b7133b76f468
+MISC metadata.xml 408 BLAKE2B 2fa0562549efb76db2df8bf0485bf3fcd123de81dd29b89ea9d2a0b87dc72db068e577e4cebfc36c2569b2a4057d14ad26490b368770ec0e566cdb549b2fb308 SHA512 2fdfa8da4f76fd449807c41fd535356f388f71dbc8793a59b7bf2b04c9be3096900decdb014389097a43565642906114169163ab8d19dcd69901457dad3d9f6c
diff --git a/dev-python/requests_download/metadata.xml b/dev-python/requests_download/metadata.xml
new file mode 100644
index 000000000000..2d3a29feeb4c
--- /dev/null
+++ b/dev-python/requests_download/metadata.xml
@@ -0,0 +1,12 @@
+<?xml version='1.0' encoding='UTF-8'?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>chutzpah@gentoo.org</email>
+ <name>Patrick McLean</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="pypi">requests_download</remote-id>
+ <remote-id type="github">takluyver/requests_download</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-python/requests_download/requests_download-0.1.2.ebuild b/dev-python/requests_download/requests_download-0.1.2.ebuild
new file mode 100644
index 000000000000..231d3877ce3c
--- /dev/null
+++ b/dev-python/requests_download/requests_download-0.1.2.ebuild
@@ -0,0 +1,30 @@
+# Copyright 2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+PYTHON_COMPAT=( python2_7 python3_{5,6,7,8} pypy{,3} )
+
+inherit distutils-r1
+
+DESCRIPTION="A convenient function to download to a file using requests"
+HOMEPAGE="https://github.com/takluyver/requests_download https://pypi.org/project/requests_download/"
+SRC_URI="https://github.com/takluyver/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="dev-python/requests[${PYTHON_USEDEP}]"
+BDEPEND="${RDEPEND}"
+
+# there are no tests upstream
+RESTRICT="test"
+
+DOCS=( README.rst )
+
+python_prepare_all() {
+ printf -- "from setuptools import setup\nsetup(name='%s',version='%s',py_modules=['%s'])" \
+ "${PN}" "${PV}" "${PN}" > setup.py || die
+
+ distutils-r1_python_prepare_all
+}