summaryrefslogtreecommitdiff
path: root/dev-python/requests_download
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-06-29 12:04:12 +0100
committerV3n3RiX <venerix@koprulu.sector>2022-06-29 12:04:12 +0100
commit0f558761aa2dee1017b4751e4017205e015a9560 (patch)
tree037df795519468a25d9362b4e95cdaeb84eb1cf9 /dev-python/requests_download
parent752d6256e5204b958b0ef7905675a940b5e9172f (diff)
gentoo resync : 29.12.2022
Diffstat (limited to 'dev-python/requests_download')
-rw-r--r--dev-python/requests_download/Manifest1
-rw-r--r--dev-python/requests_download/requests_download-0.1.2-r1.ebuild25
2 files changed, 26 insertions, 0 deletions
diff --git a/dev-python/requests_download/Manifest b/dev-python/requests_download/Manifest
index 2f44c68b2200..510164266872 100644
--- a/dev-python/requests_download/Manifest
+++ b/dev-python/requests_download/Manifest
@@ -1,3 +1,4 @@
DIST requests_download-0.1.2.tar.gz 2584 BLAKE2B c6f2eb7a182e0f42ccb7b603dec47a077b1b946bfa93968972dce5267c7c51fa8c4158e15cd35621cbe229e12f6644db9734e52439796d8d8411be16a38e1e9a SHA512 99d4b275200c88befd2730d17a3329c8cbb155fa5cf9600a7466e8ab109f999a9fc9b8c668aa3b389bc2a3deb33b8a3fd390270d71f04bb0a8f998da67cfde82
+EBUILD requests_download-0.1.2-r1.ebuild 649 BLAKE2B aa43af6ae7a386f425923f964ec8442b8127172bb19ee60b49e4876c3cc0afac1a0dc306b23fa83022cc3a76124041753b7ffad05adc2037bdc7850a9e54d024 SHA512 82c8fbf9e55d86728e97ca27e2cca1272fb150dcd9ab31f71964a3ed6e79a500e36ee9abef272e4dfa63058c4dccca761e0fb31be59825ad4c5b3039ddadce62
EBUILD requests_download-0.1.2.ebuild 818 BLAKE2B 8796df05fc86245accc7895b49cda1fcb1bf715ee3117965a1dd2475869c77347f1077b03006614c9b6d2b4f491cdf2497b7034c6b5424de6c30faa5b025e1b0 SHA512 8bad3ae0fbaf9850ab6f97709a6df6041252cbe553ac0fb0c0f4c2a10a04cd7122e4f2ac9c1fce09d50543d290ddd08e57bba55159b4735473df7f7d523766fe
MISC metadata.xml 434 BLAKE2B 55a4f9a132c3c50d9a9852e73dd24ff70517c9be1a2c4c7e84f04fbfd6a24aa250e165db5bff5959fa2e5a88f063f080a16c2b47e061d6d501b67dd0860714d4 SHA512 f7950fc65c69c3376caf4e7865e9517d75e7df1b054748d6ca4850707ec7c5fb7124dc2057f8131c20cbc9e2f1d7198fe2d25879250b0cf99d8ed7fd6dbc1fc5
diff --git a/dev-python/requests_download/requests_download-0.1.2-r1.ebuild b/dev-python/requests_download/requests_download-0.1.2-r1.ebuild
new file mode 100644
index 000000000000..b9bb4886b279
--- /dev/null
+++ b/dev-python/requests_download/requests_download-0.1.2-r1.ebuild
@@ -0,0 +1,25 @@
+# Copyright 2019-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=flit
+PYTHON_COMPAT=( python3_{8..11} pypy3 )
+
+inherit distutils-r1
+
+DESCRIPTION="A convenient function to download to a file using requests"
+HOMEPAGE="https://github.com/takluyver/requests_download https://pypi.org/project/requests_download/"
+SRC_URI="https://github.com/takluyver/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~mips ~x86"
+
+RDEPEND="dev-python/requests[${PYTHON_USEDEP}]"
+BDEPEND="${RDEPEND}"
+
+# there are no tests upstream
+RESTRICT="test"
+
+DOCS=( README.rst )