summaryrefslogtreecommitdiff
path: root/dev-python/requests-toolbelt
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-06-29 12:04:12 +0100
committerV3n3RiX <venerix@koprulu.sector>2022-06-29 12:04:12 +0100
commit0f558761aa2dee1017b4751e4017205e015a9560 (patch)
tree037df795519468a25d9362b4e95cdaeb84eb1cf9 /dev-python/requests-toolbelt
parent752d6256e5204b958b0ef7905675a940b5e9172f (diff)
gentoo resync : 29.12.2022
Diffstat (limited to 'dev-python/requests-toolbelt')
-rw-r--r--dev-python/requests-toolbelt/Manifest2
-rw-r--r--dev-python/requests-toolbelt/requests-toolbelt-0.9.1-r1.ebuild55
-rw-r--r--dev-python/requests-toolbelt/requests-toolbelt-0.9.1.ebuild58
3 files changed, 56 insertions, 59 deletions
diff --git a/dev-python/requests-toolbelt/Manifest b/dev-python/requests-toolbelt/Manifest
index d8c632f5c866..fc67508bb143 100644
--- a/dev-python/requests-toolbelt/Manifest
+++ b/dev-python/requests-toolbelt/Manifest
@@ -2,5 +2,5 @@ AUX requests-toolbelt-0.8.0-test-tracebacks.patch 1428 BLAKE2B 6f9645f2a456cde3a
AUX requests-toolbelt-0.9.1-py310.patch 1470 BLAKE2B 864c496f712b9667de991afe7d8db0071b15e6c546fb495c3df5aa25d354bb2873f697d5777f5e6f1a9890289bad192a5c5053d11ab71eb0967762b30c35a977 SHA512 3780eeef7835319d5696f1ac8273c682c4b2a97171b7fed889c1960e3887f1fa6eecf13d4c961a9c2aa9e02e919e885f18bfde8eeabf452e16267ff671d07703
AUX requests-toolbelt-0.9.1-tests.patch 5781 BLAKE2B ff7339a1daf0ba2df49914847000f0b8b5ff2d097a59bcb02bcb2b20a885f18223a1da1f44a99d846dcff423239108411c193da5092bbb27fdf50bf211dd59f7 SHA512 86919154164274efe8bceb42eb9fc17524d4e144a541e82bc10692da66e533220cdc7186362d77fd4f3acdc639744cdf5273c2e4e2091eb4d33c1fdc6c631ec5
DIST requests-toolbelt-0.9.1.tar.gz 207286 BLAKE2B 6123677a9abafebddf7dffde2150b2426b5132ebe0c330ff891322ecc3d69232a5b15a0c66e3e1fb4832dc04f5a636a939613fba041e499e9fbca9814f548c7e SHA512 12229928df5df71cb57bc65ef453dc0e4a2bbe190c1579811b2c2823673bd81aeba856b00000fa20b253d0f0fa4fff55ea1e750794ca3785f71c376b1df7fd93
-EBUILD requests-toolbelt-0.9.1.ebuild 1555 BLAKE2B 5028af6ad3bed8ef796f4ec5bcb6aec35d10c385c5c8a19139cb1ff541eefd5a469dd8815591d4ffc6686c52571514586eabf2ed4a1b005078a76dd5d9aca1c2 SHA512 a139183863289c597e29bdbc553821bb80cced7e2957baa006ac9c04811d74a5e3d7afa55635f572c1b8bd16e5658e62d31ff1f9317e401aa5f83359aa7d4f2e
+EBUILD requests-toolbelt-0.9.1-r1.ebuild 1441 BLAKE2B ed064f4ee21e74de5a5474fd741e6fd047d4def4f1ce3c887dfb643d965a18105c4914395d9156353218b5a9e160dbe3ad6e84f7896f64ff8ffa4cd059a7cd7b SHA512 567bb53929f4e20ee443f882510f6c53a635e648206120a15da32c345fac935bb39eb8acc36fe6ddcd9f2f78f601458e14d3b6aead926e7be293dccca63bcc3f
MISC metadata.xml 423 BLAKE2B 71af8f087b4bf8d805a70aed1dcb46128b0252f68a1e892530c5393bc6666c8d203e147558214935803a34b5be32bc90f6bb3fa103af4406c0fe6d974acbd739 SHA512 1c875ab992aa1d463fdd52468597f5bebb7aff54c6d665660d2b4df1d41b78e78575be4629b11eef10b783ef1dd4b048b86742ce20eb4584558bc8d87b17988f
diff --git a/dev-python/requests-toolbelt/requests-toolbelt-0.9.1-r1.ebuild b/dev-python/requests-toolbelt/requests-toolbelt-0.9.1-r1.ebuild
new file mode 100644
index 000000000000..a5fc91d08018
--- /dev/null
+++ b/dev-python/requests-toolbelt/requests-toolbelt-0.9.1-r1.ebuild
@@ -0,0 +1,55 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..11} pypy3 )
+
+inherit distutils-r1
+
+DESCRIPTION="A utility belt for advanced users of python-requests"
+HOMEPAGE="
+ https://toolbelt.readthedocs.io/
+ https://github.com/requests/toolbelt/
+ https://pypi.org/project/requests-toolbelt/
+"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~alpha amd64 arm arm64 hppa ~ia64 ~loong ppc ppc64 ~riscv ~s390 sparc x86 ~x64-macos"
+
+RDEPEND="
+ <dev-python/requests-3.0.0[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ dev-python/betamax[${PYTHON_USEDEP}]
+ dev-python/mock[${PYTHON_USEDEP}]
+ )
+"
+
+DOCS=( AUTHORS.rst HISTORY.rst README.rst )
+
+PATCHES=(
+ "${FILESDIR}/requests-toolbelt-0.8.0-test-tracebacks.patch"
+ "${FILESDIR}/requests-toolbelt-0.9.1-tests.patch"
+ "${FILESDIR}/requests-toolbelt-0.9.1-py310.patch"
+)
+
+distutils_enable_tests pytest
+
+EPYTEST_DESELECT=(
+ # Internet
+ tests/test_multipart_encoder.py::TestFileFromURLWrapper::test_no_content_length_header
+ tests/test_multipart_encoder.py::TestFileFromURLWrapper::test_read_file
+ tests/test_multipart_encoder.py::TestMultipartEncoder::test_reads_file_from_url_wrapper
+)
+
+EPYTEST_IGNORE=(
+ # certs have expired
+ # (if you ever fix this, look into git history for proper
+ # cryptography/pyopenssl logic)
+ tests/test_x509_adapter.py
+)
diff --git a/dev-python/requests-toolbelt/requests-toolbelt-0.9.1.ebuild b/dev-python/requests-toolbelt/requests-toolbelt-0.9.1.ebuild
deleted file mode 100644
index 947110d8ae64..000000000000
--- a/dev-python/requests-toolbelt/requests-toolbelt-0.9.1.ebuild
+++ /dev/null
@@ -1,58 +0,0 @@
-# Copyright 1999-2022 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-PYTHON_COMPAT=( python3_{8..10} pypy3 )
-
-inherit distutils-r1
-
-DESCRIPTION="A utility belt for advanced users of python-requests"
-HOMEPAGE="https://toolbelt.readthedocs.org/"
-SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
-
-LICENSE="Apache-2.0"
-SLOT="0"
-KEYWORDS="~alpha amd64 arm arm64 hppa ~ia64 ~loong ppc ppc64 ~riscv ~s390 sparc x86 ~x64-macos"
-IUSE="test"
-
-RDEPEND="<dev-python/requests-3.0.0[${PYTHON_USEDEP}]"
-DEPEND="${RDEPEND}
- test? (
- dev-python/betamax[${PYTHON_USEDEP}]
- dev-python/mock[${PYTHON_USEDEP}]
- !alpha? ( !hppa? ( !ia64? (
- dev-python/cryptography[${PYTHON_USEDEP}]
- dev-python/pyopenssl[${PYTHON_USEDEP}]
- ) ) )
- )"
-
-DOCS=( AUTHORS.rst HISTORY.rst README.rst )
-
-PATCHES=(
- "${FILESDIR}/requests-toolbelt-0.8.0-test-tracebacks.patch"
- "${FILESDIR}/requests-toolbelt-0.9.1-tests.patch"
-
- "${FILESDIR}/requests-toolbelt-0.9.1-py310.patch"
-)
-
-distutils_enable_tests pytest
-
-python_test() {
- local EPYTEST_DESELECT=(
- # Internet
- tests/test_multipart_encoder.py::TestFileFromURLWrapper::test_no_content_length_header
- tests/test_multipart_encoder.py::TestFileFromURLWrapper::test_read_file
- tests/test_multipart_encoder.py::TestMultipartEncoder::test_reads_file_from_url_wrapper
- )
-
- local EPYTEST_IGNORE=()
- if ! has_version "dev-python/cryptography[${PYTHON_USEDEP}]" ||
- ! has_version "dev-python/pyopenssl[${PYTHON_USEDEP}]"
- then
- EPYTEST_IGNORE+=(
- tests/test_x509_adapter.py
- )
- fi
-
- epytest
-}