summaryrefslogtreecommitdiff
path: root/dev-python/requests-mock
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-05-29 09:16:49 +0100
committerV3n3RiX <venerix@koprulu.sector>2023-05-29 09:16:49 +0100
commitb2d3769042cfd3d8ceadaa52f6a5aafabb0d4114 (patch)
tree4fcc91b967ba153d4030d61e10f1b07b53755488 /dev-python/requests-mock
parent2d3042634af4767714cb90eff3f773ef54afb5ed (diff)
gentoo auto-resync : 29:05:2023 - 09:16:49
Diffstat (limited to 'dev-python/requests-mock')
-rw-r--r--dev-python/requests-mock/Manifest2
-rw-r--r--dev-python/requests-mock/requests-mock-1.10.0-r1.ebuild (renamed from dev-python/requests-mock/requests-mock-1.10.0.ebuild)11
2 files changed, 10 insertions, 3 deletions
diff --git a/dev-python/requests-mock/Manifest b/dev-python/requests-mock/Manifest
index c19a868d41c4..f76ad5a23997 100644
--- a/dev-python/requests-mock/Manifest
+++ b/dev-python/requests-mock/Manifest
@@ -1,3 +1,3 @@
DIST requests-mock-1.10.0.tar.gz 72627 BLAKE2B 4ce1838f03b732de4007c2e9b700876dcf8dba0f5eafef1292e0e40ae75e08f9b3bf74c3620d2d762944ccf9af248304929f57a337122b1a69d13355dc3f290e SHA512 873c9b219e2a2360872fac22c83371ce40f4dee45e6a0d40365f4f551271c2168a662dced6e8baad890b1dadfc03d21d4ce013f149d25a42d998af4f4fca2a79
-EBUILD requests-mock-1.10.0.ebuild 1337 BLAKE2B 2aa3b4350bfd4ca176e5df6bfa61510302aa9960e89fc646da41ae4156d6ebfa631b76cbb23f6f463a62e230e67b5519c72114774c0adb35a163a810784c6e35 SHA512 5e58231bf2aaf486216b9c88a6899267106181c73399bba16d984900f8557270b52532fcd73e39f723c3807f955c2680e9b28d31112d573ca026fc852d58b457
+EBUILD requests-mock-1.10.0-r1.ebuild 1541 BLAKE2B 74b98fabd503939869c6e74b0b78753d345e4fb05d344ccd82301decb5bd642785a373a4f67f660f22a4f3b52d07d312b972301db010f26aff33fefc4e082a65 SHA512 5b4f3b7f1499378721718cba33169eba64f0f41e274c2271ab1fc6a3daf3200ba22720b0fee7a9712ce3b3e399b97890c679e6ead755a96a1add185ab5afe38b
MISC metadata.xml 479 BLAKE2B ddd64d016f85e6960f2d8a10d53591c6ffa5c0f61ebc4074f5867a03c0d8f533468351b87cb10e662391aa3d8fdd61b07bcf607c1d5b07a13fe85cf600def424 SHA512 341437e0fb7b532b7845d000e0647ed9858efe1336e8b6f57f55f677483eae4985ac0f54016da09d22d007895f3450a5e1fa6cf5d20fa715f74466a4cdf43cfa
diff --git a/dev-python/requests-mock/requests-mock-1.10.0.ebuild b/dev-python/requests-mock/requests-mock-1.10.0-r1.ebuild
index 39c7bfbeceb3..7f72de938bf4 100644
--- a/dev-python/requests-mock/requests-mock-1.10.0.ebuild
+++ b/dev-python/requests-mock/requests-mock-1.10.0-r1.ebuild
@@ -3,21 +3,28 @@
EAPI=8
-PYTHON_COMPAT=( pypy3 python3_{9..11} )
DISTUTILS_USE_PEP517=setuptools
PYPI_NO_NORMALIZE=1
+PYTHON_COMPAT=( pypy3 python3_{10..11} )
+
inherit distutils-r1 pypi
DESCRIPTION="Mock out responses from the requests package"
-HOMEPAGE="https://github.com/jamielennox/requests-mock"
+HOMEPAGE="
+ https://github.com/jamielennox/requests-mock/
+ https://pypi.org/project/requests-mock/
+"
LICENSE="Apache-2.0"
SLOT="0"
KEYWORDS="amd64 ~arm arm64 ~ppc64 ~riscv x86"
+# urllib3 causes regressions that aren't caught by tests:
+# https://github.com/jamielennox/requests-mock/issues/228
RDEPEND="
>=dev-python/requests-2.3[${PYTHON_USEDEP}]
dev-python/six[${PYTHON_USEDEP}]
+ <dev-python/urllib3-2[${PYTHON_USEDEP}]
"
BDEPEND="
>=dev-python/pbr-0.8[${PYTHON_USEDEP}]