summaryrefslogtreecommitdiff
path: root/dev-python/requests-mock
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /dev-python/requests-mock
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'dev-python/requests-mock')
-rw-r--r--dev-python/requests-mock/Manifest5
-rw-r--r--dev-python/requests-mock/metadata.xml12
-rw-r--r--dev-python/requests-mock/requests-mock-1.2.0.ebuild39
-rw-r--r--dev-python/requests-mock/requests-mock-1.5.0.ebuild61
4 files changed, 117 insertions, 0 deletions
diff --git a/dev-python/requests-mock/Manifest b/dev-python/requests-mock/Manifest
new file mode 100644
index 000000000000..a213ac09d5c6
--- /dev/null
+++ b/dev-python/requests-mock/Manifest
@@ -0,0 +1,5 @@
+DIST requests-mock-1.2.0.tar.gz 40219 BLAKE2B b5ded6c97d920bab0c610c1be1c80f299e56cccd393c824b5c9ab3e0c298491b8be0b285c440bc8ba32eb1eec2eca14ec363d0f188c5b095192a56d01383c322 SHA512 ed24d1809aef597219ae2b0b376156a0760040795ccd660ee38f84cd1ceed58cbc5009764d7a365d31f941ee16e2b537b92ddcff92bcd8d47b7e95c67dc8d82c
+DIST requests-mock-1.5.0.tar.gz 47824 BLAKE2B 90d540e2372430c70b0ada0bc48a3a8085452e062e9ab57a232d080df8312c2a722c01d61fb399fe2a6bc31a2d6d61914d8d0e2c912a2e439062b27bb31914cf SHA512 21838017ac4d3066e2240b40b27bbe16f3bd989f37eba90f0a0d0cdb997e7e65c6d9dc63b31f64daaa6146cc3c6bccbba86382eda3f2ca72eb7cc8381969af36
+EBUILD requests-mock-1.2.0.ebuild 1003 BLAKE2B a00179065fafab878c218677048be534ae3415e8aa7b69edc50549acf208cae28e3f87f6a0603687b300aab88ca10c8ab96f7e6276174c6c466ce1ea28e80ee8 SHA512 824e726de49409376cf8bcaa61ec492929e8260481fa054cd6844da7c7ce6e963fb05f106536ddde33614c09821316008b4c8cacd6be8424c5ffa9a5a1ad311f
+EBUILD requests-mock-1.5.0.ebuild 1661 BLAKE2B 87da1c1772940d5181c8732b8426cf2fb0a58747f0c78e39a9e705f23aa28eef735eb05e635a53106e1d671b7e67eaf1411ddbb319bbd6c4190f027a5bc3f29a SHA512 4391ecddb12dc742d1188e4b1c6fe6c60f950a686736efd46bf558a9d53b41b2d397012970139a50b587ea8c32a8f0f3e77c417b7c8550add5601edcdb883ca6
+MISC metadata.xml 381 BLAKE2B b69401a04acb38bf976897fd9e0110f4c39c160a1fc69ef799d7a3fa934ae9258143e264d783f16813c61f866eeaea901b332eadd35a4cefd335dbf826943c63 SHA512 654e7f3a3324b844c147097b3af1dc6de182e3494a2ca8214e1f8f5d6794667847171c3d5570dd8b2d3f8ff3dc3fcd76821477854be6cdafdde0c6626110597c
diff --git a/dev-python/requests-mock/metadata.xml b/dev-python/requests-mock/metadata.xml
new file mode 100644
index 000000000000..3123916606e5
--- /dev/null
+++ b/dev-python/requests-mock/metadata.xml
@@ -0,0 +1,12 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>python@gentoo.org</email>
+ <name>Python</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="pypi">requests-mock</remote-id>
+ <remote-id type="github">jamielennox/requests-mock</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-python/requests-mock/requests-mock-1.2.0.ebuild b/dev-python/requests-mock/requests-mock-1.2.0.ebuild
new file mode 100644
index 000000000000..f1334e757942
--- /dev/null
+++ b/dev-python/requests-mock/requests-mock-1.2.0.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python2_7 python3_{4,5,6} )
+
+inherit distutils-r1
+
+DESCRIPTION="Mock out responses from the requests package"
+HOMEPAGE="https://github.com/jamielennox/requests-mock"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="amd64 ~arm64 x86"
+IUSE="test"
+
+DEPEND="
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ >=dev-python/pbr-0.8[${PYTHON_USEDEP}]
+ test? (
+ dev-python/fixtures[${PYTHON_USEDEP}]
+ dev-python/mock[${PYTHON_USEDEP}]
+ >=dev-python/testrepository-0.0.18[${PYTHON_USEDEP}]
+ dev-python/testtools[${PYTHON_USEDEP}]
+ )
+"
+RDEPEND="
+ >=dev-python/requests-1.1[${PYTHON_USEDEP}]
+ dev-python/six[${PYTHON_USEDEP}]
+"
+
+python_test() {
+ rm -rf .testrepository || die "couldn't remove '.testrepository' under ${EPYTHON}"
+
+ testr init || die "testr init failed under ${EPYTHON}"
+ testr run || die "testr run failed under ${EPYTHON}"
+}
diff --git a/dev-python/requests-mock/requests-mock-1.5.0.ebuild b/dev-python/requests-mock/requests-mock-1.5.0.ebuild
new file mode 100644
index 000000000000..bcc74016ab76
--- /dev/null
+++ b/dev-python/requests-mock/requests-mock-1.5.0.ebuild
@@ -0,0 +1,61 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( pypy{,3} python{2_7,3_{4,5,6}} )
+
+inherit distutils-r1
+
+DESCRIPTION="Mock out responses from the requests package"
+HOMEPAGE="https://github.com/jamielennox/requests-mock"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~x86"
+IUSE="doc test"
+
+DEPEND="
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ >=dev-python/pbr-0.8[${PYTHON_USEDEP}]
+ doc? ( dev-python/sphinx[${PYTHON_USEDEP}] )
+ test? (
+ dev-python/fixtures[${PYTHON_USEDEP}]
+ dev-python/mock[${PYTHON_USEDEP}]
+ dev-python/subunit[${PYTHON_USEDEP}]
+ >=dev-python/testrepository-0.0.18[${PYTHON_USEDEP}]
+ dev-python/testtools[${PYTHON_USEDEP}]
+ )
+"
+RDEPEND="
+ >=dev-python/requests-1.1[${PYTHON_USEDEP}]
+ dev-python/six[${PYTHON_USEDEP}]
+"
+
+python_prepare_all() {
+ # Disable intersphinx
+ # Disable reno which only works inside a git repository
+ sed -i -e "s/'reno.sphinxext',//" \
+ -e "s/'sphinx.ext.intersphinx'//" \
+ doc/source/conf.py || die
+ # Remove the release notes section which requires reno
+ rm doc/source/release-notes.rst || die
+ sed -i '/^=============$/,/release-notes/d' doc/source/index.rst || die
+ distutils-r1_python_prepare_all
+}
+
+python_compile_all() {
+ if use doc; then
+ sphinx-build doc/source docs/source/build/_html || die
+ HTML_DOCS=( docs/source/build/_html/. )
+ fi
+}
+
+python_test() {
+ rm -rf .testrepository \
+ || die "couldn't remove '.testrepository' under ${EPYTHON}"
+
+ testr init || die "testr init failed under ${EPYTHON}"
+ testr run || die "testr run failed under ${EPYTHON}"
+}