summaryrefslogtreecommitdiff
path: root/dev-python/requests-mock
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2021-04-28 20:21:43 +0100
committerV3n3RiX <venerix@redcorelinux.org>2021-04-28 20:21:43 +0100
commit40aaaa64e86ba6710bbeb31c4615a6ce80e75e11 (patch)
tree758c221bad35c9288d0bd6df9c7dfc226728e52c /dev-python/requests-mock
parent8d5dbd847cbc704a6a06405856e94b461011afe3 (diff)
gentoo resync : 28.04.2021
Diffstat (limited to 'dev-python/requests-mock')
-rw-r--r--dev-python/requests-mock/Manifest4
-rw-r--r--dev-python/requests-mock/requests-mock-1.9.0.ebuild45
-rw-r--r--dev-python/requests-mock/requests-mock-1.9.1.ebuild45
3 files changed, 94 insertions, 0 deletions
diff --git a/dev-python/requests-mock/Manifest b/dev-python/requests-mock/Manifest
index 0afeec81721b..ef7bbfb4eeff 100644
--- a/dev-python/requests-mock/Manifest
+++ b/dev-python/requests-mock/Manifest
@@ -1,3 +1,7 @@
DIST requests-mock-1.8.0.tar.gz 59794 BLAKE2B 2bdcd180ea793a02cf34eda356d90c0e338cec6f3fb718564026d28ea06ac975073f291be9cb685f012c803fdeca1fe29139537529e292b91a3356f0b781f97a SHA512 252bce965e0fca03cd5ce09912c726045f9c632e90bfee13b06c9f3e2c6b70eab7f39cf8e7efb3b7d2cf2b5d79cc5c5ba6e2379b3d48ce33bf78861ada911918
+DIST requests-mock-1.9.0.tar.gz 66243 BLAKE2B 33602e85376d7812b8f4b35bf657c905ddc7db4d85e3de1f70d38871c90c42fc886e99bce3dc45079b6c8ac8e3e6b0b5291d4acda31d26045396d4ed505c3faf SHA512 1382077357a13dbec65cc4226b628ff6b55348422d9f0e9e2311c85affbc40437d22c2f95fa305303a86decc765a6228366f27eea76e254da194789b1d8fb610
+DIST requests-mock-1.9.1.tar.gz 66782 BLAKE2B 5457d359bf93f3f1e335481e44c1e9a391ee88c648b3c385806274e2c39ae3a69268d792dfc2e4609f2ccebd47dc2a3bb488f11b1b479c010a4194fe5cdc3be6 SHA512 96a8a787daa7d42796baf2807543ca18c27f595e101fd230cd392eb2417b3b0925b977a6fc49d70e21362e5b647cac201cb9f3968301ce2702772ddd85cf7094
EBUILD requests-mock-1.8.0.ebuild 1314 BLAKE2B 2905ad624ce6ec7329fb59e02f6309aa0e2781237f3ed98eabd6c89c2e3f8f12fcff366c1974f8ca788124e93e9d907e19845146aed4997faaeb4462cba3661d SHA512 e260ac73f27d04f9017088b557ebf8463f888e1f4b0921856c028399c402281f178372415dfff7207bac342eeb04fd2aa00118dbdc07983c2cc5a83cb8ab227e
+EBUILD requests-mock-1.9.0.ebuild 1282 BLAKE2B 0d471d80b9df7e995b810737c6051d79b04231db277a637ecb625ad6a5783ac4dabf761d4f9e39e904f2b862222c7ae58273918f04e76d93123f402de350f56b SHA512 a2725095d5ad6f7e31e645cc2711c1250f5b2a534b6adc3ebfe5503a40faa7de2114020f22f101244ee97f31da4af09bf0c58d234d1f0255897cdc0180448f42
+EBUILD requests-mock-1.9.1.ebuild 1282 BLAKE2B 0d471d80b9df7e995b810737c6051d79b04231db277a637ecb625ad6a5783ac4dabf761d4f9e39e904f2b862222c7ae58273918f04e76d93123f402de350f56b SHA512 a2725095d5ad6f7e31e645cc2711c1250f5b2a534b6adc3ebfe5503a40faa7de2114020f22f101244ee97f31da4af09bf0c58d234d1f0255897cdc0180448f42
MISC metadata.xml 478 BLAKE2B 73ae7388ccece263501b7b1b4b1953e2528cfa2287460aae4f9d4758dbb9a41ec38d6a00c45f74e87e4625243660ba530f85e37328ade1b88dbda55a20ea739d SHA512 5efc54aa7f3fda2909ddb82975cb6bd554ad90924075a22ecba41e50e4af8a70722ec9f69c7a588ba2cd01cf937d887a11f747bb0787f20976567423feaa5867
diff --git a/dev-python/requests-mock/requests-mock-1.9.0.ebuild b/dev-python/requests-mock/requests-mock-1.9.0.ebuild
new file mode 100644
index 000000000000..930d9082097b
--- /dev/null
+++ b/dev-python/requests-mock/requests-mock-1.9.0.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( pypy3 python3_{7..9} )
+
+inherit distutils-r1
+
+DESCRIPTION="Mock out responses from the requests package"
+HOMEPAGE="https://github.com/jamielennox/requests-mock"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc64 ~x86"
+
+RDEPEND="
+ >=dev-python/requests-2.3[${PYTHON_USEDEP}]
+ dev-python/six[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ >=dev-python/pbr-0.8[${PYTHON_USEDEP}]
+ test? (
+ dev-python/fixtures[${PYTHON_USEDEP}]
+ dev-python/mock[${PYTHON_USEDEP}]
+ dev-python/pytest[${PYTHON_USEDEP}]
+ dev-python/testtools[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_sphinx doc/source
+distutils_enable_tests unittest
+
+python_prepare_all() {
+ # Disable reno which only works inside a git repository
+ sed -i "s/'reno.sphinxext',//" doc/source/conf.py || die
+ # Remove the release notes section which requires reno
+ rm doc/source/release-notes.rst || die
+ sed -i '/^=============$/,/release-notes/d' doc/source/index.rst || die
+ # Disable a test which requires purl (not in the tree)
+ sed -i -e "/^import purl$/d" -e "s/test_with_purl/_&/" \
+ tests/test_adapter.py || die
+ distutils-r1_python_prepare_all
+}
diff --git a/dev-python/requests-mock/requests-mock-1.9.1.ebuild b/dev-python/requests-mock/requests-mock-1.9.1.ebuild
new file mode 100644
index 000000000000..930d9082097b
--- /dev/null
+++ b/dev-python/requests-mock/requests-mock-1.9.1.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( pypy3 python3_{7..9} )
+
+inherit distutils-r1
+
+DESCRIPTION="Mock out responses from the requests package"
+HOMEPAGE="https://github.com/jamielennox/requests-mock"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc64 ~x86"
+
+RDEPEND="
+ >=dev-python/requests-2.3[${PYTHON_USEDEP}]
+ dev-python/six[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ >=dev-python/pbr-0.8[${PYTHON_USEDEP}]
+ test? (
+ dev-python/fixtures[${PYTHON_USEDEP}]
+ dev-python/mock[${PYTHON_USEDEP}]
+ dev-python/pytest[${PYTHON_USEDEP}]
+ dev-python/testtools[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_sphinx doc/source
+distutils_enable_tests unittest
+
+python_prepare_all() {
+ # Disable reno which only works inside a git repository
+ sed -i "s/'reno.sphinxext',//" doc/source/conf.py || die
+ # Remove the release notes section which requires reno
+ rm doc/source/release-notes.rst || die
+ sed -i '/^=============$/,/release-notes/d' doc/source/index.rst || die
+ # Disable a test which requires purl (not in the tree)
+ sed -i -e "/^import purl$/d" -e "s/test_with_purl/_&/" \
+ tests/test_adapter.py || die
+ distutils-r1_python_prepare_all
+}