summaryrefslogtreecommitdiff
path: root/dev-python/requests-download
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2024-11-23 03:02:57 +0000
committerV3n3RiX <venerix@koprulu.sector>2024-11-23 03:02:57 +0000
commit71dd9d29cdaf7cc0ecdb9ea37d128726a941c630 (patch)
tree4eccd905f575579fe47abb8a83bbdb44ceb8c929 /dev-python/requests-download
parentc7a7ec40cf928d8fc6a8241aa208272c008c7b4d (diff)
gentoo auto-resync : 23:11:2024 - 03:02:56
Diffstat (limited to 'dev-python/requests-download')
-rw-r--r--dev-python/requests-download/Manifest3
-rw-r--r--dev-python/requests-download/metadata.xml13
-rw-r--r--dev-python/requests-download/requests-download-0.1.2-r2.ebuild37
3 files changed, 53 insertions, 0 deletions
diff --git a/dev-python/requests-download/Manifest b/dev-python/requests-download/Manifest
new file mode 100644
index 000000000000..bf7bfdca9d6b
--- /dev/null
+++ b/dev-python/requests-download/Manifest
@@ -0,0 +1,3 @@
+DIST requests_download-0.1.2.gh.tar.gz 2584 BLAKE2B c6f2eb7a182e0f42ccb7b603dec47a077b1b946bfa93968972dce5267c7c51fa8c4158e15cd35621cbe229e12f6644db9734e52439796d8d8411be16a38e1e9a SHA512 99d4b275200c88befd2730d17a3329c8cbb155fa5cf9600a7466e8ab109f999a9fc9b8c668aa3b389bc2a3deb33b8a3fd390270d71f04bb0a8f998da67cfde82
+EBUILD requests-download-0.1.2-r2.ebuild 733 BLAKE2B 26d194ef02bceb793e05d21c9db1351df504214e1aa33a8aa63a37281d7156b37b0b9f74fcbc03e1cc845b2ba4187fd5056f643bf63fe4970e2ecc1ac5431bc7 SHA512 4a5ced039bf4ac9b638bb1cc441a5d786df59b2f3b56a3af0bf1807cb16798c93c6788def81d9344cc9891bc9211ae854d8a6b11edafd55e4bdaf2bbd9252661
+MISC metadata.xml 434 BLAKE2B 55a4f9a132c3c50d9a9852e73dd24ff70517c9be1a2c4c7e84f04fbfd6a24aa250e165db5bff5959fa2e5a88f063f080a16c2b47e061d6d501b67dd0860714d4 SHA512 f7950fc65c69c3376caf4e7865e9517d75e7df1b054748d6ca4850707ec7c5fb7124dc2057f8131c20cbc9e2f1d7198fe2d25879250b0cf99d8ed7fd6dbc1fc5
diff --git a/dev-python/requests-download/metadata.xml b/dev-python/requests-download/metadata.xml
new file mode 100644
index 000000000000..86556891f3f8
--- /dev/null
+++ b/dev-python/requests-download/metadata.xml
@@ -0,0 +1,13 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>chutzpah@gentoo.org</email>
+ <name>Patrick McLean</name>
+ </maintainer>
+ <stabilize-allarches/>
+ <upstream>
+ <remote-id type="pypi">requests_download</remote-id>
+ <remote-id type="github">takluyver/requests_download</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-python/requests-download/requests-download-0.1.2-r2.ebuild b/dev-python/requests-download/requests-download-0.1.2-r2.ebuild
new file mode 100644
index 000000000000..4e5b9fd41874
--- /dev/null
+++ b/dev-python/requests-download/requests-download-0.1.2-r2.ebuild
@@ -0,0 +1,37 @@
+# Copyright 2019-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=flit
+PYTHON_COMPAT=( python3_{10..12} pypy3 )
+
+inherit distutils-r1
+
+MY_P=requests_download-${PV}
+DESCRIPTION="A convenient function to download to a file using requests"
+HOMEPAGE="
+ https://github.com/takluyver/requests_download/
+ https://pypi.org/project/requests_download/
+"
+SRC_URI="
+ https://github.com/takluyver/requests_download/archive/${PV}.tar.gz
+ -> ${MY_P}.gh.tar.gz
+"
+S=${WORKDIR}/${MY_P}
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="amd64 ~mips ~x86"
+
+RDEPEND="
+ dev-python/requests[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ ${RDEPEND}
+"
+
+# there are no tests upstream
+RESTRICT="test"
+
+DOCS=( README.rst )