summaryrefslogtreecommitdiff
path: root/dev-python/requests-credssp
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2019-03-03 13:42:34 +0000
committerV3n3RiX <venerix@redcorelinux.org>2019-03-03 13:42:34 +0000
commit066d27181e9a797ad9f8fc43b49fc9a10ff2f707 (patch)
tree3cb05783d73b2c33589ba305144a31c718e123cd /dev-python/requests-credssp
parent16449a80e28af2209916cc66d19c9a44ca2b90d9 (diff)
gentoo resync : 03.03.2019
Diffstat (limited to 'dev-python/requests-credssp')
-rw-r--r--dev-python/requests-credssp/Manifest3
-rw-r--r--dev-python/requests-credssp/metadata.xml12
-rw-r--r--dev-python/requests-credssp/requests-credssp-1.0.2.ebuild25
3 files changed, 40 insertions, 0 deletions
diff --git a/dev-python/requests-credssp/Manifest b/dev-python/requests-credssp/Manifest
new file mode 100644
index 000000000000..6a320f78d7cc
--- /dev/null
+++ b/dev-python/requests-credssp/Manifest
@@ -0,0 +1,3 @@
+DIST requests-credssp-1.0.2.tar.gz 21813 BLAKE2B 4626b31e9933e7fe5abdcba59834bedbc14afdd32b21d90124bbb458407213ba8cb92e98394f980f43aacd61de6c0e56e835cf47489ea55338a3dcdd171099e4 SHA512 8a076fc53eee73e24b08f6283b02a48519b9df076222b2e37c145c1d4c1756c29ccc41f0016c5a8ee7f5f7bf76c95fa158016f2cddd42b45a5ab2182939ffae0
+EBUILD requests-credssp-1.0.2.ebuild 711 BLAKE2B 22db5715c5e0f8e32a4cc7cb55680c279bdb17c7ffb86b2c09076dbd40c68fb94dc4e2a8fced6068af873f1ffab42ceabe91e0adf005ab57419644bf14f7efa9 SHA512 e72a54c7a88d631527b04070f515527acdb5e90a27fdf2b5124e0b731c49450231dfa774eace6fb8fc550d71c79760d5e282c2f5acfaf0cd1dcd6489356b2c68
+MISC metadata.xml 325 BLAKE2B 29ae1049a0331156fbe1f955fe60417f1d9c5a9b78d0248dd919077c9a6938843faa37f6a56fc50d60d5193f6f3593d2845ef5f371f4bea5d69bc03a9111977c SHA512 738d9d27265c68d240b23837c3c527f60067e1ca70630ed610845a3b2796905f236d90fb3b812958dfd202d3c91e958a9976dd3395a9ceda59ad06d6f1a67893
diff --git a/dev-python/requests-credssp/metadata.xml b/dev-python/requests-credssp/metadata.xml
new file mode 100644
index 000000000000..5619a58605f2
--- /dev/null
+++ b/dev-python/requests-credssp/metadata.xml
@@ -0,0 +1,12 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>chainsaw@gentoo.org</email>
+ <name>Tony Vroon</name>
+ </maintainer>
+
+ <upstream>
+ <remote-id type="pypi">requests-credssp</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-python/requests-credssp/requests-credssp-1.0.2.ebuild b/dev-python/requests-credssp/requests-credssp-1.0.2.ebuild
new file mode 100644
index 000000000000..be0662bf8c94
--- /dev/null
+++ b/dev-python/requests-credssp/requests-credssp-1.0.2.ebuild
@@ -0,0 +1,25 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python2_7 python3_{4,5,6} )
+inherit distutils-r1
+
+DESCRIPTION="HTTPS CredSSP authentication with the requests library"
+HOMEPAGE="https://pypi.org/project/requests-credssp/"
+SRC_URI="mirror://pypi/r/requests-credssp/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE=""
+
+RDEPEND="dev-python/cryptography[${PYTHON_USEDEP}]
+ dev-python/ntlm-auth[${PYTHON_USEDEP}]
+ dev-python/pyasn1[${PYTHON_USEDEP}]
+ dev-python/pyopenssl[${PYTHON_USEDEP}]
+ dev-python/requests[${PYTHON_USEDEP}]
+ dev-python/six[${PYTHON_USEDEP}]"
+DEPEND="${RDEPEND}
+ dev-python/setuptools[${PYTHON_USEDEP}]"