summaryrefslogtreecommitdiff
path: root/dev-python/requests-cache
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /dev-python/requests-cache
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'dev-python/requests-cache')
-rw-r--r--dev-python/requests-cache/Manifest3
-rw-r--r--dev-python/requests-cache/metadata.xml15
-rw-r--r--dev-python/requests-cache/requests-cache-0.4.12.ebuild33
3 files changed, 51 insertions, 0 deletions
diff --git a/dev-python/requests-cache/Manifest b/dev-python/requests-cache/Manifest
new file mode 100644
index 000000000000..493f0eda34ff
--- /dev/null
+++ b/dev-python/requests-cache/Manifest
@@ -0,0 +1,3 @@
+DIST requests-cache-0.4.12.zip 44767 BLAKE2B f328d8ae8e3377af626030a6e3617c78e488024fa4ada9894576d339e571ba8ee6d905612ddc2802810bbeffbd8c94d90c743889e80fbf21418a7c67c5a005f6 SHA512 784d630eec99b607596d6ebcb7e51b0b4ed612b131437000391ecea6f3a684d1f61d169d57266ffc044a3939dcd4e7d6f85b9538165ae3613b1d3e55f18585fd
+EBUILD requests-cache-0.4.12.ebuild 851 BLAKE2B b209a185ae182d45f3d37c47c5fbb121936233388eea01b98a501f986b670158b64274bf60c06722b92d3c53150c9523882c9e30acff67d378f066380a53d94c SHA512 e9a8fd72164bff7e73c154ad3de4d3d45394925807505f38b630ad93c7f214d059e557129e319a894d65d1d46fd75cbdf76b5d7e02288153e46ee3000bf6d61a
+MISC metadata.xml 444 BLAKE2B 6008ac86bdb3740724aff487116d542902602f70670735ac2219b72db042b1974ffa6b4eab0254e59d16fa0438e022d8b9f675899b0ac181d88d4f82dd78d04e SHA512 0cc1b4cee3f1aecef89eb15ffd1e03a0ff4887f9b87a10ea90b6d11e3f5144b8d8d67dcad8c1dd26df3cea9e07140ed1ec76c4b1587d0db1b0f9c60b6daad41f
diff --git a/dev-python/requests-cache/metadata.xml b/dev-python/requests-cache/metadata.xml
new file mode 100644
index 000000000000..54115df8f824
--- /dev/null
+++ b/dev-python/requests-cache/metadata.xml
@@ -0,0 +1,15 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>zx2c4@gentoo.org</email>
+ <name>Jason A. Donenfeld</name>
+ </maintainer>
+ <maintainer type="project">
+ <email>python@gentoo.org</email>
+ <name>Python</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="pypi">requests-cache</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-python/requests-cache/requests-cache-0.4.12.ebuild b/dev-python/requests-cache/requests-cache-0.4.12.ebuild
new file mode 100644
index 000000000000..d2cbcf8ca088
--- /dev/null
+++ b/dev-python/requests-cache/requests-cache-0.4.12.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+PYTHON_COMPAT=( python2_7 python3_{4,5,6} pypy )
+
+inherit distutils-r1
+
+HOMEPAGE="https://pypi.org/project/requests-cache/"
+DESCRIPTION="Persistent cache for requests library"
+SRC_URI="mirror://pypi/${P:0:1}/${PN}/${P}.zip"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="amd64 x86"
+IUSE="doc"
+
+# Portage only has versions of request >= minimum border
+RDEPEND=">=dev-python/requests-2.6[${PYTHON_USEDEP}]"
+DEPEND="
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ doc? ( dev-python/sphinx[${PYTHON_USEDEP}] )"
+
+# Testsuite excels in tests connecting to the network via local server daemons
+python_compile_all() {
+ use doc && emake -C docs html
+}
+
+python_install_all() {
+ use doc && local HTML_DOCS=( docs/_build/html/. )
+ distutils-r1_python_install_all
+}