summaryrefslogtreecommitdiff
path: root/dev-python/requests-cache
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2024-02-18 05:38:53 +0000
committerV3n3RiX <venerix@koprulu.sector>2024-02-18 05:38:53 +0000
commit3e4b97f04e1561890eb4b0bcb3a411b931c08d02 (patch)
treed34aa692c74eb0e0de725fa00b6df5785268b52c /dev-python/requests-cache
parent78fce155315439a69aa67573fd4696b735649431 (diff)
gentoo auto-resync : 18:02:2024 - 05:38:53
Diffstat (limited to 'dev-python/requests-cache')
-rw-r--r--dev-python/requests-cache/Manifest2
-rw-r--r--dev-python/requests-cache/requests-cache-1.2.0.ebuild92
2 files changed, 94 insertions, 0 deletions
diff --git a/dev-python/requests-cache/Manifest b/dev-python/requests-cache/Manifest
index 45d2c1437e06..2b4b2484d50f 100644
--- a/dev-python/requests-cache/Manifest
+++ b/dev-python/requests-cache/Manifest
@@ -1,3 +1,5 @@
DIST requests-cache-1.1.1.gh.tar.gz 2927360 BLAKE2B 2db8b71d4f219f2b61e4477a57af9dee09783ea47e86dfcc7b7726acb2507043186433ee6a9f67162c0a01c5f1439fd52ea9b74b89daa94cbe351341ef6b1f53 SHA512 99782fe635daa0834709b254b0d51c5d2b2ad37d26201acdc143f963b613bb6b4e5863e2246a2bf9d099c773e229157a983b04a40740e6207e2c356dc48bdba6
+DIST requests-cache-1.2.0.gh.tar.gz 3057187 BLAKE2B 135d39d8fac1e123c71b07b30002b980b5fdcdb586cafb310f8f72e865cdc97f62b699cd981068207c6f020deef595469801d440cf5034566e9618385d569437 SHA512 b198d282cfd656c432d3a63f4d615191ac1ff97c9563e9bd6945e7a78444601108beb47a0f4a79740c7bd6942c3753f025cd52457e87ece7964229799bbb8fa1
EBUILD requests-cache-1.1.1.ebuild 2435 BLAKE2B 3ca3e0653a97af57e78b0cb7dc43ef7085dbd5287a35fb823da9f3cdbdadc4177c65897fa4b5527ce017bff99d402eda0f7946e2b0c61128189b20cabe64c0f4 SHA512 68b6e62d8ffcd37264130cc49bb8177fab342da8c380e75ecfb6426e5a92cc2e3fb3ec4fe3f5353e31cd06a5e9c624de9527a813eac006565205f470349077a4
+EBUILD requests-cache-1.2.0.ebuild 2440 BLAKE2B ad45739124ed79a2f299cb8f551d6f48215dc19f210c9bd4de73ef3bd3ab6427b75d2d000c56a94596acc11ccc3ddf985cee6116e3a1485a91220d8c03cd32c0 SHA512 e7acf6fc792264958ff9970a061023c0e7dce59b462ee03b03b8d3998f915f66079fb554b78d90484e89124fd1056be359cb2aac08a5505c8f67b60681181116
MISC metadata.xml 541 BLAKE2B a8fd81921a36e2fe5bdec38cc1039b9e91971c992a59cbe2dc4826977f753bd6cd2533f65b5f1a076308a898972fe70e85a2c8cf480259e9801f51b10c4de8a4 SHA512 64f29b67eaf3ce892a9f918abd7eaf8f020323e9e0d986b424cffc83e3ac1ba5cb14b534f0a0ec73a8e81694ca4e0e7f98ef02968ac5b43dab104b2b12e8e0f2
diff --git a/dev-python/requests-cache/requests-cache-1.2.0.ebuild b/dev-python/requests-cache/requests-cache-1.2.0.ebuild
new file mode 100644
index 000000000000..e6f048116b96
--- /dev/null
+++ b/dev-python/requests-cache/requests-cache-1.2.0.ebuild
@@ -0,0 +1,92 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=poetry
+PYTHON_COMPAT=( pypy3 python3_{10..12} )
+PYTHON_REQ_USE="sqlite"
+
+inherit distutils-r1 optfeature
+
+HOMEPAGE="
+ https://pypi.org/project/requests-cache/
+ https://github.com/requests-cache/requests-cache/
+"
+DESCRIPTION="Persistent cache for requests library"
+SRC_URI="
+ https://github.com/requests-cache/requests-cache/archive/v${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~loong ~ppc64 ~riscv ~x86"
+
+RDEPEND="
+ dev-python/attrs[${PYTHON_USEDEP}]
+ >=dev-python/cattrs-22.2[${PYTHON_USEDEP}]
+ >=dev-python/platformdirs-2.5[${PYTHON_USEDEP}]
+ >=dev-python/requests-2.0.0[${PYTHON_USEDEP}]
+ dev-python/urllib3[${PYTHON_USEDEP}]
+ >=dev-python/url-normalize-1.4[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ dev-python/itsdangerous[${PYTHON_USEDEP}]
+ dev-python/pytest-httpbin[${PYTHON_USEDEP}]
+ dev-python/requests-mock[${PYTHON_USEDEP}]
+ dev-python/responses[${PYTHON_USEDEP}]
+ >=dev-python/rich-10.0[${PYTHON_USEDEP}]
+ dev-python/timeout-decorator[${PYTHON_USEDEP}]
+ >=dev-python/ujson-5.4[${PYTHON_USEDEP}]
+ $(python_gen_cond_dep '
+ dev-python/time-machine[${PYTHON_USEDEP}]
+ ' 'python*')
+ )
+"
+
+distutils_enable_tests pytest
+
+python_test() {
+ local EPYTEST_IGNORE=(
+ # These require extra servers running
+ tests/integration/test_dynamodb.py
+ tests/integration/test_gridfs.py
+ tests/integration/test_mongodb.py
+ tests/integration/test_redis.py
+ )
+ local EPYTEST_DESELECT=(
+ # Requires Internet access
+ tests/integration/test_upgrade.py::test_version_upgrade
+ )
+
+ case ${EPYTHON} in
+ pypy3)
+ EPYTEST_DESELECT+=(
+ # "database is locked", upstream probably relies on GC
+ # too much
+ tests/integration/test_sqlite.py
+ )
+ ;;
+ python3.12)
+ # https://github.com/requests-cache/requests-cache/issues/845
+ EPYTEST_DESELECT+=(
+ tests/integration/test_memory.py::TestMemoryCache::test_response_no_duplicate_read
+ tests/integration/test_sqlite.py::TestSQLiteCache::test_concurrency
+ )
+ ;;
+ esac
+
+ local -x USE_PYTEST_HTTPBIN=true
+ epytest
+}
+
+pkg_postinst() {
+ optfeature "redis backend" "dev-python/redis"
+ optfeature "MongoDB backend" "dev-python/pymongo"
+
+ optfeature "JSON serialization" "dev-python/ujson"
+ optfeature "YAML serialization" "dev-python/pyyaml"
+ optfeature "signing serialized data" "dev-python/itsdangerous"
+}