summaryrefslogtreecommitdiff
path: root/dev-python/requests-cache
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-02-17 08:06:58 +0000
committerV3n3RiX <venerix@koprulu.sector>2023-02-17 08:06:58 +0000
commit29394d0921808a94a409f01eff49f681651de5d5 (patch)
tree93d18027cb4ea68a3c967602c5793af032180bab /dev-python/requests-cache
parent5987fa693ef880163ebde423615a177cb5bda20e (diff)
gentoo auto-resync : 17:02:2023 - 08:06:58
Diffstat (limited to 'dev-python/requests-cache')
-rw-r--r--dev-python/requests-cache/Manifest2
-rw-r--r--dev-python/requests-cache/requests-cache-0.9.7.ebuild71
2 files changed, 0 insertions, 73 deletions
diff --git a/dev-python/requests-cache/Manifest b/dev-python/requests-cache/Manifest
index 0f44cbed1f68..6e203e4d7cf4 100644
--- a/dev-python/requests-cache/Manifest
+++ b/dev-python/requests-cache/Manifest
@@ -1,5 +1,3 @@
-DIST requests-cache-0.9.7.gh.tar.gz 1544100 BLAKE2B a255d3cce0345ff03e020327c10a1d8cc25e519069764b7e3e1a43a0e5cd899aec824e3c147561796cba1f269550505f881cf913d909ce7e6c52e8f76ad9688a SHA512 00b2c7080030ed07f5d896871a431aec2625dab6ab84f01f7e6fea9e81692f757304e25ee6addbe7695e93d0c1c04484c31b95a71d7c9e12f6c23a5b7747ae30
DIST requests-cache-0.9.8.gh.tar.gz 1540296 BLAKE2B 8b2ab1227b28c3822cd9111375c8759f5d7099f2724680a6560e4e14cd16558a1dcb8dd98d043fdf2f9a3861d76dd0d2c2f84df059338e9fa28c1257e74e87b9 SHA512 f428a7b498d2ef2b6c23d3715bac2274c320b6f9d6f56017e69ab5fa6b8830242a2f335ed6c3758a741a51f108c6dacae1a447ff8f05ca5686303caf48a1dc59
-EBUILD requests-cache-0.9.7.ebuild 1798 BLAKE2B dec2bba9653b432876434d37c587ba5f01325ca600008ef22164973d795e3e056fdc632b8033f8516dfd1e4be0a26417453aee595adb243fa482a1c8336c598c SHA512 3441bfc66c25d93c3bc57a8e1077a4c56da32146f80dd5c0c15d9a2cc3429e0f410d53f5b9d2c0775c38e46e96ab9cf9dbb62e6bcc57c7483d07584c652dda6a
EBUILD requests-cache-0.9.8.ebuild 1798 BLAKE2B dec2bba9653b432876434d37c587ba5f01325ca600008ef22164973d795e3e056fdc632b8033f8516dfd1e4be0a26417453aee595adb243fa482a1c8336c598c SHA512 3441bfc66c25d93c3bc57a8e1077a4c56da32146f80dd5c0c15d9a2cc3429e0f410d53f5b9d2c0775c38e46e96ab9cf9dbb62e6bcc57c7483d07584c652dda6a
MISC metadata.xml 541 BLAKE2B a8fd81921a36e2fe5bdec38cc1039b9e91971c992a59cbe2dc4826977f753bd6cd2533f65b5f1a076308a898972fe70e85a2c8cf480259e9801f51b10c4de8a4 SHA512 64f29b67eaf3ce892a9f918abd7eaf8f020323e9e0d986b424cffc83e3ac1ba5cb14b534f0a0ec73a8e81694ca4e0e7f98ef02968ac5b43dab104b2b12e8e0f2
diff --git a/dev-python/requests-cache/requests-cache-0.9.7.ebuild b/dev-python/requests-cache/requests-cache-0.9.7.ebuild
deleted file mode 100644
index 358a9638f092..000000000000
--- a/dev-python/requests-cache/requests-cache-0.9.7.ebuild
+++ /dev/null
@@ -1,71 +0,0 @@
-# Copyright 1999-2023 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-DISTUTILS_USE_PEP517=poetry
-PYTHON_COMPAT=( python3_{9..11} )
-PYTHON_REQ_USE="sqlite"
-
-inherit distutils-r1 optfeature
-
-HOMEPAGE="
- https://pypi.org/project/requests-cache/
- https://github.com/requests-cache/requests-cache/
-"
-DESCRIPTION="Persistent cache for requests library"
-SRC_URI="
- https://github.com/requests-cache/requests-cache/archive/v${PV}.tar.gz
- -> ${P}.gh.tar.gz
-"
-
-LICENSE="BSD"
-SLOT="0"
-KEYWORDS="amd64 x86"
-
-RDEPEND="
- dev-python/attrs[${PYTHON_USEDEP}]
- dev-python/appdirs[${PYTHON_USEDEP}]
- >=dev-python/cattrs-22.2[${PYTHON_USEDEP}]
- >=dev-python/requests-2.0.0[${PYTHON_USEDEP}]
- dev-python/urllib3[${PYTHON_USEDEP}]
- >=dev-python/url-normalize-1.4[${PYTHON_USEDEP}]
-"
-BDEPEND="
- test? (
- dev-python/itsdangerous[${PYTHON_USEDEP}]
- dev-python/pytest-httpbin[${PYTHON_USEDEP}]
- dev-python/requests-mock[${PYTHON_USEDEP}]
- dev-python/responses[${PYTHON_USEDEP}]
- dev-python/timeout-decorator[${PYTHON_USEDEP}]
- dev-python/ujson[${PYTHON_USEDEP}]
- )
-"
-
-distutils_enable_tests pytest
-
-python_test() {
- local EPYTEST_IGNORE=(
- # These require extra servers running
- tests/integration/test_dynamodb.py
- tests/integration/test_gridfs.py
- tests/integration/test_mongodb.py
- tests/integration/test_redis.py
- )
- local EPYTEST_DESELECT=(
- # Requires Internet access
- tests/integration/test_compat.py::test_version_upgrade
- )
-
- local -x USE_PYTEST_HTTPBIN=true
- epytest
-}
-
-pkg_postinst() {
- optfeature "redis backend" "dev-python/redis"
- optfeature "MongoDB backend" "dev-python/pymongo"
-
- optfeature "JSON serialization" "dev-python/ujson"
- optfeature "YAML serialization" "dev-python/pyyaml"
- optfeature "signing serialized data" "dev-python/itsdangerous"
-}