summaryrefslogtreecommitdiff
path: root/dev-python/requests-cache/requests-cache-0.7.3.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2021-10-20 10:22:14 +0100
committerV3n3RiX <venerix@koprulu.sector>2021-10-20 10:22:14 +0100
commit46eedbedafdb0040c37884982d4c775ce277fb7b (patch)
treedb33a91259730be84999e13a8d8168c799f50ac0 /dev-python/requests-cache/requests-cache-0.7.3.ebuild
parente23a08d0c97a0cc415aaa165da840b056f93c997 (diff)
gentoo resync : 20.10.2021
Diffstat (limited to 'dev-python/requests-cache/requests-cache-0.7.3.ebuild')
-rw-r--r--dev-python/requests-cache/requests-cache-0.7.3.ebuild54
1 files changed, 0 insertions, 54 deletions
diff --git a/dev-python/requests-cache/requests-cache-0.7.3.ebuild b/dev-python/requests-cache/requests-cache-0.7.3.ebuild
deleted file mode 100644
index db97940e2622..000000000000
--- a/dev-python/requests-cache/requests-cache-0.7.3.ebuild
+++ /dev/null
@@ -1,54 +0,0 @@
-# Copyright 1999-2021 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-DISTUTILS_USE_SETUPTOOLS=pyproject.toml
-PYTHON_COMPAT=( python3_{8..10} )
-PYTHON_REQ_USE="sqlite"
-
-inherit distutils-r1
-
-HOMEPAGE="
- https://pypi.org/project/requests-cache/
- https://github.com/reclosedev/requests-cache/"
-DESCRIPTION="Persistent cache for requests library"
-SRC_URI="
- https://github.com/reclosedev/requests-cache/archive/v${PV}.tar.gz
- -> ${P}.gh.tar.gz"
-
-LICENSE="BSD"
-SLOT="0"
-KEYWORDS="~amd64 x86"
-
-RDEPEND="
- dev-python/cattrs[${PYTHON_USEDEP}]
- dev-python/itsdangerous[${PYTHON_USEDEP}]
- >=dev-python/requests-2.0.0[${PYTHON_USEDEP}]
- >=dev-python/url-normalize-1.4[${PYTHON_USEDEP}]"
-BDEPEND="
- test? (
- dev-python/pytest-httpbin[${PYTHON_USEDEP}]
- dev-python/requests-mock[${PYTHON_USEDEP}]
- dev-python/responses[${PYTHON_USEDEP}]
- dev-python/timeout-decorator[${PYTHON_USEDEP}]
- )"
-
-distutils_enable_tests pytest
-
-python_test() {
- local ignore=(
- # These require extra servers running
- tests/integration/test_dynamodb.py
- tests/integration/test_gridfs.py
- tests/integration/test_mongodb.py
- tests/integration/test_redis.py
- )
- local deselect=(
- # Requires Internet access
- tests/integration/test_compat.py::test_version_upgrade
- )
-
- local -x USE_PYTEST_HTTPBIN=true
- epytest ${deselect[@]/#/--deselect } ${ignore[@]/#/--ignore }
-}