summaryrefslogtreecommitdiff
path: root/dev-python/reportlab/files
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-04-06 22:33:41 +0100
committerV3n3RiX <venerix@koprulu.sector>2022-04-06 22:33:41 +0100
commite68d405c5d712af4387159df07e226217bdda049 (patch)
tree009ab0f3d427f0813e62930d71802cb054c07e30 /dev-python/reportlab/files
parent401101f9c8077911929d3f2b60a37098460a5d89 (diff)
gentoo resync : 06.04.2022
Diffstat (limited to 'dev-python/reportlab/files')
-rw-r--r--dev-python/reportlab/files/reportlab-3.6.9-paths.patch21
1 files changed, 21 insertions, 0 deletions
diff --git a/dev-python/reportlab/files/reportlab-3.6.9-paths.patch b/dev-python/reportlab/files/reportlab-3.6.9-paths.patch
new file mode 100644
index 000000000000..e5ed7c43478d
--- /dev/null
+++ b/dev-python/reportlab/files/reportlab-3.6.9-paths.patch
@@ -0,0 +1,21 @@
+Disable broken logic for finding freetype2 that hits symlink loops.
+
+diff -dupr reportlab-3.6.9.orig/setup.py reportlab-3.6.9/setup.py
+--- reportlab-3.6.9.orig/setup.py 2022-03-28 10:13:33.892516135 +0200
++++ reportlab-3.6.9/setup.py 2022-03-28 10:49:11.048573739 +0200
+@@ -737,13 +737,10 @@ def main():
+ else:
+ FT_LIB=FT_LIB_DIR=FT_INC_DIR=FT_MACROS=[]
+ else:
+- ftv, I, L = inc_lib_dirs('freetype')
+ FT_LIB=['freetype']
+- FT_LIB_DIR=L
+- FT_INC_DIR=I
++ FT_LIB_DIR=[]
++ FT_INC_DIR=['/usr/include/freetype2']
+ FT_MACROS = [('RENDERPM_FT',None)]
+- infoline('installing with freetype version %s' % ftv)
+- infoline('FT_LIB_DIR=%r FT_INC_DIR=%r' % (FT_LIB_DIR,FT_INC_DIR))
+ if not FT_LIB:
+ infoline('# installing without freetype no ttf, sorry!')
+ infoline('# You need to install a static library version of the freetype2 software')