summaryrefslogtreecommitdiff
path: root/dev-python/reportlab/files/reportlab-3.5.48-usr-lib-LLD.patch
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2020-08-25 10:45:55 +0100
committerV3n3RiX <venerix@redcorelinux.org>2020-08-25 10:45:55 +0100
commit3cf7c3ef441822c889356fd1812ebf2944a59851 (patch)
treec513fe68548b40365c1c2ebfe35c58ad431cdd77 /dev-python/reportlab/files/reportlab-3.5.48-usr-lib-LLD.patch
parent05b8b0e0af1d72e51a3ee61522941bf7605cd01c (diff)
gentoo resync : 25.08.2020
Diffstat (limited to 'dev-python/reportlab/files/reportlab-3.5.48-usr-lib-LLD.patch')
-rw-r--r--dev-python/reportlab/files/reportlab-3.5.48-usr-lib-LLD.patch34
1 files changed, 34 insertions, 0 deletions
diff --git a/dev-python/reportlab/files/reportlab-3.5.48-usr-lib-LLD.patch b/dev-python/reportlab/files/reportlab-3.5.48-usr-lib-LLD.patch
new file mode 100644
index 000000000000..09ae9675eb58
--- /dev/null
+++ b/dev-python/reportlab/files/reportlab-3.5.48-usr-lib-LLD.patch
@@ -0,0 +1,34 @@
+--- a/setup.py
++++ b/setup.py
+@@ -163,22 +163,6 @@
+ if self.L is None:
+ L = []
+ I = []
+- if platform == "cygwin":
+- aDir(L, os.path.join("/usr/lib", "python%s" % sys.version[:3], "config"))
+- elif platform == "darwin":
+- # attempt to make sure we pick freetype2 over other versions
+- aDir(I, "/sw/include/freetype2")
+- aDir(I, "/sw/lib/freetype2/include")
+- # fink installation directories
+- aDir(L, "/sw/lib")
+- aDir(I, "/sw/include")
+- # darwin ports installation directories
+- aDir(L, "/opt/local/lib")
+- aDir(I, "/opt/local/include")
+- aDir(I, "/usr/local/include")
+- aDir(L, "/usr/local/lib")
+- aDir(I, "/usr/include")
+- aDir(L, "/usr/lib")
+ aDir(I, "/usr/include/freetype2")
+ prefix = sysconfig.get_config_var("prefix")
+ if prefix:
+@@ -574,7 +558,7 @@
+ SOURCES,
+ include_dirs=[RENDERPM,LIBART_INC,GT1_DIR]+FT_INC_DIR,
+ define_macros=FT_MACROS+[('LIBART_COMPILATION',None)]+debug_macros+[('LIBART_VERSION',LIBART_VERSION)],
+- library_dirs=[]+FT_LIB_DIR,
++ library_dirs=[],
+
+ # libraries to link against
+ libraries=FT_LIB+LIBART_LIB,