summaryrefslogtreecommitdiff
path: root/dev-python/reno
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-02-17 14:07:47 +0000
committerV3n3RiX <venerix@koprulu.sector>2023-02-17 14:07:47 +0000
commit7c9730bcb62df7cbf8248c5db9a478aac52c60ea (patch)
tree3521ee333c83fb6c7ff14d0a0a2d742464e88767 /dev-python/reno
parent29394d0921808a94a409f01eff49f681651de5d5 (diff)
gentoo auto-resync : 17:02:2023 - 14:07:46
Diffstat (limited to 'dev-python/reno')
-rw-r--r--dev-python/reno/Manifest1
-rw-r--r--dev-python/reno/reno-3.5.0-r1.ebuild44
2 files changed, 45 insertions, 0 deletions
diff --git a/dev-python/reno/Manifest b/dev-python/reno/Manifest
index 149fea7f1b9e..f42d9e047cc9 100644
--- a/dev-python/reno/Manifest
+++ b/dev-python/reno/Manifest
@@ -1,3 +1,4 @@
DIST reno-3.5.0.tar.gz 83644 BLAKE2B 803d3d3c9ed572624b77d2851221edcd0a86241f86876970f1a64877d3083b39d8e574567f14dea52680538770a37bc70c55d74b66ddab6fda551209c32bb844 SHA512 4d48ec3faf26d046498edccc0dd6007dff36d8346395b5c62b2b85a8ff9bba5ac571cbdcb2aa8e522b6f4c155bd845a416cc715c30a29e8eae6d033ee1b52be7
+EBUILD reno-3.5.0-r1.ebuild 1137 BLAKE2B 1713fc76bf450f7fc7472d1202bcbc8983bc86ef9ca5fef10d7be101fb2ff02debdf62c880beacda2f54e9a4bc15f1763c73b30220968cde1d57ce55bbff6189 SHA512 f56d2946aa8775ecb5e631656f1072c6a396b5da25cb818daa1e267cc607600d72c69311ceff2626eb3a422620d37d960b72c4c04eea2c672d037625b307e729
EBUILD reno-3.5.0.ebuild 1072 BLAKE2B bc828fd77cebe008f3884f8c130a51a74035ca718974b9332d9b12d61a83cb85c67688cd1a20326b06d75ccd620cd875c639fc08e4a8f523bb7e7a685ab31234 SHA512 8007dc6071edbc7cdf3ade9cc92927dfd90327744e817b17072dbdab84977df06041296aaf99d996acff717b1c17738c01c64627997b91a662c05f7bf29bcec8
MISC metadata.xml 501 BLAKE2B 3c3c1d7026eba72db293c2c7e628cd79127314ac578b1cd2db662e058c0be9b0225b3304dbb0f5b30d38729e6bb495014905ae27c924fcf01b3410e2e7f1a0db SHA512 8944b85dd5a9dbd5419abbd8c70d74d414f987053a9721ec402b047af2e35b2584254d19aede528cb96b8f720f8b92cabb6797ddc2c41ea700c2fa5e3ecef627
diff --git a/dev-python/reno/reno-3.5.0-r1.ebuild b/dev-python/reno/reno-3.5.0-r1.ebuild
new file mode 100644
index 000000000000..af452418d530
--- /dev/null
+++ b/dev-python/reno/reno-3.5.0-r1.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{9..11} )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="Release notes manager, storing release notes in a git repo and building docs"
+HOMEPAGE="
+ https://opendev.org/openstack/reno/
+ https://github.com/openstack/reno/
+ https://pypi.org/project/reno/
+"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~ia64 ~ppc64 ~riscv ~s390 ~x86"
+
+RDEPEND="
+ dev-python/pbr[${PYTHON_USEDEP}]
+ >=dev-python/pyyaml-5.3.1[${PYTHON_USEDEP}]
+ >=dev-python/dulwich-0.15.0[${PYTHON_USEDEP}]
+ >=dev-python/packaging-20.4[${PYTHON_USEDEP}]
+ >=dev-python/docutils-0.11[${PYTHON_USEDEP}]
+ >=dev-python/sphinx-2.1.1[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ dev-python/pbr[${PYTHON_USEDEP}]
+ test? (
+ >=dev-python/testtools-1.4.0[${PYTHON_USEDEP}]
+ )
+"
+
+# The doc needs to be built from a git repository
+distutils_enable_tests unittest
+
+python_prepare_all() {
+ # Some tests need to be run from a git repository
+ rm reno/tests/test_{cache,semver}.py || die
+ distutils-r1_python_prepare_all
+}