summaryrefslogtreecommitdiff
path: root/dev-python/reflink
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2019-01-31 16:00:27 +0000
committerV3n3RiX <venerix@redcorelinux.org>2019-01-31 16:00:27 +0000
commit1db00cc6e94b90c08090bb5b8c406622946c4ae5 (patch)
treec34bf820c2809fb7e08ed5564df2a25cf759516f /dev-python/reflink
parent693cc9b6e847a01c1bb692153021aaf9fb0fab25 (diff)
gentoo resync 31.01.2019
Diffstat (limited to 'dev-python/reflink')
-rw-r--r--dev-python/reflink/Manifest4
-rw-r--r--dev-python/reflink/files/0.2.1-correct-test-deps.patch17
-rw-r--r--dev-python/reflink/metadata.xml15
-rw-r--r--dev-python/reflink/reflink-0.2.1.ebuild46
4 files changed, 82 insertions, 0 deletions
diff --git a/dev-python/reflink/Manifest b/dev-python/reflink/Manifest
new file mode 100644
index 000000000000..6529367e6bf9
--- /dev/null
+++ b/dev-python/reflink/Manifest
@@ -0,0 +1,4 @@
+AUX 0.2.1-correct-test-deps.patch 325 BLAKE2B 33600ee1ffe704b26ba310dcdf4bd75850a6c8805e184f0aa90194600cf1bc6bf3005978ad957dcf2b8f14ea5de31e35f902c6304974f644c755013e4c6451fe SHA512 bafdd031a205891dc171a0ec0f8f62085c15ab7909e405444e88c6fede2f8640bcacc3e9c7f5e99244320770fcbcbf9009fc9da06d838905f7a388f7af124894
+DIST reflink-0.2.1.tar.gz 14638 BLAKE2B a6449ebb27619ead9ff8452df6c48f3617e5f06eb347fbbe14ab00b9a43c01de8e101466288ac6fb73602165d4d4e9315f941c2f28dffe245ed2c39a10a61cf1 SHA512 5995ed787bda93cb46d99a603110768087420edd72c01d5f3f7f08a3f8f63b4629b900a3c173dd7f3119a892ac19ab1a9c3000ddd83810b22a52dfb5fb892a28
+EBUILD reflink-0.2.1.ebuild 1020 BLAKE2B a4d18f27b94032a9e2266ce0e7e0283542ce9d392d592f440980f213463fecc424ca076acc25886aabd85e205c5806539c1e06e7c35f1e24e45e44a4a287bc6f SHA512 822c2e0494959cfdbaba5420170e2c596e0f8125c270501363f95c4c76b445f5e01f14072909289bd18e3f6ae93f1e9892f8f97af47443c61c8dcb1ea22cd1db
+MISC metadata.xml 493 BLAKE2B d7e0d0236537a68ada8c267aa6a2d6803a4f88e82938a73a7bcd0cf9cb5567177745f5fc2c1d81e92f17501672a430439845be6c63b7853cdf927302259bbec5 SHA512 8a4c8db0dc28f8ee0d6bd855554e8cf1f7661f5625f37ee04483fa918ac78d238487f1246dca1c96f647ccb6e9a35bd22b171d659ff06cd616c369d01bfba221
diff --git a/dev-python/reflink/files/0.2.1-correct-test-deps.patch b/dev-python/reflink/files/0.2.1-correct-test-deps.patch
new file mode 100644
index 000000000000..78b1ef8fd94e
--- /dev/null
+++ b/dev-python/reflink/files/0.2.1-correct-test-deps.patch
@@ -0,0 +1,17 @@
+diff --git a/setup.py b/setup.py
+index 234c92b..3ef3237 100644
+--- a/setup.py
++++ b/setup.py
+@@ -20,11 +20,11 @@ requirements = [
+
+ setup_requirements = [
+ 'cffi',
+- 'pytest-runner',
+ ]
+
+ test_requirements = [
+ 'pytest',
++ 'pytest-runner',
+ ]
+
+ if sys.platform not in ['linux', 'linux2', 'win32', 'darwin']:
diff --git a/dev-python/reflink/metadata.xml b/dev-python/reflink/metadata.xml
new file mode 100644
index 000000000000..e3b3aabe2dda
--- /dev/null
+++ b/dev-python/reflink/metadata.xml
@@ -0,0 +1,15 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>gyakovlev@gentoo.org</email>
+ <name>Georgy Yakovlev</name>
+ </maintainer>
+ <longdescription lang="en">
+ Python wrapper around the reflink system calls.
+ Btrfs, XFS, OCFS2 reflink support, Apple macOS APFS clonefile support.
+ </longdescription>
+ <upstream>
+ <remote-id type="pypi">reflink</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-python/reflink/reflink-0.2.1.ebuild b/dev-python/reflink/reflink-0.2.1.ebuild
new file mode 100644
index 000000000000..59c051cb1949
--- /dev/null
+++ b/dev-python/reflink/reflink-0.2.1.ebuild
@@ -0,0 +1,46 @@
+# Copyright 2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python{2_7,3_{4,5,6}} )
+
+inherit distutils-r1
+
+DESCRIPTION="RFC-compliant FQDN validation and manipulation for Python"
+HOMEPAGE="https://gitlab.com/rubdos/pyreflink"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE="doc test"
+
+BDEPEND="dev-python/setuptools[${PYTHON_USEDEP}]
+ doc? ( dev-python/sphinx[${PYTHON_USEDEP}] )
+ test? (
+ dev-python/pytest[${PYTHON_USEDEP}]
+ dev-python/pytest-runner[${PYTHON_USEDEP}]
+ sys-fs/btrfs-progs
+ )
+"
+RDEPEND="virtual/python-cffi[${PYTHON_USEDEP}]"
+DEPEND="${RDEPEND}"
+
+# goes places, like writing to /dev or creating btrfs volumes
+RESTRICT="test"
+
+PATCHES=( "${FILESDIR}/${PV}-correct-test-deps.patch" )
+
+python_compile_all() {
+ use doc && emake -C docs html
+}
+
+python_install_all() {
+ use doc && local HTML_DOCS=( docs/_build/html/. )
+ distutils-r1_python_install_all
+}
+
+python_test() {
+ esetup.py test
+}