summaryrefslogtreecommitdiff
path: root/dev-python/redis
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2024-03-30 19:13:59 +0000
committerV3n3RiX <venerix@koprulu.sector>2024-03-30 19:13:59 +0000
commita40f8cd35ca0e91929e52f40825a390bd16a626c (patch)
tree4e14e83d52541d7c7466e389678cc81cd6ac2866 /dev-python/redis
parentbe3b27c21c5761f8ff9688e4d468045abaddb9c4 (diff)
gentoo auto-resync : 30:03:2024 - 19:13:59
Diffstat (limited to 'dev-python/redis')
-rw-r--r--dev-python/redis/Manifest4
-rw-r--r--dev-python/redis/redis-5.0.2.ebuild95
-rw-r--r--dev-python/redis/redis-5.0.3.ebuild2
3 files changed, 2 insertions, 99 deletions
diff --git a/dev-python/redis/Manifest b/dev-python/redis/Manifest
index d6b1661e2df6..f108b0bd9965 100644
--- a/dev-python/redis/Manifest
+++ b/dev-python/redis/Manifest
@@ -1,5 +1,3 @@
-DIST redis-py-5.0.2.gh.tar.gz 4774000 BLAKE2B 60ca8e11c2896b2f36d09fa494afc3ea039a79eb46a4503d6c5561f16fd9e2779aecb314e79c87e083212b5a619c555615a037f83572bc0a8fe54b8d04e6530b SHA512 1f75f2959737fc4d9e83c1e88cebbaad8801ac1a6113a1275b6461c657136f6f561d8ac8c5a62ba3f1d7f5463c416aa6351f8150b983505e7b0a93e3e8b4b354
DIST redis-py-5.0.3.gh.tar.gz 4774007 BLAKE2B f1b53319f76fd15af28941d643a333e7556f4701b46d218872a17200a867ba71c5fe72a092e00ac68ca811f41409a1e2eef05a235d2fcb6ba455cef225cd47c5 SHA512 be7158062e905ff3f61fc2b311b1288e53f494de1734dd5a58a34250754de635b9bf125900621b7b6ad8c67d8020b88ca3ae07af2626459acaf77db5f228222c
-EBUILD redis-5.0.2.ebuild 2682 BLAKE2B 275a2bb562c2335fea0d7b8194a36db0992f2c3cd1d67e337434749fc627eb619ce124bcda3e9abcaedbb7ea050843bf0e3d8a091622b6186e80562d91c847f9 SHA512 417e564a44ba1130110c5324628d5d6e7cccf3709d55d497eceb7b5d3b091fee45c6f30d04c08cb6ca9c27a4c5505bd4b08cb0a5258f8d033ce2d597f2d19a4c
-EBUILD redis-5.0.3.ebuild 2723 BLAKE2B a2c0c45831ccd3f17dac8f2ce36c4a2075e9ac709e0e7968cabe10d38aa5e82d4611913d8f0459167b235d7e335c3b96a0803d7f682a268cc51eb91c0ffea3c7 SHA512 6d26f66a122e90983730a7145e9e4c809253f8e0be4ceaf9fcb5545fdacab9c9c4c1dbbcfe0e3781c925d058e84c0f133e9ebadf5ea9ccaa76a08df02579e1d9
+EBUILD redis-5.0.3.ebuild 2717 BLAKE2B eb9da475b7350a4392de80e4e008c788fd83c5df5145417c9b48d32a1dab4c5968017e409f2e812c29286456dccd558efa7d909c49b232782f3c0d02f9670567 SHA512 646abbb80ed4b3fbe84c830da4940fbe1a2b6ca05e7758aad55cbef0cbb567f6273b247c8e8a715543316a37fea231e00f5069afb74e2e98536421413a68c93b
MISC metadata.xml 506 BLAKE2B 0e5747e826132dd365bdf6d3a63f0936ed476bc69c4c4d55126e692039046f51f69b193ead0baa181090b11f69ab2a49220d8f906f9fe3fc18331b76ff9e0b0f SHA512 725d650bfe345b132588930a18ade44182ec07f6697d2fd8806dc208ab1556939926e8899fc6d43691101d971f9c1e011fb8a5675fdde4698dbf4c230db15c75
diff --git a/dev-python/redis/redis-5.0.2.ebuild b/dev-python/redis/redis-5.0.2.ebuild
deleted file mode 100644
index c2e9edec6cdd..000000000000
--- a/dev-python/redis/redis-5.0.2.ebuild
+++ /dev/null
@@ -1,95 +0,0 @@
-# Copyright 1999-2024 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-DISTUTILS_USE_PEP517=setuptools
-PYTHON_COMPAT=( python3_{10..12} pypy3 )
-
-inherit distutils-r1
-
-MY_P=redis-py-${PV}
-DESCRIPTION="Python client for Redis key-value store"
-HOMEPAGE="
- https://github.com/redis/redis-py/
- https://pypi.org/project/redis/
-"
-SRC_URI="
- https://github.com/redis/redis-py/archive/v${PV}.tar.gz
- -> ${MY_P}.gh.tar.gz
-"
-S=${WORKDIR}/${MY_P}
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="amd64 arm arm64 ~hppa ppc ppc64 ~riscv ~sparc x86"
-
-RDEPEND="
- >=dev-python/async-timeout-4.0.2[${PYTHON_USEDEP}]
-"
-BDEPEND="
- test? (
- dev-db/redis
- dev-python/pytest-asyncio[${PYTHON_USEDEP}]
- dev-python/pytest-timeout[${PYTHON_USEDEP}]
- )
-"
-
-distutils_enable_tests pytest
-
-python_test() {
- local EPYTEST_DESELECT=(
- # Flaky test
- tests/test_pubsub.py::TestPubSubDeadlock::test_pubsub_deadlock
- # require extra redis modules that apparently aren't packaged
- # on Gentoo
- tests/{,test_asyncio/}test_bloom.py
- tests/{,test_asyncio/}test_graph.py
- tests/{,test_asyncio/}test_json.py
- tests/{,test_asyncio/}test_timeseries.py
- # apparently available only in "Redis Stack 7.2 RC3 or later"
- tests/test_commands.py::TestRedisCommands::test_tfunction_load_delete
- tests/test_commands.py::TestRedisCommands::test_tfunction_list
- tests/test_commands.py::TestRedisCommands::test_tfcall
- # TODO
- tests/test_commands.py::TestRedisCommands::test_zrank_withscore
- tests/test_commands.py::TestRedisCommands::test_zrevrank_withscore
- tests/test_commands.py::TestRedisCommands::test_xinfo_consumers
- tests/test_asyncio/test_commands.py::TestRedisCommands::test_zrank_withscore
- tests/test_asyncio/test_commands.py::TestRedisCommands::test_zrevrank_withscore
- tests/test_asyncio/test_commands.py::TestRedisCommands::test_xinfo_consumers
- tests/test_asyncio/test_pubsub.py::TestPubSubAutoReconnect::test_reconnect_socket_error[pool-hiredis-listen]
- )
-
- # TODO: try to run more servers?
- epytest -m "not redismod and not onlycluster and not replica and not ssl"
-}
-
-src_test() {
- local redis_pid="${T}"/redis.pid
- local redis_port=6379
-
- if has_version ">=dev-db/redis-7"; then
- local extra_conf="
- enable-debug-command yes
- enable-module-command yes
- "
- fi
-
- # Spawn Redis itself for testing purposes
- einfo "Spawning Redis"
- einfo "NOTE: Port ${redis_port} must be free"
- "${EPREFIX}"/usr/sbin/redis-server - <<- EOF || die "Unable to start redis server"
- daemonize yes
- pidfile ${redis_pid}
- port ${redis_port}
- bind 127.0.0.1 ::1
- ${extra_conf}
- EOF
-
- # Run the tests
- distutils-r1_src_test
-
- # Clean up afterwards
- kill "$(<"${redis_pid}")" || die
-}
diff --git a/dev-python/redis/redis-5.0.3.ebuild b/dev-python/redis/redis-5.0.3.ebuild
index c3596deb755c..023d2a7d8947 100644
--- a/dev-python/redis/redis-5.0.3.ebuild
+++ b/dev-python/redis/redis-5.0.3.ebuild
@@ -22,7 +22,7 @@ S=${WORKDIR}/${MY_P}
LICENSE="MIT"
SLOT="0"
-KEYWORDS="~amd64 ~arm ~arm64 ~hppa ~ppc ~ppc64 ~riscv ~sparc ~x86"
+KEYWORDS="amd64 arm arm64 ~hppa ppc ppc64 ~riscv ~sparc x86"
RDEPEND="
$(python_gen_cond_dep '