summaryrefslogtreecommitdiff
path: root/dev-python/redis
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-08-21 15:44:13 +0100
committerV3n3RiX <venerix@koprulu.sector>2023-08-21 15:44:13 +0100
commit7d52991b5dce3a07be15d3cbbf06abb3fc08cb9c (patch)
treed01066a68df91636e424d940eab767df96d6f51a /dev-python/redis
parent28e28adc401b344fa5c230e2609c542873c372f8 (diff)
gentoo auto-resync : 21:08:2023 - 15:44:13
Diffstat (limited to 'dev-python/redis')
-rw-r--r--dev-python/redis/Manifest2
-rw-r--r--dev-python/redis/redis-5.0.0.ebuild105
2 files changed, 107 insertions, 0 deletions
diff --git a/dev-python/redis/Manifest b/dev-python/redis/Manifest
index 68d55fbaf76a..c0370542c05d 100644
--- a/dev-python/redis/Manifest
+++ b/dev-python/redis/Manifest
@@ -1,3 +1,5 @@
DIST redis-py-4.5.5.gh.tar.gz 4748642 BLAKE2B 6e924477be81af995190328b8747e2eac3d905fcff8cd97c6f89702e3888a4185918144cf11b9173b25dd4c2e62ce988e2f1f5b2c1261bb35e64031772a5a81a SHA512 f1d8f1b009f30613776904cef42a090a51da2833d667d47f9650c9a35187d11911d5b23b20f2ba2279714758963830c873473028775f39419e4d996da54eee83
+DIST redis-py-5.0.0.gh.tar.gz 4767898 BLAKE2B 0dc1fcafe7ad82c00bf634e19b5afb7201f39dfd26dfcce398fbc40cff79fe03d3e2ecc2acccebf1405700fb72fc5894ce1b8438b55e6c10d52ec08124da50cb SHA512 24133be64b73a58edd7b0361a8b168b67f0e783576aaf0007f4b4b8d6032a227d6ebc7319c89fc323fc72ef1063e4a899d9a8be9eaa833d347345a59a65fff31
EBUILD redis-4.5.5.ebuild 1905 BLAKE2B 42ca13a233cb4fbc6e5cc72e1a519a143d6846c16e3082953e8b6706524a3d4442eec01dc3e60a150f47bc2040fbf1fecdbd621108c1c03674a6ed1a3ed11855 SHA512 f6d2b8f8d45f426807256e39f43517cb6736ad0ca7b96b0d617f539236811ba93a0ea46688f758675cd931e0e8677e76b2ed6bda97ebb985819d1cf06b8bf635
+EBUILD redis-5.0.0.ebuild 2706 BLAKE2B 517046ed349aa80ee74c11252dccfe71afc76197d0a41c76a8fc176b6e4ea44f0ed904d25efce5de878665dd6f91bd5d8fd43c33c96ec508f05dbb2ff3306ddc SHA512 e926bff6d6d911228c336d4f7b1c360b1f11df7a5035389021d55d7c4ba9e7cddf3bf0f509564e83b32fa3e40642849573eb805a6a95db76235161ebe2273854
MISC metadata.xml 506 BLAKE2B 0e5747e826132dd365bdf6d3a63f0936ed476bc69c4c4d55126e692039046f51f69b193ead0baa181090b11f69ab2a49220d8f906f9fe3fc18331b76ff9e0b0f SHA512 725d650bfe345b132588930a18ade44182ec07f6697d2fd8806dc208ab1556939926e8899fc6d43691101d971f9c1e011fb8a5675fdde4698dbf4c230db15c75
diff --git a/dev-python/redis/redis-5.0.0.ebuild b/dev-python/redis/redis-5.0.0.ebuild
new file mode 100644
index 000000000000..00bec2d400ad
--- /dev/null
+++ b/dev-python/redis/redis-5.0.0.ebuild
@@ -0,0 +1,105 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..12} pypy3 )
+
+inherit distutils-r1
+
+MY_P=redis-py-${PV}
+DESCRIPTION="Python client for Redis key-value store"
+HOMEPAGE="
+ https://github.com/redis/redis-py/
+ https://pypi.org/project/redis/
+"
+SRC_URI="
+ https://github.com/redis/redis-py/archive/v${PV}.tar.gz
+ -> ${MY_P}.gh.tar.gz
+"
+S=${WORKDIR}/${MY_P}
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~hppa ~ppc ~ppc64 ~riscv ~sparc ~x86"
+
+RDEPEND="
+ $(python_gen_cond_dep '
+ >=dev-python/async-timeout-4.0.2[${PYTHON_USEDEP}]
+ ' 3.{9..10})
+"
+BDEPEND="
+ test? (
+ dev-db/redis
+ dev-python/pytest-asyncio[${PYTHON_USEDEP}]
+ dev-python/pytest-timeout[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+python_test() {
+ local EPYTEST_DESELECT=(
+ # Flaky test
+ tests/test_pubsub.py::TestPubSubDeadlock::test_pubsub_deadlock
+ # require extra redis modules that apparently aren't packaged
+ # on Gentoo
+ tests/test_bloom.py
+ tests/test_graph.py
+ tests/test_json.py
+ tests/test_timeseries.py
+ # apparently available only in "Redis Stack 7.2 RC3 or later"
+ tests/test_commands.py::TestRedisCommands::test_tfunction_load_delete
+ tests/test_commands.py::TestRedisCommands::test_tfunction_list
+ tests/test_commands.py::TestRedisCommands::test_tfcall
+ # TODO
+ tests/test_commands.py::TestRedisCommands::test_zrank_withscore
+ tests/test_commands.py::TestRedisCommands::test_zrevrank_withscore
+ tests/test_commands.py::TestRedisCommands::test_xinfo_consumers
+ tests/test_asyncio/test_commands.py::TestRedisCommands::test_zrank_withscore
+ tests/test_asyncio/test_commands.py::TestRedisCommands::test_zrevrank_withscore
+ tests/test_asyncio/test_commands.py::TestRedisCommands::test_xinfo_consumers
+ )
+
+ case ${EPYTHON} in
+ python3.12)
+ EPYTEST_DESELECT+=(
+ tests/test_asyncio/test_connect.py
+ tests/test_asyncio/test_cwe_404.py
+ )
+ ;;
+ esac
+
+ # TODO: try to run more servers?
+ epytest -m "not redismod and not onlycluster and not replica and not ssl"
+}
+
+src_test() {
+ local redis_pid="${T}"/redis.pid
+ local redis_port=6379
+
+ if has_version ">=dev-db/redis-7"; then
+ local extra_conf="
+ enable-debug-command yes
+ enable-module-command yes
+ "
+ fi
+
+ # Spawn Redis itself for testing purposes
+ einfo "Spawning Redis"
+ einfo "NOTE: Port ${redis_port} must be free"
+ "${EPREFIX}"/usr/sbin/redis-server - <<- EOF || die "Unable to start redis server"
+ daemonize yes
+ pidfile ${redis_pid}
+ port ${redis_port}
+ bind 127.0.0.1 ::1
+ ${extra_conf}
+ EOF
+
+ # Run the tests
+ distutils-r1_src_test
+
+ # Clean up afterwards
+ kill "$(<"${redis_pid}")" || die
+}