summaryrefslogtreecommitdiff
path: root/dev-python/recurring-ical-events
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2024-09-11 12:30:55 +0100
committerV3n3RiX <venerix@koprulu.sector>2024-09-11 12:30:55 +0100
commit65a36438d5b824f80023c282dadc3fcd5736b526 (patch)
tree12aedb23736e7cceba662d217cdd7f0f2a2662ba /dev-python/recurring-ical-events
parentadd278b9601ff9e4af091c91c851ee46a185be8f (diff)
gentoo auto-resync : 11:09:2024 - 12:30:54
Diffstat (limited to 'dev-python/recurring-ical-events')
-rw-r--r--dev-python/recurring-ical-events/Manifest2
-rw-r--r--dev-python/recurring-ical-events/recurring-ical-events-3.3.0.ebuild45
2 files changed, 47 insertions, 0 deletions
diff --git a/dev-python/recurring-ical-events/Manifest b/dev-python/recurring-ical-events/Manifest
index 565f4f111bd0..c9af8c585202 100644
--- a/dev-python/recurring-ical-events/Manifest
+++ b/dev-python/recurring-ical-events/Manifest
@@ -1,5 +1,7 @@
DIST python-recurring-ical-events-3.1.1.gh.tar.gz 438998 BLAKE2B 9a141e697444278fd5f41e94e3ab2b12308b38f9c7aaca264e65ffccf9328a36cb67a0e2ed4dbf7dd3abccabf400762184570b62185d39428b0d6c11682d7305 SHA512 3ea995bd56430f9322d888559567dc809552cb6752f4a2acc4e33e385d730b91aa4a2d2389f3ab1ac9dfb5c7eb09327cfc9e858dd06671f7a1c30d39a30e7767
DIST python-recurring-ical-events-3.2.0.gh.tar.gz 439359 BLAKE2B 10b72e24d97dff1b7d0883a2da632facf1d89945447540acbb64e1f61c490870458bd5c9d389484fbc1be562a88232baf9817dce5be3adc5628e7367b5bef5c5 SHA512 27b9e4e5ed84ad94a1ca12c03995a17ff9db933d98c38f9c34c9cd33fe524e80b55a1507f0e2800b9d027e8030904a06ce05aee596d6d93d2d69ed8ab1ea9046
+DIST python-recurring-ical-events-3.3.0.gh.tar.gz 472075 BLAKE2B 70f531550a8d766e027fb9416883880385731c8b72a4115e2311024bfc4eac8fc7e8b06dc079309430e8d9da6d725c3e2efce8ce7e1ae93ca7f1d1cd288ff41b SHA512 d414d2b035c80d46fa7ea63c9df995edf632841b4f2bd9072d9004a2aaf8a9468de276330c5f939f172a93121577bfd1402606b9fab525af9aa662cd49c16501
EBUILD recurring-ical-events-3.1.1.ebuild 1057 BLAKE2B e96f600f7e031826bc691cda6a9b00947b1b72acb119b5469471cfcec45cc3c308394c2c42b05bffce131dce411da50cdf1e8693b035b0d1402a2f5d59adf1b8 SHA512 ce91f1daa472dc13d5f3023eb8bfdcd90715dd277296d14743e342a7ff368372a798ca27ccc11034d2de834476d403f4f181737fb09b6fd6594ccc3fa1a0a1e2
EBUILD recurring-ical-events-3.2.0.ebuild 1057 BLAKE2B e96f600f7e031826bc691cda6a9b00947b1b72acb119b5469471cfcec45cc3c308394c2c42b05bffce131dce411da50cdf1e8693b035b0d1402a2f5d59adf1b8 SHA512 ce91f1daa472dc13d5f3023eb8bfdcd90715dd277296d14743e342a7ff368372a798ca27ccc11034d2de834476d403f4f181737fb09b6fd6594ccc3fa1a0a1e2
+EBUILD recurring-ical-events-3.3.0.ebuild 1057 BLAKE2B e96f600f7e031826bc691cda6a9b00947b1b72acb119b5469471cfcec45cc3c308394c2c42b05bffce131dce411da50cdf1e8693b035b0d1402a2f5d59adf1b8 SHA512 ce91f1daa472dc13d5f3023eb8bfdcd90715dd277296d14743e342a7ff368372a798ca27ccc11034d2de834476d403f4f181737fb09b6fd6594ccc3fa1a0a1e2
MISC metadata.xml 431 BLAKE2B 19ac0f0a385fb9b0524bf641831fbe3c02f35f3ada35922b297563f871cb8e745404e04d18d9f7428ef5b3cca27f5205f4a7f99e85e2a3da18542a19574f04de SHA512 35283cfbd447b3ec9d0d97ec7c11580db012ee60076b12ba733962d58896203a162ece04a9015eca8cc556f28fac307fc9ddeb27c3ea9cb9c8b2d6df0cf93a50
diff --git a/dev-python/recurring-ical-events/recurring-ical-events-3.3.0.ebuild b/dev-python/recurring-ical-events/recurring-ical-events-3.3.0.ebuild
new file mode 100644
index 000000000000..6c85248725e5
--- /dev/null
+++ b/dev-python/recurring-ical-events/recurring-ical-events-3.3.0.ebuild
@@ -0,0 +1,45 @@
+# Copyright 2023-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..13} )
+
+inherit distutils-r1
+
+MY_P=python-${P}
+DESCRIPTION="Repeat ICalendar events by RRULE, RDATE and EXDATE"
+HOMEPAGE="
+ https://github.com/niccokunzmann/python-recurring-ical-events/
+ https://pypi.org/project/recurring-ical-events/
+"
+SRC_URI="
+ https://github.com/niccokunzmann/python-recurring-ical-events/archive/v${PV}.tar.gz
+ -> ${MY_P}.gh.tar.gz
+"
+S=${WORKDIR}/${MY_P}
+
+LICENSE="LGPL-3+"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~x86"
+
+RDEPEND="
+ <dev-python/icalendar-7[${PYTHON_USEDEP}]
+ >=dev-python/icalendar-5.0.9[${PYTHON_USEDEP}]
+ >=dev-python/python-dateutil-2.8.1[${PYTHON_USEDEP}]
+ <dev-python/x-wr-timezone-1.0.0[${PYTHON_USEDEP}]
+ >=dev-python/x-wr-timezone-0.0.5[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ >=dev-python/icalendar-6[${PYTHON_USEDEP}]
+ >=dev-python/pytz-2023.3[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+EPYTEST_IGNORE=(
+ test/test_readme.py
+)