summaryrefslogtreecommitdiff
path: root/dev-python/rebulk/rebulk-3.2.0.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-02-19 08:13:24 +0000
committerV3n3RiX <venerix@koprulu.sector>2023-02-19 08:13:24 +0000
commitfd089c26c06476b291a5255011ee378561c2615d (patch)
tree399fe09e6963d1ae925dd682eabcc3fab873daf7 /dev-python/rebulk/rebulk-3.2.0.ebuild
parent1aa99ecc93a15a428a88197dd05d97bcd33102b7 (diff)
gentoo auto-resync : 19:02:2023 - 08:13:24
Diffstat (limited to 'dev-python/rebulk/rebulk-3.2.0.ebuild')
-rw-r--r--dev-python/rebulk/rebulk-3.2.0.ebuild32
1 files changed, 32 insertions, 0 deletions
diff --git a/dev-python/rebulk/rebulk-3.2.0.ebuild b/dev-python/rebulk/rebulk-3.2.0.ebuild
new file mode 100644
index 000000000000..2040332eb271
--- /dev/null
+++ b/dev-python/rebulk/rebulk-3.2.0.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{9..11} )
+
+inherit distutils-r1
+
+DESCRIPTION="Python library that performs advanced searches in strings"
+HOMEPAGE="
+ https://github.com/Toilal/rebulk/
+ https://pypi.org/project/rebulk/
+"
+SRC_URI="
+ https://github.com/Toilal/rebulk/archive/v${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="MIT Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~x86"
+
+distutils_enable_tests pytest
+
+python_prepare_all() {
+ # Remove base64-encoded zip archive with pytest.
+ rm runtests.py || die
+
+ distutils-r1_python_prepare_all
+}