summaryrefslogtreecommitdiff
path: root/dev-python/re-assert
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-06-29 12:04:12 +0100
committerV3n3RiX <venerix@koprulu.sector>2022-06-29 12:04:12 +0100
commit0f558761aa2dee1017b4751e4017205e015a9560 (patch)
tree037df795519468a25d9362b4e95cdaeb84eb1cf9 /dev-python/re-assert
parent752d6256e5204b958b0ef7905675a940b5e9172f (diff)
gentoo resync : 29.12.2022
Diffstat (limited to 'dev-python/re-assert')
-rw-r--r--dev-python/re-assert/Manifest2
-rw-r--r--dev-python/re-assert/re-assert-1.1.0-r1.ebuild (renamed from dev-python/re-assert/re-assert-1.1.0.ebuild)18
2 files changed, 14 insertions, 6 deletions
diff --git a/dev-python/re-assert/Manifest b/dev-python/re-assert/Manifest
index a0bf2387e602..5f81a1b2ab64 100644
--- a/dev-python/re-assert/Manifest
+++ b/dev-python/re-assert/Manifest
@@ -1,3 +1,3 @@
DIST re-assert-1.1.0.gh.tar.gz 5010 BLAKE2B fc65f43b3525d02d877d51f0a1556b6b205dd1126fc205b775f5c0b6c34ee7c3e8d224fc3f46a80e8df4a366674be90221e891e19e12072c87ff82451ca8676c SHA512 fc14267cc68a12ff7350982f0bf54c77107809c9f0379ab3aa73fa1b7cf5ccabb130fcd35ab75bdf183e69c802a041deac707e1f0bab1c3815d4146b4e320c07
-EBUILD re-assert-1.1.0.ebuild 572 BLAKE2B 114316530def4015d6252051453669b59b724b6c7fb752ebc0fe1f6e20fe7e40c7c2f97c70f4b4918996bf5f63b34c633b35369d5d73baacf70a6bae1238eaf4 SHA512 af5ed428087ef1fed19eaeefd54d49a3e6422f527ba3dfa281bc6a615dfe85ce0c7f9d8158ca48caed997c8e8dcab937eac2f9f365a8cd942ff36d107015e1ca
+EBUILD re-assert-1.1.0-r1.ebuild 650 BLAKE2B 38276ca45bb45547be1d5dd6d157d907b9f33438b704641507fb324471ab33952c58b01def083ac838b32b8961d259c7d3af8501910e48f8e54c5dcb84a76987 SHA512 f16845687aaa622f92ffc725b621a54de392ea66a8c323eda21eb7672bf11653b4ab0a47670c39d3b4138a4b05da7b024ff71748c729e2f961f9566de5bc22f4
MISC metadata.xml 395 BLAKE2B dba34f6404c171596f781768e266b2e3ae21b2572db8695c6d17ffac5cfd91ea63ade4dac01b4961a5b691090ad6940d11cc82b629e6abc71e7b393c70e1f572 SHA512 f6c637f1fd777a2382954939e57c07aba53287f9a148ff19c6444ef249d87ac0e1d003b8ec2c2bbf396f756169dac2205bf597f16f5334a4f94e0032a08fe299
diff --git a/dev-python/re-assert/re-assert-1.1.0.ebuild b/dev-python/re-assert/re-assert-1.1.0-r1.ebuild
index 63d0e6096c9f..4826d5328163 100644
--- a/dev-python/re-assert/re-assert-1.1.0.ebuild
+++ b/dev-python/re-assert/re-assert-1.1.0-r1.ebuild
@@ -1,21 +1,29 @@
# Copyright 2020-2022 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=7
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..11} pypy3 )
-PYTHON_COMPAT=( python3_{8..10} pypy3 )
inherit distutils-r1
DESCRIPTION="Show where your regex match assertion failed"
-HOMEPAGE="https://github.com/asottile/re-assert"
+HOMEPAGE="
+ https://github.com/asottile/re-assert/
+ https://pypi.org/project/re-assert/
+"
SRC_URI="
https://github.com/asottile/re-assert/archive/v${PV}.tar.gz
- -> ${P}.gh.tar.gz"
+ -> ${P}.gh.tar.gz
+"
LICENSE="MIT"
SLOT="0"
KEYWORDS="~alpha amd64 arm arm64 hppa ~ia64 ~loong ppc ppc64 ~riscv ~s390 sparc x86 ~x64-macos"
-RDEPEND="dev-python/regex[${PYTHON_USEDEP}]"
+RDEPEND="
+ dev-python/regex[${PYTHON_USEDEP}]
+"
distutils_enable_tests pytest