summaryrefslogtreecommitdiff
path: root/dev-python/rdflib
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /dev-python/rdflib
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'dev-python/rdflib')
-rw-r--r--dev-python/rdflib/Manifest5
-rw-r--r--dev-python/rdflib/metadata.xml15
-rw-r--r--dev-python/rdflib/rdflib-4.2.1.ebuild85
-rw-r--r--dev-python/rdflib/rdflib-4.2.2.ebuild88
4 files changed, 193 insertions, 0 deletions
diff --git a/dev-python/rdflib/Manifest b/dev-python/rdflib/Manifest
new file mode 100644
index 000000000000..84cc3afa7343
--- /dev/null
+++ b/dev-python/rdflib/Manifest
@@ -0,0 +1,5 @@
+DIST rdflib-4.2.1.tar.gz 889467 BLAKE2B cc5f675646ca7a55ff40d4d98eb138953d8763d8b44b5b495cdc9bb83df16d425214bb681f8f841e053a3cb4d52edd30988afcf2c301a96f699a70d9c129cca5 SHA512 49145f80a9e027847523faed059c16ec1de358bb9d8fc3ab4fd3bf95a88dd181986b1785deedf6e837cf0b064bd74ab8e27fbb5581e33310353da3546ae7b016
+DIST rdflib-4.2.2.tar.gz 905094 BLAKE2B fe17b5752f67c745bfdf4a160c2f5d49da19f0d85b6eddc4a65fa0ddb660de8bcc19c3ccecf893fb67f725b973cb94481374d9ee0c82072416a93e44952dba9b SHA512 efc24d8ce1080e59950cecc9c779ae0d63673c8690f74db1772f6c2dbf24d6f4de5214d5870a074bffe549b42d8d5f5d131df29bbfd174b763ae1f843aec7d5c
+EBUILD rdflib-4.2.1.ebuild 2684 BLAKE2B 7683c11fcc2cc52eab51ff618131bd334b969e93fec1a5267376a04928187a5348b1c8287939d385d7e74372dbe101d8c1fff0a7ab7d7bcddfbd79c4691aa13d SHA512 8f52696ab3e53ae1367ee75141c0866fac7fab5d9ac4aa87a02c796c206f3d9f3cea2818298a4a3ca4dc2524175bdb3ba34f40726be4d1a51f4d4cac138f0f38
+EBUILD rdflib-4.2.2.ebuild 2714 BLAKE2B 81f918e766311059476025f74194b1ef2f06391c6e1ee3bdbe78060d28ad90cbc8e7c0e9c74c2de944be43f3fec2037d0e706e2e5a68a7a1a485409984ac909b SHA512 ce4c1925b9e87c9717416e64fa5dea45b52cbe501c66a9e64d281081fec6c32b453398b5dfcf9c5615a081ca9aefe6133d9e2647c549833160b55c329303cd7d
+MISC metadata.xml 462 BLAKE2B a2b02fb03f0966423a2354b593cee26c55aca5d28df913d6bbe9ba0731b093c5499568829736b86d8440c173f40059041905fe49e0a7de3cc5df32ae186241ff SHA512 d9b717e12472862a9071d3d2ad3efffcc053f6890a9a307f882040f77e7304addf30fdceaf94b9a752de5daaf7eae21a68d39311f9997bc1e99c598b5093fd78
diff --git a/dev-python/rdflib/metadata.xml b/dev-python/rdflib/metadata.xml
new file mode 100644
index 000000000000..0f9dc9bd02e5
--- /dev/null
+++ b/dev-python/rdflib/metadata.xml
@@ -0,0 +1,15 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>python@gentoo.org</email>
+ <name>Python</name>
+ </maintainer>
+ <use>
+ <flag name="redland">enable support for Redland triplestore</flag>
+ </use>
+ <upstream>
+ <remote-id type="pypi">rdflib</remote-id>
+ <remote-id type="github">RDFLib/rdflib</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-python/rdflib/rdflib-4.2.1.ebuild b/dev-python/rdflib/rdflib-4.2.1.ebuild
new file mode 100644
index 000000000000..58fbcff35e9c
--- /dev/null
+++ b/dev-python/rdflib/rdflib-4.2.1.ebuild
@@ -0,0 +1,85 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+PYTHON_COMPAT=( python{2_7,3_4,3_5} )
+PYTHON_REQ_USE="sqlite?,threads(+)"
+
+# The usual required for tests
+DISTUTILS_IN_SOURCE_BUILD=1
+
+inherit distutils-r1
+
+DESCRIPTION="RDF library containing a triple store and parser/serializer"
+HOMEPAGE="https://github.com/RDFLib/rdflib https://pypi.org/project/rdflib/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="alpha amd64 arm ia64 ~mips ppc ppc64 sparc x86 ~amd64-linux ~x86-linux"
+IUSE="doc berkdb examples mysql redland sqlite test"
+
+RDEPEND="
+ dev-python/isodate[${PYTHON_USEDEP}]
+ dev-python/html5lib[${PYTHON_USEDEP}]
+ dev-python/pyparsing[${PYTHON_USEDEP}]
+ berkdb? ( dev-python/bsddb3[${PYTHON_USEDEP}] )
+ mysql? ( dev-python/mysql-python[$(python_gen_usedep python2_7)] )
+ redland? ( dev-libs/redland-bindings[python,$(python_gen_usedep python2_7)] )"
+DEPEND="${RDEPEND}
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ test? ( dev-python/sparql-wrapper[${PYTHON_USEDEP}]
+ >=dev-python/nose-1.3.1-r1[${PYTHON_USEDEP}] )"
+
+python_prepare_all() {
+ # Upstream manufactured .pyc files which promptly break distutils' src_test
+ find -name "*.py[oc~]" -delete || die
+
+ # Bug 358189; take out tests that attempt to connect to the network
+ sed -e "/'--with-doctest',/d" -e "/'--doctest-extension=.doctest',/d" \
+ -e "/'--doctest-tests',/d" -i run_tests.py || die
+
+ sed -e "s: 'sphinx.ext.intersphinx',::" -i docs/conf.py || die
+
+ # doc build requires examples folder at the upper level of docs
+ if use doc; then
+ cd docs || die
+ ln -sf ../examples . || die
+ cd ../ || die
+ fi
+
+ distutils-r1_python_prepare_all
+}
+
+python_compile_all() {
+ # https://github.com/RDFLib/rdflib/issues/510
+ if use doc; then
+ einfo ""; einfo "Several warnings and Errors present in the build"
+ einfo "For a complete build, it is required to install"
+ einfo "github.com/gjhiggins/n3_pygments_lexer and"
+ einfo "github.com/gjhiggins/sparql_pygments_lexer"
+ einfo "outside portage via pip or by cloning. These have not been"
+ einfo "given a tagged release by the author and are not in portage"
+ einfo ""
+ emake -C docs html
+ fi
+}
+
+python_test() {
+ # the default; nose with: --where=./ does not work for python3
+ if python_is_python3; then
+ pushd "${BUILD_DIR}/src/" > /dev/null
+ "${PYTHON}" ./run_tests.py || die "Tests failed under ${EPYTHON}"
+ popd > /dev/null
+ else
+ "${PYTHON}" ./run_tests.py || die "Tests failed under ${EPYTHON}"
+ fi
+}
+
+python_install_all() {
+ use doc && local HTML_DOCS=( docs/_build/html/. )
+ use examples && local EXAMPLES=( examples/. )
+
+ distutils-r1_python_install_all
+}
diff --git a/dev-python/rdflib/rdflib-4.2.2.ebuild b/dev-python/rdflib/rdflib-4.2.2.ebuild
new file mode 100644
index 000000000000..7d4375d15c6f
--- /dev/null
+++ b/dev-python/rdflib/rdflib-4.2.2.ebuild
@@ -0,0 +1,88 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python{2_7,3_{4,5,6}} )
+PYTHON_REQ_USE="sqlite?,threads(+)"
+
+# The usual required for tests
+DISTUTILS_IN_SOURCE_BUILD=1
+
+inherit distutils-r1
+
+DESCRIPTION="RDF library containing a triple store and parser/serializer"
+HOMEPAGE="https://github.com/RDFLib/rdflib https://pypi.org/project/rdflib/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="alpha amd64 arm ~hppa ia64 ~mips ppc ppc64 sparc x86 ~amd64-linux ~x86-linux"
+IUSE="doc berkdb examples mysql redland sqlite test"
+
+RDEPEND="
+ dev-python/isodate[${PYTHON_USEDEP}]
+ dev-python/html5lib[${PYTHON_USEDEP}]
+ dev-python/pyparsing[${PYTHON_USEDEP}]
+ berkdb? ( dev-python/bsddb3[${PYTHON_USEDEP}] )
+ mysql? ( dev-python/mysql-python[$(python_gen_usedep python2_7)] )
+ redland? ( dev-libs/redland-bindings[python,$(python_gen_usedep python2_7)] )"
+DEPEND="${RDEPEND}
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ test? ( dev-python/sparql-wrapper[${PYTHON_USEDEP}]
+ >=dev-python/nose-1.3.1-r1[${PYTHON_USEDEP}] )"
+
+python_prepare_all() {
+ # Upstream manufactured .pyc files which promptly break distutils' src_test
+ find -name "*.py[oc~]" -delete || die
+
+ # Bug 358189; take out tests that attempt to connect to the network
+ sed -e "/'--with-doctest',/d" -e "/'--doctest-extension=.doctest',/d" \
+ -e "/'--doctest-tests',/d" -i run_tests.py || die
+
+ sed -e "s: 'sphinx.ext.intersphinx',::" -i docs/conf.py || die
+
+ # doc build requires examples folder at the upper level of docs
+ if use doc; then
+ cd docs || die
+ ln -sf ../examples . || die
+ cd ../ || die
+ fi
+
+ distutils-r1_python_prepare_all
+}
+
+python_compile_all() {
+ # https://github.com/RDFLib/rdflib/issues/510
+ if use doc; then
+ einfo ""; einfo "Several warnings and Errors present in the build"
+ einfo "For a complete build, it is required to install"
+ einfo "github.com/gjhiggins/n3_pygments_lexer and"
+ einfo "github.com/gjhiggins/sparql_pygments_lexer"
+ einfo "outside portage via pip or by cloning. These have not been"
+ einfo "given a tagged release by the author and are not in portage"
+ einfo ""
+ emake -C docs html
+ fi
+}
+
+python_test() {
+ # the default; nose with: --where=./ does not work for python3
+ if python_is_python3; then
+ pushd "${BUILD_DIR}/src/" > /dev/null
+ "${PYTHON}" ./run_tests.py || die "Tests failed under ${EPYTHON}"
+ popd > /dev/null
+ else
+ "${PYTHON}" ./run_tests.py || die "Tests failed under ${EPYTHON}"
+ fi
+}
+
+python_install_all() {
+ use doc && local HTML_DOCS=( docs/_build/html/. )
+ if use examples ; then
+ docinto examples
+ dodoc -r examples/.
+ fi
+
+ distutils-r1_python_install_all
+}