summaryrefslogtreecommitdiff
path: root/dev-python/rdflib
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-07-29 21:08:17 +0100
committerV3n3RiX <venerix@koprulu.sector>2022-07-29 21:08:17 +0100
commit496936ff0f7db69d1f7317341230acb866e3c330 (patch)
tree1541e919cd45c0ab5bdee8f1ac1344508da3b3af /dev-python/rdflib
parentc9ac6938788ee1708e7c900f8f78e9037aea1ca1 (diff)
gentoo auto-resync : 29:07:2022 - 21:08:17
Diffstat (limited to 'dev-python/rdflib')
-rw-r--r--dev-python/rdflib/Manifest2
-rw-r--r--dev-python/rdflib/rdflib-6.2.0.ebuild95
2 files changed, 97 insertions, 0 deletions
diff --git a/dev-python/rdflib/Manifest b/dev-python/rdflib/Manifest
index d73b0cd8ee5d..6406e259ba43 100644
--- a/dev-python/rdflib/Manifest
+++ b/dev-python/rdflib/Manifest
@@ -1,3 +1,5 @@
DIST rdflib-6.1.1.tar.gz 1587670 BLAKE2B f13831124a8f292f0481f5ee9995b6b7ba82992cbe51abb0067703b2acee9f13ce5a62379636ac9f36823afa5b841799c1f26358efb6c12eca2df333611d5488 SHA512 049608dc37dba929eac1e40431885d319311f27be9fddc292d768e3703927e61a646a73137e4a1eaa16836cfba4606ea2cfd8fe3a86cfbf10e3271cee2ee251f
+DIST rdflib-6.2.0.gh.tar.gz 4886953 BLAKE2B 74044b0cbaf6c1ba6f2a43347112118dcf92b5237afdd49782ca6d637df092379ff2d81eaec254ad0bf25057f8c0cd44c82a35a89d4ce7b21c8e222de9aef16a SHA512 8177c50e9c2d48859a061dfee24c3560b8f979bc306b3d940a9251ec130e3a324bbad474f4fa7ced5e11522d3bd4e13931461bf106f31177fd972806968d8245
EBUILD rdflib-6.1.1.ebuild 1394 BLAKE2B f25e7f9deb40dc790efdcfdfd251e3120167b5820663ad7f7cc95df73cac7406328b89c431b16c631d0680d1395d1bbb0c935aa863d8f2b85f85acf09b69c032 SHA512 4eb944c0fb47f966da9dbeefe2899d2500e611c90b09d8c4ee942f2f236ea7870b2a4a7dba542fbdea66df83210ca2ae7fd42a15b514cab2acdba3a21b3e81a8
+EBUILD rdflib-6.2.0.ebuild 4051 BLAKE2B 9c6f2d0ebdf783b857ca719647e5ddc0150fe1099d8e7791add30e1552aebb3e65c33f5fcc9ddae881d46cb29a0465ddd2aca7b7698d009959dcfa3aaf62c4b9 SHA512 b3d270d6b5bede3870bed14190d2da5806482a3e6ad63278c3259af2ea8beff66c56d9f1f01a0e43adad931bfea16fa3a5afb3e6bc79a2b22ba167f1ef37abd5
MISC metadata.xml 400 BLAKE2B eea3d3a69375a70a1c4a93cebf48169032f9d7cc6ba5df0422bad8c0f4e1caa10721a42b66cfb0dad2ab85aff38f826a0790b4d2dbac90be16e88ecf507d9025 SHA512 d8b94c9c8c037f40db80a44d235ada552851c3b979f496462e19a909eb2b46f606c23458b20869060b596969015616d065b2df0f5b24d2b3d7224afa6089e8e7
diff --git a/dev-python/rdflib/rdflib-6.2.0.ebuild b/dev-python/rdflib/rdflib-6.2.0.ebuild
new file mode 100644
index 000000000000..e41b3e6e638d
--- /dev/null
+++ b/dev-python/rdflib/rdflib-6.2.0.ebuild
@@ -0,0 +1,95 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..10} )
+PYTHON_REQ_USE="sqlite?,threads(+)"
+
+inherit distutils-r1 optfeature
+
+DESCRIPTION="RDF library containing a triple store and parser/serializer"
+HOMEPAGE="
+ https://github.com/RDFLib/rdflib/
+ https://pypi.org/project/rdflib/
+"
+SRC_URI="
+ https://github.com/RDFLib/rdflib/archive/${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~riscv ~sparc ~x86"
+IUSE="examples sqlite"
+
+RDEPEND="
+ dev-python/isodate[${PYTHON_USEDEP}]
+ dev-python/html5lib[${PYTHON_USEDEP}]
+ dev-python/pyparsing[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ dev-python/berkeleydb[${PYTHON_USEDEP}]
+ dev-python/requests[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+python_prepare_all() {
+ # doctests require internet
+ sed -i -e '/doctest-modules/d' pyproject.toml || die
+
+ # we disable pytest-cov
+ sed -i -e 's@, no_cover: None@@' test/test_misc/test_plugins.py || die
+
+ distutils-r1_python_prepare_all
+}
+
+python_test() {
+ local EPYTEST_DESELECT=(
+ # some of them fail with encoding problems (bad code most likely)
+ # but too many to list them one by one
+ test/test_w3c_spec/test_sparql11_w3c.py::test_entry_sparql11
+ "test/test_sparql/test_result.py::test_select_result_serialize_parse[xml-TEXT_IO-utf-8]"
+ "test/test_sparql/test_result.py::test_select_result_serialize_parse[xml-STR_PATH-utf-8]"
+ "test/test_sparql/test_result.py::test_select_result_serialize_parse[xml-BINARY_IO-utf-8]"
+ "test/test_sparql/test_result.py::test_select_result_serialize_parse[xml-None-utf-8]"
+ "test/test_sparql/test_result.py::test_select_result_parse_serialized[xml-TEXT_IO-utf-8]"
+
+ # Internet
+ test/test_sparql/test_service.py
+ "test/jsonld/test_onedotone.py::test_suite[https://w3c.github.io/json-ld-api/tests/toRdf-manifest#tc034-do_test_parser-https://w3c.github.io/json-ld-api/tests/-toRdf-c034-toRdf/c034-in.jsonld-toRdf/c034-out.nq-False-options66]"
+ "test/jsonld/test_onedotone.py::test_suite[https://w3c.github.io/json-ld-api/tests/toRdf-manifest#te126-do_test_parser-https://w3c.github.io/json-ld-api/tests/-toRdf-e126-toRdf/e126-in.jsonld-toRdf/e126-out.nq-False-options167]"
+ "test/jsonld/test_onedotone.py::test_suite[https://w3c.github.io/json-ld-api/tests/toRdf-manifest#te127-do_test_parser-https://w3c.github.io/json-ld-api/tests/-toRdf-e127-toRdf/e127-in.jsonld-toRdf/e127-out.nq-False-options168]"
+ "test/jsonld/test_onedotone.py::test_suite[https://w3c.github.io/json-ld-api/tests/toRdf-manifest#tso05-do_test_parser-https://w3c.github.io/json-ld-api/tests/-toRdf-so05-toRdf/so05-in.jsonld-toRdf/so05-out.nq-False-options253]"
+ "test/jsonld/test_onedotone.py::test_suite[https://w3c.github.io/json-ld-api/tests/toRdf-manifest#tso08-do_test_parser-https://w3c.github.io/json-ld-api/tests/-toRdf-so08-toRdf/so08-in.jsonld-toRdf/so08-out.nq-False-options254]"
+ "test/jsonld/test_onedotone.py::test_suite[https://w3c.github.io/json-ld-api/tests/toRdf-manifest#tso09-do_test_parser-https://w3c.github.io/json-ld-api/tests/-toRdf-so09-toRdf/so09-in.jsonld-toRdf/so09-out.nq-False-options255]"
+ "test/jsonld/test_onedotone.py::test_suite[https://w3c.github.io/json-ld-api/tests/toRdf-manifest#tso11-do_test_parser-https://w3c.github.io/json-ld-api/tests/-toRdf-so11-toRdf/so11-in.jsonld-toRdf/so11-out.nq-False-options256]"
+ test/test_extras/test_infixowl/test_basic.py::test_infix_owl_example1
+ test/test_extras/test_infixowl/test_context.py::test_context
+ test/test_graph/test_graph.py::test_guess_format_for_parse
+ )
+ local EPYTEST_IGNORE=(
+ # Uses network
+ test/test_so_69984830.py
+ )
+ local -x PYTEST_DISABLE_PLUGIN_AUTOLOAD=1
+
+ epytest
+}
+
+python_install_all() {
+ distutils-r1_python_install_all
+
+ if use examples; then
+ dodoc -r examples
+ docompress -x /usr/share/doc/${PF}/examples
+ fi
+}
+
+pkg_postinst() {
+ optfeature "support for sys-libs/db (Berkeley DB for MySQL)" dev-python/berkeleydb
+}