summaryrefslogtreecommitdiff
path: root/dev-python/ratelimit
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2020-05-14 11:09:11 +0100
committerV3n3RiX <venerix@redcorelinux.org>2020-05-14 11:09:11 +0100
commitdeba8115d2c2af26df42966b91ef04ff4dd79cde (patch)
tree9a48f42594e1a9e6b2020d5535a784314434d7a7 /dev-python/ratelimit
parent38423c67c8a23f6a1bc42038193182e2da3116eb (diff)
gentoo resync : 14.05.2020
Diffstat (limited to 'dev-python/ratelimit')
-rw-r--r--dev-python/ratelimit/Manifest2
-rw-r--r--dev-python/ratelimit/ratelimit-1.4.1.ebuild13
2 files changed, 4 insertions, 11 deletions
diff --git a/dev-python/ratelimit/Manifest b/dev-python/ratelimit/Manifest
index 0e28738c6b14..17ef9d522b91 100644
--- a/dev-python/ratelimit/Manifest
+++ b/dev-python/ratelimit/Manifest
@@ -1,3 +1,3 @@
DIST ratelimit-1.4.1.tar.gz 10700 BLAKE2B d2fc1b0695c6bdc7653862ca790e9f5ec87b25513a93ec058384f334b47d5080570e3511eb6680b934b345ef5562771a078fc4ced3ceed263a7aafd26af3bfdd SHA512 ab8a2cc95b852f91c614ba5a5a677d2b4b99d5f810ec8a11e69d97af58cef1f67457e1cf686a286073c85b39c2ebbeca0a459382e410c9e8eda12cecdda57f02
-EBUILD ratelimit-1.4.1.ebuild 611 BLAKE2B 284883f0023cce6d1d542cc89761d0c6d8b547ff1f06cdda574cd6789903cad88e6117c34d3827024314d594f1b9cd3e60ed038c7c2f0d80bb6d90815f93c4da SHA512 9d80fd84a4da2f74969f9a9e89c486767f53a1e967580bbee5fcea4b386ef09940c2ff61c6e9d7b53e3cbe02ad4e269cb117419951290f29f08658cb940cfb41
+EBUILD ratelimit-1.4.1.ebuild 517 BLAKE2B 3876d99b545ea1c12a7dcfa21c5cbc33c81088b1a01364bb4a345316250439859ec1efdfb121baa1b650409b7ac191c7793c6f7894ca86e0ac046a7568534634 SHA512 8d87580f28489774d7de43409bb6fbf0d60fa2960ac3ea62048102222bd97c5ebe08b0a7f22c7ef430849283351f92a2307769080ccbd64189126f8fb67065a1
MISC metadata.xml 716 BLAKE2B 9ebf5c00beb4571be310d9c5ef0708677f5c80c59ff6335b526618ae1d005d97e9415131be27043895d99ca0c27420261b1adb19160a0c647c1999af99c4261f SHA512 356610616edb0430a4d069a9f86f0db51952b2c522cc3a7a618629f115a3ac9018fc2e023d4199628a97bf1c52783f932ec2e90b4c1d2e4eb1693aa24757fcf2
diff --git a/dev-python/ratelimit/ratelimit-1.4.1.ebuild b/dev-python/ratelimit/ratelimit-1.4.1.ebuild
index bc4af83a74e6..6974189b99e6 100644
--- a/dev-python/ratelimit/ratelimit-1.4.1.ebuild
+++ b/dev-python/ratelimit/ratelimit-1.4.1.ebuild
@@ -1,8 +1,8 @@
# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=6
-PYTHON_COMPAT=( python3_6 )
+EAPI=7
+PYTHON_COMPAT=( python3_{6,7,8} )
inherit distutils-r1
@@ -13,18 +13,11 @@ HOMEPAGE="https://github.com/tomasbasham/ratelimit"
LICENSE="MIT"
SLOT="0"
KEYWORDS="~amd64 ~x86"
-IUSE="test"
-RESTRICT="!test? ( test )"
-DEPEND="
- test? ( dev-python/pytest[${PYTHON_USEDEP}] )"
+distutils_enable_tests pytest
src_prepare() {
default
# remove --cov args injection
rm pytest.ini || die
}
-
-python_test() {
- pytest || die
-}