summaryrefslogtreecommitdiff
path: root/dev-python/ratelimit
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /dev-python/ratelimit
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'dev-python/ratelimit')
-rw-r--r--dev-python/ratelimit/Manifest3
-rw-r--r--dev-python/ratelimit/metadata.xml20
-rw-r--r--dev-python/ratelimit/ratelimit-1.4.1.ebuild26
3 files changed, 49 insertions, 0 deletions
diff --git a/dev-python/ratelimit/Manifest b/dev-python/ratelimit/Manifest
new file mode 100644
index 000000000000..637f4e70e462
--- /dev/null
+++ b/dev-python/ratelimit/Manifest
@@ -0,0 +1,3 @@
+DIST ratelimit-1.4.1.tar.gz 10700 BLAKE2B d2fc1b0695c6bdc7653862ca790e9f5ec87b25513a93ec058384f334b47d5080570e3511eb6680b934b345ef5562771a078fc4ced3ceed263a7aafd26af3bfdd SHA512 ab8a2cc95b852f91c614ba5a5a677d2b4b99d5f810ec8a11e69d97af58cef1f67457e1cf686a286073c85b39c2ebbeca0a459382e410c9e8eda12cecdda57f02
+EBUILD ratelimit-1.4.1.ebuild 566 BLAKE2B df2d66c46e4f034f22b058f533d763fe46c16d9675c3e1d5c726ca5985d0b97411b524892063618e67c259fc276dea7d961d17eaaf088fc26c5e63d7de24df61 SHA512 a8445d5d480db02949c0693b1e75ba44dcbaf474a7bfbd7b4aed8644c6ac1204e2278a10944ee9efe809e97cac777ebaa43b06990506669b6a899ab474e33ece
+MISC metadata.xml 724 BLAKE2B 2ebbc8dbd58619d4978081c22d294e19682a10a159321b143e942e4a4f969400792a411fb6db3670d747fea6747927030d590c45251e753ff5183be3667297e8 SHA512 aec024dc134acf8c02150822fdd1b29ac3042aac96a5a54d5c1876e20bd4bf4bd2211374460b8dd4c19b37be44d063b5cd36ac77f196c30b4529c65bd7c45249
diff --git a/dev-python/ratelimit/metadata.xml b/dev-python/ratelimit/metadata.xml
new file mode 100644
index 000000000000..b656231c3c9c
--- /dev/null
+++ b/dev-python/ratelimit/metadata.xml
@@ -0,0 +1,20 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <longdescription lang="en">
+ ratelimit introduces a method decorator preventing a method from being
+ called more than once within a given time period. It prevents API providers
+ from banning your applications by conforming to set rate limits.
+ </longdescription>
+ <maintainer type="person">
+ <email>horea.christ@gmail.com</email>
+ <name>Horea Christian</name>
+ </maintainer>
+ <maintainer type="project">
+ <email>proxy-maint@gentoo.org</email>
+ <name>Proxy Maintainers</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="github">tomasbasham/ratelimit"</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-python/ratelimit/ratelimit-1.4.1.ebuild b/dev-python/ratelimit/ratelimit-1.4.1.ebuild
new file mode 100644
index 000000000000..3c01b8f2c100
--- /dev/null
+++ b/dev-python/ratelimit/ratelimit-1.4.1.ebuild
@@ -0,0 +1,26 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+PYTHON_COMPAT=( python{2_7,3_4,3_5,3_6} )
+
+inherit distutils-r1
+
+DESCRIPTION="An API rate limit decorator for Python"
+SRC_URI="https://github.com/tomasbasham/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+HOMEPAGE="https://github.com/tomasbasham/ratelimit"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="test"
+
+DEPEND="
+ test? (
+ dev-python/pytest[${PYTHON_USEDEP}]
+ dev-python/pytest-cov[${PYTHON_USEDEP}]
+ )"
+
+python_test() {
+ py.test || die
+}