summaryrefslogtreecommitdiff
path: root/dev-python/ratelimit
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2021-08-21 23:14:26 +0100
committerV3n3RiX <venerix@redcorelinux.org>2021-08-21 23:14:26 +0100
commit7c59acba5699c9c58090a7a738669669a7307023 (patch)
treed51d27d020895a6b7a3298d9d1b9846c1fcb59a0 /dev-python/ratelimit
parente2db47eaae00ec33f8971db44b68645c5d3b9590 (diff)
gentoo resync : 21.08.2021
Diffstat (limited to 'dev-python/ratelimit')
-rw-r--r--dev-python/ratelimit/Manifest6
-rw-r--r--dev-python/ratelimit/metadata.xml1
-rw-r--r--dev-python/ratelimit/ratelimit-2.2.1.ebuild (renamed from dev-python/ratelimit/ratelimit-1.4.1.ebuild)15
3 files changed, 13 insertions, 9 deletions
diff --git a/dev-python/ratelimit/Manifest b/dev-python/ratelimit/Manifest
index 20e2dbed0774..9f4edc59246a 100644
--- a/dev-python/ratelimit/Manifest
+++ b/dev-python/ratelimit/Manifest
@@ -1,3 +1,3 @@
-DIST ratelimit-1.4.1.tar.gz 10700 BLAKE2B d2fc1b0695c6bdc7653862ca790e9f5ec87b25513a93ec058384f334b47d5080570e3511eb6680b934b345ef5562771a078fc4ced3ceed263a7aafd26af3bfdd SHA512 ab8a2cc95b852f91c614ba5a5a677d2b4b99d5f810ec8a11e69d97af58cef1f67457e1cf686a286073c85b39c2ebbeca0a459382e410c9e8eda12cecdda57f02
-EBUILD ratelimit-1.4.1.ebuild 515 BLAKE2B 7073794194696d691e50036afdfa5edee465cadac00ca2b159e6d624b5a907208e5ef479d43ec1943e1575bccecff76bdaa9317c74f53603490e206849b732d5 SHA512 df9131a1012d99335fb877a5146a0188b6293f1e6b1a5658071fc4c211c1f45feb74d5e504cd21697a91b7b732e36484f3d170287a3d70471e79abe16dacedc2
-MISC metadata.xml 795 BLAKE2B 7f7f299b3996eafc699e0ff404d42978ebd8dda4aba085c3cb965d4b138873e2288e3632f92c4e94a3f689853f7dc92d419b9cd03eeac6c9044d0a881164f5dd SHA512 88cbe1d6d7e4602f762e9eeaa50d4fe626ed84a14f0b60b0512e7e974310fdc32c52aa184b290b1e9a7c9a1d01eef96ba87096c87698ffaafffa24a4e7c9f748
+DIST ratelimit-2.2.1.gh.tar.gz 12366 BLAKE2B 7c810bd111202ef6cd86a789627367665457eb2fd88f13d91b18c934210b72f8f4b0ca1ae0e26b502234c4bf3e74d1c6608260d51a022f9f733d10eb061de023 SHA512 a9a2347e9f9e152e5b1ffcf346cf750c5c52471aa2216b485d989edfc55686077990676a35e0125277313ad50a656a14ab72b7aac61b661e2fc4ec74611b5990
+EBUILD ratelimit-2.2.1.ebuild 543 BLAKE2B ae68a3f6b887653148016003fd026ee0091b330f9d49fd17880a4ac45bc8752def9edb4d90c17e12c9dbd029be450fdc171a410d11ea793a494f4fbae6092e05 SHA512 9910bb1d9eb7a2d6957a547c44718aa91523bfef1418dc073825b7fda56ed393a10128af7a4a9695d5f4c76500426802b8ae0b0444aa300244cf05552e3d3061
+MISC metadata.xml 819 BLAKE2B 80d368f9bf7b6f9da9ee311fcf0f75078983b1cd359511e0084385075a14f646cff1c8799844444daa8ed81b35e147d1acc09eb2de9118ae59095ccbdee8b432 SHA512 42efa6ff949dc3d20e16550bee4bfa072b21e3f5902e56548e693603b72884833154c09119f00229271c5a1573dd15256d74ad9ed46373994c1dc7cf89212d3e
diff --git a/dev-python/ratelimit/metadata.xml b/dev-python/ratelimit/metadata.xml
index d191e88e1329..6312eca96d72 100644
--- a/dev-python/ratelimit/metadata.xml
+++ b/dev-python/ratelimit/metadata.xml
@@ -14,6 +14,7 @@
<email>proxy-maint@gentoo.org</email>
<name>Proxy Maintainers</name>
</maintainer>
+ <stabilize-allarches/>
<upstream>
<remote-id type="github">tomasbasham/ratelimit</remote-id>
<remote-id type="pypi">ratelimit</remote-id>
diff --git a/dev-python/ratelimit/ratelimit-1.4.1.ebuild b/dev-python/ratelimit/ratelimit-2.2.1.ebuild
index af0e0a7a99f3..469d3b4e290f 100644
--- a/dev-python/ratelimit/ratelimit-1.4.1.ebuild
+++ b/dev-python/ratelimit/ratelimit-2.2.1.ebuild
@@ -1,14 +1,17 @@
-# Copyright 1999-2020 Gentoo Authors
+# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=7
-PYTHON_COMPAT=( python3_{7,8} )
+EAPI=8
+PYTHON_COMPAT=( python3_{8..10} )
inherit distutils-r1
DESCRIPTION="An API rate limit decorator for Python"
-SRC_URI="https://github.com/tomasbasham/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
HOMEPAGE="https://github.com/tomasbasham/ratelimit"
+SRC_URI="
+ https://github.com/tomasbasham/${PN}/archive/v${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
LICENSE="MIT"
SLOT="0"
@@ -17,7 +20,7 @@ KEYWORDS="~amd64 ~x86"
distutils_enable_tests pytest
src_prepare() {
- default
- # remove --cov args injection
+ # remove --cov args injection
rm pytest.ini || die
+ distutils-r1_src_prepare
}