summaryrefslogtreecommitdiff
path: root/dev-python/rackspace-auth-openstack
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /dev-python/rackspace-auth-openstack
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'dev-python/rackspace-auth-openstack')
-rw-r--r--dev-python/rackspace-auth-openstack/Manifest4
-rw-r--r--dev-python/rackspace-auth-openstack/metadata.xml16
-rw-r--r--dev-python/rackspace-auth-openstack/rackspace-auth-openstack-1.3.ebuild18
-rw-r--r--dev-python/rackspace-auth-openstack/rackspace-auth-openstack-9999.ebuild19
4 files changed, 57 insertions, 0 deletions
diff --git a/dev-python/rackspace-auth-openstack/Manifest b/dev-python/rackspace-auth-openstack/Manifest
new file mode 100644
index 000000000000..26648d64207d
--- /dev/null
+++ b/dev-python/rackspace-auth-openstack/Manifest
@@ -0,0 +1,4 @@
+DIST rackspace-auth-openstack-1.3.tar.gz 6799 BLAKE2B 33754daf35b7260af030da4a83f61224c6bf11ec9fe554282b45c5839aabc5687e2fe288b9af6252e4731de5bea381eb8e8a98a401371afddcf996652f892f23 SHA512 813fe85d38bc80bae65a3f160f50c17fe8bc7279dc3ad4689012b3fa9c0fdd1577c0491de0c87d3b8fe4e6ba5c1166cf30cc1d0533fa15c516a826ef6c36934c
+EBUILD rackspace-auth-openstack-1.3.ebuild 469 BLAKE2B e01bde0d679ab70ce106edab5c79ea22b7b9d52b31c815d074c63aa8e5b9a5390a8dbe8d416e5ac400f13c0247f93e300a2e33c412efe2c07d3df2ae70f4595e SHA512 d0da2bd0ca3b31755ae19858c88de69eaaa22397dbe424032091acee6895ec006f4fdc86fc475a471d08d9e7fde163ac69613ab9eff2fe393afe5ddceaef05b1
+EBUILD rackspace-auth-openstack-9999.ebuild 465 BLAKE2B d1f2ba6702da5bdb1d791b34fe4289feb87b275839620782410692b1293c45e5bab18835584bbece18095bf99f376d6cc114c4724b52ca3438fd31578f83b7f3 SHA512 98af9c24340c0ef900bb9edb4c7a512b4a1c3a79d5199c16312b6636bdeb7737105656a5d66cfda64321d9c31d9e2152249bc3c94a961dccec28639f7b695e3f
+MISC metadata.xml 588 BLAKE2B b868993dca0c3a017ae5e12e57983676c97e8d84dde1b803f0c0ae2fcab8b1b19f581a288ecbaa7d547457a762ce30e9551e88d58d61bddf19bb126dd87cad21 SHA512 c59d7bcf7d96b1eca6a82cdef09e717b97df65ca1ddaa9696a0a931ccb3af0a330ef285c23a0ed90324c5f49a8fd007989faa6a718c3fc79c631b7e548272221
diff --git a/dev-python/rackspace-auth-openstack/metadata.xml b/dev-python/rackspace-auth-openstack/metadata.xml
new file mode 100644
index 000000000000..92f30d28fb24
--- /dev/null
+++ b/dev-python/rackspace-auth-openstack/metadata.xml
@@ -0,0 +1,16 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>prometheanfire@gentoo.org</email>
+ <name>Matthew Thode</name>
+ </maintainer>
+ <longdescription lang="en">
+ This is a plugin for OpenStack Clients which provides client support for
+ Rackspace authentication extensions to OpenStack.
+ </longdescription>
+ <upstream>
+ <remote-id type="pypi">rackspace-auth-openstack</remote-id>
+ <remote-id type="github">emonty/rackspace-auth-openstack</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-python/rackspace-auth-openstack/rackspace-auth-openstack-1.3.ebuild b/dev-python/rackspace-auth-openstack/rackspace-auth-openstack-1.3.ebuild
new file mode 100644
index 000000000000..df312692eccb
--- /dev/null
+++ b/dev-python/rackspace-auth-openstack/rackspace-auth-openstack-1.3.ebuild
@@ -0,0 +1,18 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+PYTHON_COMPAT=( python2_7 python3_{4,5,6} )
+
+inherit distutils-r1
+
+DESCRIPTION="Rackspace Auth Plugin for OpenStack Clients"
+HOMEPAGE="https://github.com/emonty/rackspace-auth-openstack"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"
+RDEPEND=""
diff --git a/dev-python/rackspace-auth-openstack/rackspace-auth-openstack-9999.ebuild b/dev-python/rackspace-auth-openstack/rackspace-auth-openstack-9999.ebuild
new file mode 100644
index 000000000000..be6b3b3ff974
--- /dev/null
+++ b/dev-python/rackspace-auth-openstack/rackspace-auth-openstack-9999.ebuild
@@ -0,0 +1,19 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+PYTHON_COMPAT=( python2_7 python3_{4,5,6} )
+
+inherit distutils-r1 git-2
+
+EGIT_REPO_URI="https://github.com/emonty/${PN}.git"
+
+DESCRIPTION="Rackspace Auth Plugin for OpenStack Clients"
+HOMEPAGE="https://github.com/emonty/rackspace-auth-openstack"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS=""
+
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"
+RDEPEND=""