summaryrefslogtreecommitdiff
path: root/dev-python/quart
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2024-01-31 11:48:59 +0000
committerV3n3RiX <venerix@koprulu.sector>2024-01-31 11:48:59 +0000
commit0c7c7c833ab740636f5a76d53ebe5bb6e0e793a8 (patch)
treec54041f822e7291ee0e13d0fa320d348bacdf4d9 /dev-python/quart
parent14cf0565bbb816bd0cf9ecd14bec28dacfac2d57 (diff)
gentoo auto-resync : 31:01:2024 - 11:48:58
Diffstat (limited to 'dev-python/quart')
-rw-r--r--dev-python/quart/Manifest3
-rw-r--r--dev-python/quart/metadata.xml12
-rw-r--r--dev-python/quart/quart-0.19.4.ebuild49
3 files changed, 64 insertions, 0 deletions
diff --git a/dev-python/quart/Manifest b/dev-python/quart/Manifest
new file mode 100644
index 000000000000..dcb277bd5ef8
--- /dev/null
+++ b/dev-python/quart/Manifest
@@ -0,0 +1,3 @@
+DIST quart-0.19.4.gh.tar.gz 493787 BLAKE2B 8a754687cc2e8321ed6b2243cfe519d95e955869a1a12c89a22aa3e304466a4a496531e7ca8e819c0daee88a6b077e7b54dbef02de84abd6f6dbf7b8988e139f SHA512 d6673a43733b8f1caa2180c545cea99eb9670d802b29f123e6c499345bc33cc5f36c9146757e0eea9def811043a9b0e7d59e5e7012ee965b425ec32620cd383a
+EBUILD quart-0.19.4.ebuild 1154 BLAKE2B bfeb7f01f563cef5629cabedb812d7b742828ce73823ad2faf3eee131b5b2ea02e80857d77cad0fbdb45571ee83d74e277a08a949618485497e544b56f790433 SHA512 ed02ee1c626bd61b6e6b0a5cb319791fb4f822f3b2bb84ee8b975e9a62a2731556c0610c960f334a6e30757afe45c7ff3816cf48c751e992214a23186073a310
+MISC metadata.xml 364 BLAKE2B 207d3328ae2624ec61834adc055ca2b01ee1a587c2b6ef8cfde8c72d7370f4bb912dbc5fefdb5432959dcf273b9ebabc394dfd163dab7be00413daa85a0b6162 SHA512 8fc752b94e06ea29021c7e73c67a488f17fbbd6b8dab79c58f8647989e9c613071b539e626bf122e6693b8b670cc57bea115581801d57d3212c037d0f91df7d2
diff --git a/dev-python/quart/metadata.xml b/dev-python/quart/metadata.xml
new file mode 100644
index 000000000000..e630e696005f
--- /dev/null
+++ b/dev-python/quart/metadata.xml
@@ -0,0 +1,12 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>python@gentoo.org</email>
+ </maintainer>
+ <stabilize-allarches/>
+ <upstream>
+ <remote-id type="github">pallets/quart</remote-id>
+ <remote-id type="pypi">Quart</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-python/quart/quart-0.19.4.ebuild b/dev-python/quart/quart-0.19.4.ebuild
new file mode 100644
index 000000000000..c81ca8ecca32
--- /dev/null
+++ b/dev-python/quart/quart-0.19.4.ebuild
@@ -0,0 +1,49 @@
+# Copyright 2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=poetry
+PYTHON_COMPAT=( pypy3 python3_{10..12} )
+
+inherit distutils-r1
+
+DESCRIPTION="A Python ASGI web microframework with the same API as Flask"
+HOMEPAGE="
+ https://github.com/pallets/quart/
+ https://pypi.org/project/Quart/
+"
+# no tests in sdist as of 0.19.4
+SRC_URI="
+ https://github.com/pallets/quart/archive/${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64"
+
+RDEPEND="
+ dev-python/aiofiles[${PYTHON_USEDEP}]
+ >=dev-python/blinker-1.6[${PYTHON_USEDEP}]
+ >=dev-python/click-8.0.0[${PYTHON_USEDEP}]
+ >=dev-python/flask-3.0.0[${PYTHON_USEDEP}]
+ >=dev-python/hypercorn-0.11.2[${PYTHON_USEDEP}]
+ dev-python/itsdangerous[${PYTHON_USEDEP}]
+ dev-python/jinja[${PYTHON_USEDEP}]
+ dev-python/markupsafe[${PYTHON_USEDEP}]
+ >=dev-python/werkzeug-3.0.0[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ dev-python/hypothesis[${PYTHON_USEDEP}]
+ dev-python/pytest-asyncio[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+python_test() {
+ local -x PYTEST_DISABLE_PLUGIN_AUTOLOAD=1
+ epytest -o addopts= -p asyncio
+}