summaryrefslogtreecommitdiff
path: root/dev-python/quart-trio
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2025-01-10 06:41:31 +0000
committerV3n3RiX <venerix@koprulu.sector>2025-01-10 06:41:31 +0000
commitf9d8ddaae80afb8fa0924cd3f769f9b37dd373e1 (patch)
treed8962e6446d606b8c95329b4b78932a65f928a5f /dev-python/quart-trio
parentd94fef9a5708b8e64f363f4a71f0b56caef5efe4 (diff)
gentoo auto-resync : 10:01:2025 - 06:41:30
Diffstat (limited to 'dev-python/quart-trio')
-rw-r--r--dev-python/quart-trio/Manifest2
-rw-r--r--dev-python/quart-trio/quart-trio-0.12.0.ebuild40
2 files changed, 42 insertions, 0 deletions
diff --git a/dev-python/quart-trio/Manifest b/dev-python/quart-trio/Manifest
index 5b06d5370367..db5578a669dd 100644
--- a/dev-python/quart-trio/Manifest
+++ b/dev-python/quart-trio/Manifest
@@ -1,4 +1,6 @@
AUX quart-trio-0.11.1-trio-0.25.patch 2490 BLAKE2B f4430630bcd8151343367804bb179863b89826c98a4893b06672c0930b6153c748b1850acc259a547fbb52d41d8b6a94eb6af80327a83e8234aec366669d93e2 SHA512 04bdeb63b4de4b3fff472bdd0eb8dbdb87a0a73f48ceaaec85d0e0747b56bd0c520b0c75ab09fa43c1dc0cb296e180b8dd3496ac43e115b5cc8f562e5dcde006
DIST quart-trio-0.11.1.gh.tar.gz 18568 BLAKE2B faabf4204a82dcc70e41d1d1ec7171c89386f2e40979c20501890d9bc27eb2af693bc791a9015a9c4c676a5e25ec69dc4975a0cd09987cd14f699a04442d54da SHA512 8ea20c36c772eff3e2b0a83a4c325cd223c19b3d7e1e51e7378897bd11479db2c8015d2e8c4713721070fc413f42b19f844a3966a0d06d299439cf514b0b3291
+DIST quart_trio-0.12.0.tar.gz 14979 BLAKE2B 7a7ffaba59e6984001941c1c54cfab189434366ab1b56d6509567c79560d916e2a5f0c81e8f23e17462de17d012d77eda3803cc8828a5378b3b92c1bab00e475 SHA512 70b1f2406185b020f999cb335c2c13599faf9c36c69f8adc437fbb846158f659e8d6527199083f9674e75c99bcd10dbf228dbd62ca7c5614b471c462b22227ee
EBUILD quart-trio-0.11.1.ebuild 1099 BLAKE2B 1e3e0dfa6b0b711fb316a6cfc562becacfab33b2b33e9bd7c98c689716b6e4ad94222d47a11237eb52499d6d7d7443100395e5215f4c6a49d331ba51277b4acb SHA512 5af16fa1045b9b9aae2ec10d6ff6359b5081535eed01bb060c9ba661ecfb761e07ce5bc636a0eca967be02113e1639f548cbdae37c50302a14b7b66590c40678
+EBUILD quart-trio-0.12.0.ebuild 892 BLAKE2B 1c174d623cb5369758e49bf42b9e27496c9c34fdd84255d3b4439dadae3fb03e73149363d7d77a91080911696c2a8da1412f307c493e357e30a71b1361f92e07 SHA512 3a23c94cfdf94271ca571e793223eeda57b985d37d423acbf8052b7df8f5953fc3b6035d018fcde59a77a9cade66a0efb67010b6518f3d79db7c81fe6686b21d
MISC metadata.xml 427 BLAKE2B fade855b0fc05b078dec5432d1e5cff22bdc4fc23bb97aecca815b7c031b67881f291afae0d5abf42fc115f405cf528683d992447d372a154015c40b1eb8f36c SHA512 2738f87b35ee3ca112096727054730fe90af48a3f77afff7aed8198a43bf505e984ec0f2d810fcd183507be58a8586c6f3dd4dcd26f40c6ba11008d7745aa714
diff --git a/dev-python/quart-trio/quart-trio-0.12.0.ebuild b/dev-python/quart-trio/quart-trio-0.12.0.ebuild
new file mode 100644
index 000000000000..53640fe9bc8b
--- /dev/null
+++ b/dev-python/quart-trio/quart-trio-0.12.0.ebuild
@@ -0,0 +1,40 @@
+# Copyright 2024-2025 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=pdm-backend
+PYTHON_COMPAT=( pypy3 python3_{10..13} )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="A Quart extension to provide trio support"
+HOMEPAGE="
+ https://github.com/pgjones/quart-trio/
+ https://pypi.org/project/quart-trio/
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~loong ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
+
+RDEPEND="
+ $(python_gen_cond_dep '
+ >=dev-python/exceptiongroup-1.1.0[${PYTHON_USEDEP}]
+ ' 3.10)
+ >=dev-python/hypercorn-0.12.0[${PYTHON_USEDEP}]
+ >=dev-python/quart-0.19[${PYTHON_USEDEP}]
+ >=dev-python/trio-0.19.0[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ dev-python/pytest-trio[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+python_test() {
+ local -x PYTEST_DISABLE_PLUGIN_AUTOLOAD=1
+ epytest -o addopts= -p trio
+}