summaryrefslogtreecommitdiff
path: root/dev-python/quart-trio
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2024-01-31 11:48:59 +0000
committerV3n3RiX <venerix@koprulu.sector>2024-01-31 11:48:59 +0000
commit0c7c7c833ab740636f5a76d53ebe5bb6e0e793a8 (patch)
treec54041f822e7291ee0e13d0fa320d348bacdf4d9 /dev-python/quart-trio
parent14cf0565bbb816bd0cf9ecd14bec28dacfac2d57 (diff)
gentoo auto-resync : 31:01:2024 - 11:48:58
Diffstat (limited to 'dev-python/quart-trio')
-rw-r--r--dev-python/quart-trio/Manifest3
-rw-r--r--dev-python/quart-trio/metadata.xml13
-rw-r--r--dev-python/quart-trio/quart-trio-0.11.1.ebuild43
3 files changed, 59 insertions, 0 deletions
diff --git a/dev-python/quart-trio/Manifest b/dev-python/quart-trio/Manifest
new file mode 100644
index 000000000000..23dff14ccaa8
--- /dev/null
+++ b/dev-python/quart-trio/Manifest
@@ -0,0 +1,3 @@
+DIST quart-trio-0.11.1.gh.tar.gz 18568 BLAKE2B faabf4204a82dcc70e41d1d1ec7171c89386f2e40979c20501890d9bc27eb2af693bc791a9015a9c4c676a5e25ec69dc4975a0cd09987cd14f699a04442d54da SHA512 8ea20c36c772eff3e2b0a83a4c325cd223c19b3d7e1e51e7378897bd11479db2c8015d2e8c4713721070fc413f42b19f844a3966a0d06d299439cf514b0b3291
+EBUILD quart-trio-0.11.1.ebuild 906 BLAKE2B f411fbbe5502cb9830d7638c966510016aca11384009c8b1cf4b03da56405510c0161ee933953180a5fd7d7f9472f1a7f5546f1ac1a3fbd279e75e49f75e237a SHA512 306d7781b333797f5d706ababb67e7d8128d1dd653b7c4434161356205e6404258ed7bc62018d0155bfaa256c1e0676c9c92a7bcda56d424721457eb5c950ef8
+MISC metadata.xml 427 BLAKE2B fade855b0fc05b078dec5432d1e5cff22bdc4fc23bb97aecca815b7c031b67881f291afae0d5abf42fc115f405cf528683d992447d372a154015c40b1eb8f36c SHA512 2738f87b35ee3ca112096727054730fe90af48a3f77afff7aed8198a43bf505e984ec0f2d810fcd183507be58a8586c6f3dd4dcd26f40c6ba11008d7745aa714
diff --git a/dev-python/quart-trio/metadata.xml b/dev-python/quart-trio/metadata.xml
new file mode 100644
index 000000000000..0a22f1b2a556
--- /dev/null
+++ b/dev-python/quart-trio/metadata.xml
@@ -0,0 +1,13 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <!-- please remove python@ if tests do not work -->
+ <maintainer type="project">
+ <email>python@gentoo.org</email>
+ </maintainer>
+ <stabilize-allarches/>
+ <upstream>
+ <remote-id type="github">pgjones/quart-trio</remote-id>
+ <remote-id type="pypi">quart-trio</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-python/quart-trio/quart-trio-0.11.1.ebuild b/dev-python/quart-trio/quart-trio-0.11.1.ebuild
new file mode 100644
index 000000000000..fff0e201a851
--- /dev/null
+++ b/dev-python/quart-trio/quart-trio-0.11.1.ebuild
@@ -0,0 +1,43 @@
+# Copyright 2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=poetry
+PYTHON_COMPAT=( pypy3 python3_{10..12} )
+
+inherit distutils-r1
+
+DESCRIPTION="A Quart extension to provide trio support"
+HOMEPAGE="
+ https://github.com/pgjones/quart-trio/
+ https://pypi.org/project/quart-trio/
+"
+# no tests in sdist, as of 0.11.1
+SRC_URI="
+ https://github.com/pgjones/quart-trio/archive/${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64"
+
+RDEPEND="
+ >=dev-python/exceptiongroup-1.0.0[${PYTHON_USEDEP}]
+ >=dev-python/hypercorn-0.12.0[${PYTHON_USEDEP}]
+ >=dev-python/quart-0.19[${PYTHON_USEDEP}]
+ >=dev-python/trio-0.19.0[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ dev-python/pytest-trio[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+python_test() {
+ local -x PYTEST_DISABLE_PLUGIN_AUTOLOAD=1
+ epytest -o addopts= -p trio
+}