summaryrefslogtreecommitdiff
path: root/dev-python/qtpy
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2025-01-23 06:45:02 +0000
committerV3n3RiX <venerix@koprulu.sector>2025-01-23 06:45:02 +0000
commitc78477d222e1ceb9516a9bbbadbba0b5c1ce11db (patch)
tree5187cbad4740387edb2c1cca0942036a0fdccd88 /dev-python/qtpy
parent564687d289b862b8b079569a45a2d39d7b8c3585 (diff)
gentoo auto-resync : 23:01:2025 - 06:45:02
Diffstat (limited to 'dev-python/qtpy')
-rw-r--r--dev-python/qtpy/Manifest4
-rw-r--r--dev-python/qtpy/metadata.xml6
-rw-r--r--dev-python/qtpy/qtpy-2.4.2.ebuild4
3 files changed, 7 insertions, 7 deletions
diff --git a/dev-python/qtpy/Manifest b/dev-python/qtpy/Manifest
index 76fbd2355c31..6adbe7ec9214 100644
--- a/dev-python/qtpy/Manifest
+++ b/dev-python/qtpy/Manifest
@@ -1,4 +1,4 @@
DIST qtpy-2.4.2.tar.gz 66849 BLAKE2B 1eb362e797950d6c1406fb02bb3047ca7f8fdecd2b75371ab34f39601c9bdebce33336e3809c0d35dca31673c88d1734721a6dfdfb65f2ce20729445c4a4ca27 SHA512 2f9a0e1a4839c8dca23b4364900a12c2bd00f518353785a41eb6bd62fdc469670457f18224e1150a5a216ff5d0c4e799c3a1711ff7703ea07fadd655538fa37a
EBUILD qtpy-2.4.2-r1.ebuild 6288 BLAKE2B 6f3b335f3993e62ff8b244c1bd44354578816cc155961ad53c1499de13aa89d0bdbc2d98b1a75d3e714853b324fe5c7c8720409b39d252d3dfa1a5b049bffc49 SHA512 bf64164e84e94b8dce61c5cd8e549fa02a552bdbf0b756359ea21d96ffeb8bd362b3576d2a8014630ed0e74a24af3291d16d1c18a5ff3037061e3b34b158b48d
-EBUILD qtpy-2.4.2.ebuild 8778 BLAKE2B 53ddca392cd093ca6522b514b6e6b03259a8af310ed9e2b7018e46544c8efc04f86e5ced5658bd6914c1eff08bfe8564532077edacc4af6ccc50e3ba1d5a4695 SHA512 9625d427f78775355f9a749d31886e5b05627c2e7f2d852af3b20bdd106b543142b27047e7bcfa9f746e8c2a49839f57e4572f8c810cff18435315b7b35a6512
-MISC metadata.xml 3214 BLAKE2B 5228c6546721dfe06c488c6ab0edbfb14c2560bba1d35a70497193daec3b258ae08dce8efd9e29204dee2adadbacb94407311900406e2b216010c649ee6b5170 SHA512 25f882c68aabe5bf27e98c17a8708763df184a3931d7d0a47026ab016b13c46a84ce3f5e5a3964804e8083ff998d311ea38ab2ca52f38288e64a987ae0c54363
+EBUILD qtpy-2.4.2.ebuild 8768 BLAKE2B c33df24c46c1a8ffce6f6d6d0b96b8768fac0b178892a5fa5281ed643773ecdd025b69b1fcedddb426feb9811f3ed0aab1fff69629403395cc08dfdab4be8d85 SHA512 3ab577bde2bc6ffe18ec62f2bd28581370a4aec395b4979d889f55f2dff03b9dc3f6006f2cb097579ac91c406edcb26f22b7ef961b35a6caa1b16d194cab6f6a
+MISC metadata.xml 3107 BLAKE2B fa723132c270828a594454973fcf8d21a007bf8b85c0d8e894b88b0503ed04f47297dd6e64271044655fa28b2e4c2f3de1b66eb102482708faeb6663ba5b32cf SHA512 d58042f52758743ed55a485c08ec3373edcd3d45ca77d3c076784c527d143ad4e530558b849f5e84416446f638f1c050bfc8e255ff85c26d1bf75777d07aacf3
diff --git a/dev-python/qtpy/metadata.xml b/dev-python/qtpy/metadata.xml
index 7feee8ad3488..2c32e7f74480 100644
--- a/dev-python/qtpy/metadata.xml
+++ b/dev-python/qtpy/metadata.xml
@@ -11,13 +11,13 @@
</maintainer>
<longdescription>
QtPy is a small abstraction layer that lets you write applications using a single API call to either PyQt or PySide.
- It provides support for PyQt5, PyQt4, PySide2 and PySide using the Qt5 layout (where the QtGui module has been split into QtGui and QtWidgets).
- Basically, you can write your code as if you were using PySide2 but import Qt modules from qtpy instead of PySide2 (or PyQt5)
+ It provides support for PyQt6, PyQt5 and PySide6.
+ Basically, you can write your code as if you were using PyQt6 but import Qt modules from qtpy instead of PyQt6 (or PySide6)
</longdescription>
<use>
<flag name="pyqt5">Use <pkg>dev-python/pyqt5</pkg> as Qt for Python implementation</flag>
<flag name="pyqt6">Use <pkg>dev-python/pyqt6</pkg> as Qt for Python implementation</flag>
- <flag name="pyside2">Use <pkg>dev-python/pyside2</pkg> as Qt for Python implementation</flag>
+ <flag name="pyside2">Use dev-python/pyside2 as Qt for Python implementation</flag>
<flag name="pyside6">Use <pkg>dev-python/pyside6</pkg> as Qt for Python implementation</flag>
<flag name="designer">Pull in bindings for the QtDesigner module and enable the designer plugin</flag>
<flag name="gui">Pull in bindings for the QtGui module</flag>
diff --git a/dev-python/qtpy/qtpy-2.4.2.ebuild b/dev-python/qtpy/qtpy-2.4.2.ebuild
index aa4ac7aafb8b..f2a73c7871e3 100644
--- a/dev-python/qtpy/qtpy-2.4.2.ebuild
+++ b/dev-python/qtpy/qtpy-2.4.2.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2024 Gentoo Authors
+# Copyright 1999-2025 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
@@ -114,7 +114,7 @@ BDEPEND="
dev-python/pytest-qt[${PYTHON_USEDEP}]
pyqt5? (
dev-python/pyqt5[${PYTHON_USEDEP}]
- dev-python/pyqt5[bluetooth,dbus,declarative,designer,gui,help,location]
+ dev-python/pyqt5[dbus,declarative,designer,gui,help,location]
dev-python/pyqt5[multimedia,network,opengl,positioning,printsupport]
dev-python/pyqt5[sensors,serialport,speech(-),sql,svg,testlib,webchannel]
dev-python/pyqt5[websockets,widgets,x11extras,xml(+),xmlpatterns]