summaryrefslogtreecommitdiff
path: root/dev-python/qtconsole
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-09-02 22:17:17 +0100
committerV3n3RiX <venerix@koprulu.sector>2023-09-02 22:17:17 +0100
commitf247b36fc6df2694a347f5305eeb7f927d7c0ffe (patch)
treec80963b87f0b1c0c5019d9259ccda86498c7edcd /dev-python/qtconsole
parente5206efa6e88d32e3819685adee35c49124ccf0e (diff)
gentoo auto-resync : 02:09:2023 - 22:17:17
Diffstat (limited to 'dev-python/qtconsole')
-rw-r--r--dev-python/qtconsole/Manifest5
-rw-r--r--dev-python/qtconsole/qtconsole-5.4.3-r1.ebuild67
-rw-r--r--dev-python/qtconsole/qtconsole-5.4.3.ebuild16
-rw-r--r--dev-python/qtconsole/qtconsole-5.4.4.ebuild67
4 files changed, 149 insertions, 6 deletions
diff --git a/dev-python/qtconsole/Manifest b/dev-python/qtconsole/Manifest
index c8b5dfc70775..5356927e0c93 100644
--- a/dev-python/qtconsole/Manifest
+++ b/dev-python/qtconsole/Manifest
@@ -1,3 +1,6 @@
DIST qtconsole-5.4.3.tar.gz 437303 BLAKE2B ead6676dabf342a74c30ecba1f280e697c7e58fb970813a572bcacf4adbc71e525df4323b50c30100433373e89eeea464dc382844066416e121a0f1c140487db SHA512 9c2061441775daa3045c1788ed57048de9197938a927647197d29a0b7cada836d5fe4e3329b5126c984064070a275cccbe0341622c3b8591f63842a619b859e8
-EBUILD qtconsole-5.4.3.ebuild 1593 BLAKE2B c432d4dd9ba6aaff230dd18c5cd6c5c85bd0ee2dab63fccb9c6d2e656961de3921f7997e22296b7eff6498fee278c3420b4e36124d39e056fe95e7e214e5d17f SHA512 b6fdf75bda7fa6e46b8ee92596d79dac857938a5eaa08507e2f8818e258c1071b11dceb32ac9813fde31b3ce4bdd76f220dd2aadd2411473435ea4c245bb9e02
+DIST qtconsole-5.4.4.tar.gz 437213 BLAKE2B 2def481c7ceb29c8ce92dfb96055310a8ee3a664a77c76da0eac672c6fd036326402a47cdaab25d504a855172067ae73e7f94b874545951674395d82f18374b5 SHA512 95d00a7896579eeba75896dd96efe9f07a54a687eca4ec2c4d9c7cf05029570788cd23267682ee4bce9943cf4d6cb36d7bd1d77be66f6bfd0f37e7d15e0d8f0f
+EBUILD qtconsole-5.4.3-r1.ebuild 1715 BLAKE2B 8ed2fd542d50e9ecdb7a039b1da4fafb0fbfb2b54bf9b14da133ef160c726685068c4e80cee27d6869fc174045c418ab6eee4f737bacd87606d94a86a7849bd8 SHA512 e559590ba514ec35b57dc2b1f78efe1cc8ae6efb758ac9c64cd43ae65285184b2cfbbd6e35b6675e3f540b85a6e0f718ce5ac72b0fe1fbbb3670c4665ecad081
+EBUILD qtconsole-5.4.3.ebuild 1729 BLAKE2B f5e78bb0ae94f4b3bea511be44370afbf5f61b5c654a7d28b964388d0c67c60d18d17ad51ead87b943e5bd1df0960029fbc30cdb157d172edbfa21ed21a0173c SHA512 0a5cff7c0101e9c418296d62326eaae393eb1b3b92625d9e0eaf489fb82262944ebd17cc779190cd33285c8ed37078c8141fd38a26c3bb0ff403344f0289c914
+EBUILD qtconsole-5.4.4.ebuild 1715 BLAKE2B dc0efc639db596a6bc1036910b02b5f255c8f103a92c63262089e422ce0639fc41e37782852312da7ac2fe7689a8aeea0b70810aca71db1ba9737a75ee6949fc SHA512 e1d9506af887b74ce38278ee054f5f7ea063e9b56afe260e228ff6497e6bbb89addc232c33ce1a911bca0f59997b5d66420c2eab40efd90002ea7b2a0a9e3759
MISC metadata.xml 690 BLAKE2B f2ddc6515f66ac4549e99bd6f152c16431875508bf12b6319e0e6a2b1596d86abc50b87ee424d3876eb55e92d1a506ade6567cbad535b4b2b54fad924a1891a7 SHA512 28bb7360ac7775d9c72c4d0f34d4c9a35c63905c4e870722236cc6c66e98f6c0eb165c8d7a9ce28948b25808a053dd1bb667d1f4783ca95319bb216310dc9f60
diff --git a/dev-python/qtconsole/qtconsole-5.4.3-r1.ebuild b/dev-python/qtconsole/qtconsole-5.4.3-r1.ebuild
new file mode 100644
index 000000000000..2dd67dae4c33
--- /dev/null
+++ b/dev-python/qtconsole/qtconsole-5.4.3-r1.ebuild
@@ -0,0 +1,67 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..11} )
+PYTHON_REQ_USE="threads(+)"
+
+inherit distutils-r1 pypi virtualx
+
+DESCRIPTION="Qt-based console for Jupyter with support for rich media output"
+HOMEPAGE="
+ https://jupyter.org/
+ https://github.com/jupyter/qtconsole/
+ https://pypi.org/project/qtconsole/
+"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~x86"
+
+RDEPEND="
+ >=dev-python/ipykernel-4.1[${PYTHON_USEDEP}]
+ dev-python/ipython_genutils[${PYTHON_USEDEP}]
+ dev-python/jupyter-core[${PYTHON_USEDEP}]
+ >=dev-python/jupyter-client-4.1.1[${PYTHON_USEDEP}]
+ dev-python/packaging[${PYTHON_USEDEP}]
+ dev-python/pygments[${PYTHON_USEDEP}]
+ >=dev-python/pyzmq-17.1[${PYTHON_USEDEP}]
+ >=dev-python/traitlets-5.2.2_p1[${PYTHON_USEDEP}]
+ >=dev-python/QtPy-2.0.1[${PYTHON_USEDEP},gui,printsupport,svg]
+"
+BDEPEND="
+ test? (
+ dev-python/flaky[${PYTHON_USEDEP}]
+ dev-python/pytest-qt[${PYTHON_USEDEP}]
+ dev-python/QtPy[${PYTHON_USEDEP},svg,testlib]
+ )
+"
+
+PDEPEND="
+ dev-python/ipython[${PYTHON_USEDEP}]
+"
+
+distutils_enable_sphinx docs/source dev-python/sphinx-rtd-theme
+distutils_enable_tests pytest
+
+src_test() {
+ virtx distutils-r1_src_test
+}
+
+python_test() {
+ local EPYTEST_DESELECT=(
+ # TODO; expects exact HTML, so perhaps fragile
+ qtconsole/tests/test_jupyter_widget.py::TestJupyterWidget::test_other_output
+ )
+ local -x QT_API
+ for QT_API in pyqt5 pyqt6 pyside2 pyside6; do
+ if has_version "dev-python/QtPy[${QT_API}]"; then
+ local -x PYTEST_QT_API=${QT_API}
+ einfo "Testing with ${QT_API}"
+ nonfatal epytest ||
+ die "Tests failed with ${EPYTHON} / ${QT_API}"
+ fi
+ done
+}
diff --git a/dev-python/qtconsole/qtconsole-5.4.3.ebuild b/dev-python/qtconsole/qtconsole-5.4.3.ebuild
index 6ec82c52c0bf..3cd57fe34ba3 100644
--- a/dev-python/qtconsole/qtconsole-5.4.3.ebuild
+++ b/dev-python/qtconsole/qtconsole-5.4.3.ebuild
@@ -4,7 +4,7 @@
EAPI=8
DISTUTILS_USE_PEP517=setuptools
-PYTHON_COMPAT=( python3_{9..11} )
+PYTHON_COMPAT=( python3_{10..11} )
PYTHON_REQ_USE="threads(+)"
inherit distutils-r1 pypi
@@ -31,10 +31,9 @@ RDEPEND="
>=dev-python/traitlets-5.2.2_p1[${PYTHON_USEDEP}]
>=dev-python/QtPy-2.0.1[${PYTHON_USEDEP},gui,printsupport,svg]
"
-# The test suite tests both against pyqt5 *and* pyside2
BDEPEND="
test? (
- dev-python/QtPy[pyqt5,pyside2,${PYTHON_USEDEP},svg,testlib]
+ dev-python/QtPy[${PYTHON_USEDEP},svg,testlib]
)
"
# required by the tests that are removed:
@@ -51,9 +50,16 @@ distutils_enable_tests pytest
python_test() {
# TODO: these tests require virtx; however, running under virtx
# causes pytest to segv on exit (even though tests pass)
- EPYTEST_IGNORE=(
+ local EPYTEST_IGNORE=(
qtconsole/tests/test_00_console_widget.py
qtconsole/tests/test_jupyter_widget.py
)
- epytest
+ local -x QT_API
+ for QT_API in pyqt5 pyqt6 pyside2 pyside6; do
+ if has_version "dev-python/QtPy[${QT_API}]"; then
+ local -x PYTEST_QT_API=${QT_API}
+ einfo "Testing with ${QT_API}"
+ epytest
+ fi
+ done
}
diff --git a/dev-python/qtconsole/qtconsole-5.4.4.ebuild b/dev-python/qtconsole/qtconsole-5.4.4.ebuild
new file mode 100644
index 000000000000..9730cda1d211
--- /dev/null
+++ b/dev-python/qtconsole/qtconsole-5.4.4.ebuild
@@ -0,0 +1,67 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..11} )
+PYTHON_REQ_USE="threads(+)"
+
+inherit distutils-r1 pypi virtualx
+
+DESCRIPTION="Qt-based console for Jupyter with support for rich media output"
+HOMEPAGE="
+ https://jupyter.org/
+ https://github.com/jupyter/qtconsole/
+ https://pypi.org/project/qtconsole/
+"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~x86"
+
+RDEPEND="
+ >=dev-python/ipykernel-4.1[${PYTHON_USEDEP}]
+ dev-python/ipython_genutils[${PYTHON_USEDEP}]
+ dev-python/jupyter-core[${PYTHON_USEDEP}]
+ >=dev-python/jupyter-client-4.1.1[${PYTHON_USEDEP}]
+ dev-python/packaging[${PYTHON_USEDEP}]
+ dev-python/pygments[${PYTHON_USEDEP}]
+ >=dev-python/pyzmq-17.1[${PYTHON_USEDEP}]
+ >=dev-python/traitlets-5.2.2_p1[${PYTHON_USEDEP}]
+ >=dev-python/QtPy-2.4.0[${PYTHON_USEDEP},gui,printsupport,svg]
+"
+BDEPEND="
+ test? (
+ dev-python/flaky[${PYTHON_USEDEP}]
+ dev-python/pytest-qt[${PYTHON_USEDEP}]
+ dev-python/QtPy[${PYTHON_USEDEP},svg,testlib]
+ )
+"
+
+PDEPEND="
+ dev-python/ipython[${PYTHON_USEDEP}]
+"
+
+distutils_enable_sphinx docs/source dev-python/sphinx-rtd-theme
+distutils_enable_tests pytest
+
+src_test() {
+ virtx distutils-r1_src_test
+}
+
+python_test() {
+ local EPYTEST_DESELECT=(
+ # TODO; expects exact HTML, so perhaps fragile
+ qtconsole/tests/test_jupyter_widget.py::TestJupyterWidget::test_other_output
+ )
+ local -x QT_API
+ for QT_API in pyqt5 pyqt6 pyside2 pyside6; do
+ if has_version "dev-python/QtPy[${QT_API}]"; then
+ local -x PYTEST_QT_API=${QT_API}
+ einfo "Testing with ${QT_API}"
+ nonfatal epytest ||
+ die "Tests failed with ${EPYTHON} / ${QT_API}"
+ fi
+ done
+}