summaryrefslogtreecommitdiff
path: root/dev-python/qtconsole
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-03-12 18:13:14 +0000
committerV3n3RiX <venerix@koprulu.sector>2023-03-12 18:13:14 +0000
commitf1ced5f5f09c4d27185e6986a465f7bc3b828c65 (patch)
treebb4a65f6889f3cbcc2f8e5053b624f23291d7921 /dev-python/qtconsole
parent70d27c1344f6a6a51e11c610966542333b6f432a (diff)
gentoo auto-resync : 12:03:2023 - 18:13:14
Diffstat (limited to 'dev-python/qtconsole')
-rw-r--r--dev-python/qtconsole/Manifest2
-rw-r--r--dev-python/qtconsole/qtconsole-5.4.1.ebuild59
2 files changed, 61 insertions, 0 deletions
diff --git a/dev-python/qtconsole/Manifest b/dev-python/qtconsole/Manifest
index b7dcdcef3fa4..11b8ea6f924a 100644
--- a/dev-python/qtconsole/Manifest
+++ b/dev-python/qtconsole/Manifest
@@ -1,3 +1,5 @@
DIST qtconsole-5.4.0.tar.gz 431119 BLAKE2B 48348b400a9b594bd028d3905719f2d67f6c9281df99863f3d0d87cf83162c91ede3e65529a8efd3bff62ad3ea343cc4ee7ea028913cd5bf7e48d0c493930445 SHA512 c25a381d8494c64d63e379c1dd5a44c1945e773b87b9a27f8494905e7eca24c6381ec5b9792d9a57ac41b14137ce238795a5ff8d83d1b6ddaa62603e7d9ab165
+DIST qtconsole-5.4.1.tar.gz 436651 BLAKE2B 111aeacd324c9cec736f43468ebbf653047018fcd97602f82325dd7f3a92b25666615ac52a58730693d69841ddf18fd83d3468f778d7805713c07047235c83a9 SHA512 98ebb91cd30f1e046429615ef88bbcc047e4673145883b15d60b30c66d0115352b23f39c1109ddfd545e40bd261bc76070a249dbfe2e1751f7c2bf7a7e5d49f3
EBUILD qtconsole-5.4.0.ebuild 1600 BLAKE2B 6819bdfa625973c0041affd6f12d1c8f7bcd14c81dea9ecaf409d7ba75b943872c3f96e8cefc761a4fef0b6221cf21780d7c2439037f3481f17d03ed4f1804bc SHA512 eb7c9d3f622fb62a25b51498a9f35b842902ddbe4b2c9c526b6241d29e3a9a11a1738faed06e82539635e57c2b75c6551703c4acc64e60c5bbad974d3c3492c8
+EBUILD qtconsole-5.4.1.ebuild 1596 BLAKE2B 8f8b8e69ec18662b2294c40662107bdee840ed7be6e69805f30bf6d13c8ada5cd7ddd3beee0bff3f134b3c918a0fa73fa0806933e45a9f5fdad7b7d8648f3e39 SHA512 8cc198a6303d7ef6eacbd9bf6a4edf226e484de29c54ab474ccc399c6679f25caee4a43fa6bb3d3853dee651e8d178258ac53c938412aa227b376f1eb381ce15
MISC metadata.xml 690 BLAKE2B f2ddc6515f66ac4549e99bd6f152c16431875508bf12b6319e0e6a2b1596d86abc50b87ee424d3876eb55e92d1a506ade6567cbad535b4b2b54fad924a1891a7 SHA512 28bb7360ac7775d9c72c4d0f34d4c9a35c63905c4e870722236cc6c66e98f6c0eb165c8d7a9ce28948b25808a053dd1bb667d1f4783ca95319bb216310dc9f60
diff --git a/dev-python/qtconsole/qtconsole-5.4.1.ebuild b/dev-python/qtconsole/qtconsole-5.4.1.ebuild
new file mode 100644
index 000000000000..66ccc4b59413
--- /dev/null
+++ b/dev-python/qtconsole/qtconsole-5.4.1.ebuild
@@ -0,0 +1,59 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{9..11} )
+PYTHON_REQ_USE="threads(+)"
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="Qt-based console for Jupyter with support for rich media output"
+HOMEPAGE="
+ https://jupyter.org/
+ https://github.com/jupyter/qtconsole/
+ https://pypi.org/project/qtconsole/
+"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~loong ~x86"
+
+RDEPEND="
+ >=dev-python/ipykernel-4.1[${PYTHON_USEDEP}]
+ dev-python/ipython_genutils[${PYTHON_USEDEP}]
+ dev-python/jupyter_core[${PYTHON_USEDEP}]
+ >=dev-python/jupyter_client-4.1.1[${PYTHON_USEDEP}]
+ dev-python/packaging[${PYTHON_USEDEP}]
+ dev-python/pygments[${PYTHON_USEDEP}]
+ >=dev-python/pyzmq-17.1[${PYTHON_USEDEP}]
+ >=dev-python/traitlets-5.2.2_p1[${PYTHON_USEDEP}]
+ >=dev-python/QtPy-2.0.1[${PYTHON_USEDEP},gui,printsupport,svg]
+"
+# The test suite tests both against pyqt5 *and* pyside2
+BDEPEND="
+ test? (
+ dev-python/QtPy[pyqt5,pyside2,${PYTHON_USEDEP},svg,testlib]
+ )
+"
+# required by the tests that are removed:
+# dev-python/flaky[${PYTHON_USEDEP}]
+# dev-python/pytest-qt[${PYTHON_USEDEP}]
+
+PDEPEND="
+ dev-python/ipython[${PYTHON_USEDEP}]
+"
+
+distutils_enable_sphinx docs/source dev-python/sphinx-rtd-theme
+distutils_enable_tests pytest
+
+python_test() {
+ # TODO: these tests require virtx; however, running under virtx
+ # causes pytest to segv on exit (even though tests pass)
+ EPYTEST_IGNORE=(
+ qtconsole/tests/test_00_console_widget.py
+ qtconsole/tests/test_jupyter_widget.py
+ )
+ epytest
+}