summaryrefslogtreecommitdiff
path: root/dev-python/qtconsole
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2024-08-29 12:00:47 +0100
committerV3n3RiX <venerix@koprulu.sector>2024-08-29 12:00:47 +0100
commitadcf4f8116a4a850dae301fb4dbcd7b71cb35975 (patch)
tree41af0dd08b04c7d619cdfed205b03ff2cc201b26 /dev-python/qtconsole
parent7166f3a0a0b7886d340010458d0b130013cb9989 (diff)
gentoo auto-resync : 29:08:2024 - 12:00:47
Diffstat (limited to 'dev-python/qtconsole')
-rw-r--r--dev-python/qtconsole/Manifest2
-rw-r--r--dev-python/qtconsole/qtconsole-5.6.0.ebuild65
2 files changed, 67 insertions, 0 deletions
diff --git a/dev-python/qtconsole/Manifest b/dev-python/qtconsole/Manifest
index f051b593db81..fd9728dba219 100644
--- a/dev-python/qtconsole/Manifest
+++ b/dev-python/qtconsole/Manifest
@@ -1,3 +1,5 @@
DIST qtconsole-5.5.2.tar.gz 439219 BLAKE2B f354d3e6132142a3da52a1cb6b290d0a07b13920bc9f33f7fb29eb307cc5b653beccc5d28e53f7cbe7483147adb6e34ffc584718a79b814c9ce2c37b57a768fc SHA512 f79e51903fe5a1164a90c0905c308d2bce066bef2c61fed2b5bb7e757a9cf56875cdd14665df9284317497cd73bb544ae09e0b23c63b527bbd4bc90b874009f6
+DIST qtconsole-5.6.0.tar.gz 440531 BLAKE2B f8d9e1ec45f310152b2c779df71c048ce6f704f8a9f366b6ed415a3dc8988553f45c4ac63fa08425e22124048e7946a4b40aedbbb15e90306bca5138426d91fe SHA512 ccd8f7b87d218237827bd52afc160cc8c00e9feecf90cde39aff55509831bdc9c4799499c91ed13538ce52a4011ed289f194662eef55b98efe09a2b9a5bd5427
EBUILD qtconsole-5.5.2.ebuild 1684 BLAKE2B 9d2984a34b05203ddf430006d94e800474aeb880c2a0e16eadde409dbdc8b5c74da812abedac79e934239b5a68a527b34e6be3ffd658ea5ec37632447d792c72 SHA512 84b1a81bde38bc3f40249abc73f61ec9a8dfe7256e491b1e7265ed72c3918291a78a72935c3b902d22908192988b594c0511b5ece35635bfaf18fd77364f7358
+EBUILD qtconsole-5.6.0.ebuild 1644 BLAKE2B 475e93a4e76e18aa6aa1be266a354669391ae01a5372ae89433cc06c8ca73cf2986925e61bcea572d544b3b0d4c88d7cd2fd9d09181e4ece32cc3999ea18f021 SHA512 1b018e998311e362712126c98003fac7676a19d6d442a69600b972697a6104ddda31109b50ebe2710a46d637365222c7caa6f7bd5b96628c3b9b5523b23277fe
MISC metadata.xml 690 BLAKE2B f2ddc6515f66ac4549e99bd6f152c16431875508bf12b6319e0e6a2b1596d86abc50b87ee424d3876eb55e92d1a506ade6567cbad535b4b2b54fad924a1891a7 SHA512 28bb7360ac7775d9c72c4d0f34d4c9a35c63905c4e870722236cc6c66e98f6c0eb165c8d7a9ce28948b25808a053dd1bb667d1f4783ca95319bb216310dc9f60
diff --git a/dev-python/qtconsole/qtconsole-5.6.0.ebuild b/dev-python/qtconsole/qtconsole-5.6.0.ebuild
new file mode 100644
index 000000000000..c9b6137a741c
--- /dev/null
+++ b/dev-python/qtconsole/qtconsole-5.6.0.ebuild
@@ -0,0 +1,65 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..13} )
+PYTHON_REQ_USE="threads(+)"
+
+inherit distutils-r1 pypi virtualx
+
+DESCRIPTION="Qt-based console for Jupyter with support for rich media output"
+HOMEPAGE="
+ https://jupyter.org/
+ https://github.com/jupyter/qtconsole/
+ https://pypi.org/project/qtconsole/
+"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~loong ~riscv ~x86"
+
+RDEPEND="
+ >=dev-python/ipykernel-4.1[${PYTHON_USEDEP}]
+ dev-python/jupyter-core[${PYTHON_USEDEP}]
+ >=dev-python/jupyter-client-4.1.1[${PYTHON_USEDEP}]
+ dev-python/packaging[${PYTHON_USEDEP}]
+ dev-python/pygments[${PYTHON_USEDEP}]
+ >=dev-python/traitlets-5.2.2_p1[${PYTHON_USEDEP}]
+ >=dev-python/QtPy-2.4.0[${PYTHON_USEDEP},gui,printsupport,svg]
+"
+BDEPEND="
+ test? (
+ dev-python/flaky[${PYTHON_USEDEP}]
+ dev-python/pytest-qt[${PYTHON_USEDEP}]
+ dev-python/QtPy[${PYTHON_USEDEP},svg,testlib]
+ )
+"
+
+PDEPEND="
+ dev-python/ipython[${PYTHON_USEDEP}]
+"
+
+distutils_enable_sphinx docs/source dev-python/sphinx-rtd-theme
+distutils_enable_tests pytest
+
+src_test() {
+ virtx distutils-r1_src_test
+}
+
+python_test() {
+ local EPYTEST_DESELECT=(
+ # TODO; expects exact HTML, so perhaps fragile
+ qtconsole/tests/test_jupyter_widget.py::TestJupyterWidget::test_other_output
+ )
+ local -x QT_API
+ for QT_API in pyqt5 pyqt6 pyside2 pyside6; do
+ if has_version "dev-python/QtPy[${QT_API}]"; then
+ local -x PYTEST_QT_API=${QT_API}
+ einfo "Testing with ${QT_API}"
+ nonfatal epytest ||
+ die "Tests failed with ${EPYTHON} / ${QT_API}"
+ fi
+ done
+}