summaryrefslogtreecommitdiff
path: root/dev-python/qscintilla-python
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2020-06-21 17:50:24 +0100
committerV3n3RiX <venerix@redcorelinux.org>2020-06-21 17:50:24 +0100
commitfeb0daf81d888e9160f9f94502de09b66f2a63fd (patch)
treeb6e5c40ce2abef3da27ed50a023153f475e0ddef /dev-python/qscintilla-python
parent9452a6e87b6c2c70513bc47a2470bf9f1168920e (diff)
gentoo resync : 21.06.2020
Diffstat (limited to 'dev-python/qscintilla-python')
-rw-r--r--dev-python/qscintilla-python/Manifest2
-rw-r--r--dev-python/qscintilla-python/qscintilla-python-2.11.5.ebuild78
2 files changed, 80 insertions, 0 deletions
diff --git a/dev-python/qscintilla-python/Manifest b/dev-python/qscintilla-python/Manifest
index 6b5d96e04921..ecab29801727 100644
--- a/dev-python/qscintilla-python/Manifest
+++ b/dev-python/qscintilla-python/Manifest
@@ -1,3 +1,5 @@
DIST QScintilla-2.11.4.tar.gz 3007719 BLAKE2B b0f88a15a3636a0056d3bdac6e5d5bb05a065461c7de7fe0d5ad1740e87ca78a47bc1fd1af90a8751b553e8e326c830088a4cb38c9ebcad6be8bf9ebdb49bad0 SHA512 90fc2427121ca9ae55e34cf636460099bbdadd844318d9ef05f86790a36e25fb64528264bb7bb99e46b7add96378eff0cc69bb692940c6a1bddfadf86a9abdbd
+DIST QScintilla-2.11.5.tar.gz 3007564 BLAKE2B e1eb7794b2e09f7bbfebde69a7c62c1a952e36b95f9c7a38c3db0b6bbdab8d0bad4a6d780dc9bf9b5e8d64111046f1741c6710d8444504230ee0f4154ce0a304 SHA512 46bc3c896b4ab71fbcc821ce3a248ecc4200378e0b621adef8d39092f940928806c76abe529b7f27ce4280e7e49091d8cbeafe6f303ca85cf5675df2887fd99b
EBUILD qscintilla-python-2.11.4.ebuild 1782 BLAKE2B 2484322cc56bd746192300cc954f2c5af3041b2b48db25f1c0f952357bb0b037c398727c5161a7ab9aea63586207fb1989c87b599160c0e2e088341ba8356da2 SHA512 26836958cb815c272ffeeaabb858f296f586af6d49f98202dcb975fc83706f964b43cd40f607d1586c0294bea9af35032a562c4c982d72d53cd974518ab32a20
+EBUILD qscintilla-python-2.11.5.ebuild 1788 BLAKE2B 1b82c0af7b35ad9f7d4e343ae772a87c4a6784ef51de5d9155f9d8381976be63025b551dcd1769ed0da349d6adecd341b053cbeb4d1fd5553dce345592ea6b99 SHA512 e5a95258bec3adfbee11ff0b2e97c63a8948e471912edf19869722c4628bf4b2c62340616268f26ac6612d6cffbad7327bff72b427139e79fc0446235d88feef
MISC metadata.xml 678 BLAKE2B e849d949281fe5162977ac3cba9c3559258f0534ced3e4e160554e2ee166cd20f979545bebae2effb0690231c987abb0ad11ed2090dbcb1c6724fc3389edc195 SHA512 58afaba4b14bf09297c024e29d51bc6b22c9a8290a6ca7f2c8c5fd63dea01037a637eeddb2ad5dfc09f2fd09d92229f74f1ee9cfb200c835110236407296e530
diff --git a/dev-python/qscintilla-python/qscintilla-python-2.11.5.ebuild b/dev-python/qscintilla-python/qscintilla-python-2.11.5.ebuild
new file mode 100644
index 000000000000..45a5ed0c4c68
--- /dev/null
+++ b/dev-python/qscintilla-python/qscintilla-python-2.11.5.ebuild
@@ -0,0 +1,78 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python2_7 python3_{6,7,8} )
+inherit python-r1 qmake-utils
+
+DESCRIPTION="Python bindings for QScintilla"
+HOMEPAGE="https://www.riverbankcomputing.com/software/qscintilla/intro"
+
+MY_PN=QScintilla
+MY_P=${MY_PN}-${PV/_pre/.dev}
+if [[ ${PV} == *_pre* ]]; then
+ SRC_URI="https://dev.gentoo.org/~pesa/distfiles/${MY_P}.tar.gz"
+else
+ SRC_URI="https://www.riverbankcomputing.com/static/Downloads/${MY_PN}/${PV}/${MY_P}.tar.gz"
+fi
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~ppc64 ~x86"
+IUSE="debug"
+
+REQUIRED_USE="
+ ${PYTHON_REQUIRED_USE}
+"
+
+RDEPEND="
+ ${PYTHON_DEPS}
+ >=dev-python/PyQt5-5.12[gui,printsupport,widgets,${PYTHON_USEDEP}]
+ >=dev-python/PyQt5-sip-4.19.22:=[${PYTHON_USEDEP}]
+ dev-qt/qtcore:5
+ dev-qt/qtgui:5
+ dev-qt/qtprintsupport:5
+ dev-qt/qtwidgets:5
+ ~x11-libs/qscintilla-${PV}:=
+"
+DEPEND="${RDEPEND}
+ >=dev-python/sip-4.19.22[${PYTHON_USEDEP}]
+"
+
+S=${WORKDIR}/${MY_P}/Python
+
+src_configure() {
+ configuration() {
+ local myconf=(
+ "${PYTHON}"
+ "${S}"/configure.py
+ --pyqt=PyQt5
+ --qmake="$(qt5_get_bindir)"/qmake
+ $(usex debug '--debug --trace' '')
+ --verbose
+ )
+ echo "${myconf[@]}"
+ "${myconf[@]}" || die
+
+ # Fix parallel install failure
+ sed -i -e '/INSTALLS += distinfo/i distinfo.depends = install_subtargets install_pep484_stubs install_api' \
+ ${MY_PN}.pro || die
+
+ # Run eqmake to respect toolchain and build flags
+ eqmake5 -recursive ${MY_PN}.pro
+ }
+ python_foreach_impl run_in_build_dir configuration
+}
+
+src_compile() {
+ python_foreach_impl run_in_build_dir default
+}
+
+src_install() {
+ installation() {
+ emake INSTALL_ROOT="${D}" install
+ python_optimize
+ }
+ python_foreach_impl run_in_build_dir installation
+}