summaryrefslogtreecommitdiff
path: root/dev-python/qscintilla-python
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-09-17 11:03:04 +0100
committerV3n3RiX <venerix@koprulu.sector>2023-09-17 11:03:04 +0100
commit0968caae52d6eae7513e2ce4e0900a2e009780ee (patch)
tree54218d0d3baaf14b964427f98c4f90f13380ffd3 /dev-python/qscintilla-python
parent58018a2c9504435bb719f2d60439ebe22fbeb503 (diff)
gentoo auto-resync : 17:09:2023 - 11:03:03
Diffstat (limited to 'dev-python/qscintilla-python')
-rw-r--r--dev-python/qscintilla-python/Manifest2
-rw-r--r--dev-python/qscintilla-python/qscintilla-python-2.14.1.ebuild80
2 files changed, 82 insertions, 0 deletions
diff --git a/dev-python/qscintilla-python/Manifest b/dev-python/qscintilla-python/Manifest
index 10042e8fff3b..9e2a9c694f49 100644
--- a/dev-python/qscintilla-python/Manifest
+++ b/dev-python/qscintilla-python/Manifest
@@ -1,3 +1,5 @@
DIST QScintilla_src-2.13.3.tar.gz 3060031 BLAKE2B e93dd884f630ef5f02fbf558ea8d9f94cfde1af03b811c8df9c3197ce9cadc430bf9727aec114ba118588effa5bc76166e3bda48800b6112edc8e8c598d72952 SHA512 be102fd6123fad0bc7f8de39080886369398889de48a4ec8873a0751890d7be1f238ae5194b71d31aac492e2881b6bf7885d9c06a2a47e36328780b47694f5b5
+DIST QScintilla_src-2.14.1.tar.gz 3233610 BLAKE2B 83b54378f0d3fa39ea120214a06c91982f81281e15c61fc70a9e83928be64724cfd2679b5e4aafee44a324e24a6c4729693cd118c6ad0b1636a199f2f41d34fe SHA512 19e2f9e0a14947501c575018df368d24eb7f8c74e74faa5246db36415bf28dc0beee507ed0e73107c02b36a99bbaf55f0ef3349f479d2332e1b92b2c4a32788a
EBUILD qscintilla-python-2.13.3.ebuild 1828 BLAKE2B 1cd38e65242a96c2313da2a9a5c5346a9505cdf3a944cedd5336696fe621639eb5ff9deba5425343813d3a99d303d57cd099d52144e6481eaab9c10cbc6880a3 SHA512 840bea845e79c7f27e90997644e37a89ecc79acaf75f2e8b177f29b3cc62a57df244c00c49f07991c423848fcad173340664aafddd27863621b1217fba5e8d29
+EBUILD qscintilla-python-2.14.1.ebuild 1852 BLAKE2B 8d92ece0d30189d6d9c212abe4a72fa30a98b4ee5f7b9ee4f68e53b5fd2ae66f35ef321e7ffbb27a1d6ba919612f1dee09e16e1d73a2bc07d55501775ee13f15 SHA512 a799e1638ed089cc797bbd66dcde5b88a5cc162ac04858796153e661c464d142f898b88d9f4361b15871321130100f6913b81e70456f1ab29c6232c7d8ed0b4b
MISC metadata.xml 679 BLAKE2B 7d346ab99b6c19180388b012b949a7ff4bd474dbe222bdbecac25c6c29a1f5b14fa9e0a979a2b217d2604c1e9471776012303c45341277582bcb0f77681d94d8 SHA512 5a09f0497846433a08b407bc3b2a5c611087744a5354f744d97663687d179a9c8a0159e73fb88a7ee70cb371ddd11293f44698d3fac4899771b9bd3a4ed11a5f
diff --git a/dev-python/qscintilla-python/qscintilla-python-2.14.1.ebuild b/dev-python/qscintilla-python/qscintilla-python-2.14.1.ebuild
new file mode 100644
index 000000000000..0161c8b4a780
--- /dev/null
+++ b/dev-python/qscintilla-python/qscintilla-python-2.14.1.ebuild
@@ -0,0 +1,80 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{10..12} )
+inherit out-of-source-utils python-r1 qmake-utils
+
+DESCRIPTION="Python bindings for QScintilla"
+HOMEPAGE="https://www.riverbankcomputing.com/software/qscintilla/ https://pypi.org/project/QScintilla/"
+
+MY_PN=QScintilla
+MY_P=${MY_PN}_src-${PV/_pre/.dev}
+if [[ ${PV} == *_pre* ]]; then
+ SRC_URI="https://dev.gentoo.org/~pesa/distfiles/${MY_P}.tar.gz"
+else
+ SRC_URI="https://www.riverbankcomputing.com/static/Downloads/${MY_PN}/${PV}/${MY_P}.tar.gz"
+fi
+S=${WORKDIR}/${MY_P}/Python
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~ppc64 ~x86"
+IUSE="debug"
+
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+DEPEND="${PYTHON_DEPS}
+ >=dev-python/PyQt5-5.15.5[gui,printsupport,widgets,${PYTHON_USEDEP}]
+ dev-qt/qtcore:5
+ dev-qt/qtgui:5
+ dev-qt/qtprintsupport:5
+ dev-qt/qtwidgets:5
+ ~x11-libs/qscintilla-${PV}:=
+"
+RDEPEND="${DEPEND}
+ >=dev-python/PyQt5-sip-12.12:=[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ >=dev-python/PyQt-builder-1.15[${PYTHON_USEDEP}]
+ >=dev-python/sip-6.7[${PYTHON_USEDEP}]
+ dev-qt/qtcore:5
+"
+
+src_prepare() {
+ default
+ mv pyproject{-qt5,}.toml || die
+}
+
+src_configure() {
+ configuration() {
+ local myconf=(
+ sip-build
+ --verbose
+ --build-dir="${BUILD_DIR}"
+ --scripts-dir="$(python_get_scriptdir)"
+ --qmake="$(qt5_get_bindir)"/qmake
+ --no-make
+ $(usev debug '--debug --qml-debug --tracing')
+ )
+ echo "${myconf[@]}"
+ "${myconf[@]}" || die
+
+ # Run eqmake to respect toolchain and build flags
+ run_in_build_dir eqmake5 -recursive ${MY_PN}.pro
+ }
+ python_foreach_impl configuration
+}
+
+src_compile() {
+ python_foreach_impl run_in_build_dir default
+}
+
+src_install() {
+ installation() {
+ emake INSTALL_ROOT="${D}" install
+ python_optimize
+ }
+ python_foreach_impl run_in_build_dir installation
+}