summaryrefslogtreecommitdiff
path: root/dev-python/qrcode/qrcode-7.1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2021-07-03 22:39:47 +0100
committerV3n3RiX <venerix@redcorelinux.org>2021-07-03 22:39:47 +0100
commit7f0ccc917c7abe6223784c703d86cd14755691fb (patch)
tree8c6793f68896b341e22f33d7e6cef88e481f4a8b /dev-python/qrcode/qrcode-7.1.ebuild
parent9aa80713372911cec499b3adb2cd746790920916 (diff)
gentoo resync : 03.07.2021
Diffstat (limited to 'dev-python/qrcode/qrcode-7.1.ebuild')
-rw-r--r--dev-python/qrcode/qrcode-7.1.ebuild28
1 files changed, 28 insertions, 0 deletions
diff --git a/dev-python/qrcode/qrcode-7.1.ebuild b/dev-python/qrcode/qrcode-7.1.ebuild
new file mode 100644
index 000000000000..0185db078736
--- /dev/null
+++ b/dev-python/qrcode/qrcode-7.1.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{8..10} )
+inherit distutils-r1
+
+DESCRIPTION="QR Code generator on top of PIL"
+HOMEPAGE="https://pypi.org/project/qrcode/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~x86"
+
+# optional deps:
+# - pillow and lxml for svg backend, set as hard deps
+RDEPEND="
+ dev-python/lxml[${PYTHON_USEDEP}]
+ dev-python/pillow[${PYTHON_USEDEP}]"
+
+distutils_enable_tests unittest
+
+src_install() {
+ distutils-r1_src_install
+ doman doc/qr.1
+}