summaryrefslogtreecommitdiff
path: root/dev-python/pyzotero
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2021-06-20 14:45:01 +0100
committerV3n3RiX <venerix@redcorelinux.org>2021-06-20 14:45:01 +0100
commit34dea8e38f88007799629d0a56b12dec480b1d21 (patch)
tree6790873994b58030360328cf5897d934b3b03d16 /dev-python/pyzotero
parent7932d472a02d4c016ff7dff4b7a5479ab9d1883d (diff)
gentoo resync : 20.06.2021
Diffstat (limited to 'dev-python/pyzotero')
-rw-r--r--dev-python/pyzotero/Manifest2
-rw-r--r--dev-python/pyzotero/pyzotero-1.4.24.ebuild41
2 files changed, 43 insertions, 0 deletions
diff --git a/dev-python/pyzotero/Manifest b/dev-python/pyzotero/Manifest
index b417cfd9c904..215ef395fdb3 100644
--- a/dev-python/pyzotero/Manifest
+++ b/dev-python/pyzotero/Manifest
@@ -1,5 +1,7 @@
DIST pyzotero-1.4.22.tar.gz 521386 BLAKE2B 3f5cc943aa108b771675955fcf7acaea62bbed360f7b9a4de4127d086c0c11679090df1e02820c0c937057cb77923c7d48ff95b06d92a6494d2db3b70fa65a27 SHA512 c9438474c30405d54194315ee007ae53527963460621c0e74b8286baa98f324601fbc99d342183ae643919890b70f08cc0ae431836b03e3d9028e62302ec63f8
DIST pyzotero-1.4.23.tar.gz 521386 BLAKE2B 4d66adc8c66c21c5ec3a21d7c0b2316bb9d983f3e31efdb11cb8840a8f94415b6e7e792d5870a33530fe877215855f7b2bc244fa05987cff0edf48ea850be54c SHA512 383809cf7a5ab950871c47101397e3a073f53d41f723acbcbe91d5c62d56c0618a70433a5ae3332d25195d4bce207c57b7f26b7c4c851621282b994f1afbf4b3
+DIST pyzotero-1.4.24.tar.gz 521403 BLAKE2B 225c881f85be6b04d54975b40d4254588214ee84974103dfe2cd64db01f586e93379e21ca537f1356c798125e149b15b326832abe172f029e8841d879650df84 SHA512 f2a1ac00c331efbfe32e00d8281d36cdf8112f68a5c3851cb34625090bfe8dec81d1afec86e4af9ae477df6855eb42ced75e942b18589564f9d04351117f0d05
EBUILD pyzotero-1.4.22.ebuild 970 BLAKE2B 7062fa58ce4bbfa46ddb81b79976869b6e7a7480fc4bf631e92e13a1f9798340902fdd088d55453e5dcf0d5298c3f23fc0c0af5469d71ac3b6ccc0772de62e82 SHA512 ba10003617ebae621c6f53341da81271c0ec142bb810398b39cbded180763beb0c5bf4800b2478191157b0533e6d88d6cce82cb08eb4e9554154435029a7edaa
EBUILD pyzotero-1.4.23.ebuild 975 BLAKE2B 5d90886cb42b8e09c05740f07500945c9495730a31df5f403efd5929c172aadc8640305052660e8851234b066cd47939152f606e096d431999b982f70070bb10 SHA512 ebeb21bd45223874a00112208a224489bb75766f7ab3510aa502365df141e4b1b1c68325e77c8e29d65f420bee213519491c77ce7bd8806fdd14611a65c1fec2
+EBUILD pyzotero-1.4.24.ebuild 975 BLAKE2B e6f2e31629a76a03180e413574a6381a315b8940f33775e791bc9425cfaf5b77eab2e1eca597f2b552eb51620ce38badae4f1e5d2631bf268b682dcff1e6f28f SHA512 30b95ac9540650f8cfc86f4ca112535ff5570ba7ccf57521c0e40c0c9b0841f4d51a05a1c093201dab4f5fa6e843be5bdcaee6810381aeba7860e2586882a30b
MISC metadata.xml 511 BLAKE2B 363254beff5da581cc2abe491330e1eff22d98aacb6f6c9de9146a185dea24e2958c1559428bb2cd4c7102a5cfd3eb639522c71bff823d03874ca8b4e213aefd SHA512 6f5187dabb878bbf49ab113a31692b0a9b11b517f6e8391da487775444d4fa19b281085f35928ee04c2bcfede4b2f78a15a7ef8860b97df1f8a0cc3208a46750
diff --git a/dev-python/pyzotero/pyzotero-1.4.24.ebuild b/dev-python/pyzotero/pyzotero-1.4.24.ebuild
new file mode 100644
index 000000000000..1ca9deced71e
--- /dev/null
+++ b/dev-python/pyzotero/pyzotero-1.4.24.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{8..9} )
+
+inherit distutils-r1
+
+DESCRIPTION="A Python client for the Zotero API"
+HOMEPAGE="https://github.com/urschrei/pyzotero"
+SRC_URI="https://github.com/urschrei/pyzotero/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64"
+
+RDEPEND="
+ app-text/zotero-bin
+ dev-python/bibtexparser[${PYTHON_USEDEP}]
+ <dev-python/feedparser-6[${PYTHON_USEDEP}]
+ dev-python/pathlib2[${PYTHON_USEDEP}]
+ dev-python/pytz[${PYTHON_USEDEP}]
+ dev-python/requests[${PYTHON_USEDEP}]
+"
+
+BDEPEND="
+ test? (
+ dev-python/python-dateutil[${PYTHON_USEDEP}]
+ dev-python/httpretty[${PYTHON_USEDEP}]
+ )"
+
+distutils_enable_sphinx doc --no-autodoc
+distutils_enable_tests pytest
+
+python_prepare_all() {
+ # do not install tests
+ sed -i "s/find_packages(),/find_packages(exclude=('test*')),/g" setup.py || die
+
+ distutils-r1_python_prepare_all
+}