summaryrefslogtreecommitdiff
path: root/dev-python/pyzotero/pyzotero-1.4.25.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2021-10-20 10:22:14 +0100
committerV3n3RiX <venerix@koprulu.sector>2021-10-20 10:22:14 +0100
commit46eedbedafdb0040c37884982d4c775ce277fb7b (patch)
treedb33a91259730be84999e13a8d8168c799f50ac0 /dev-python/pyzotero/pyzotero-1.4.25.ebuild
parente23a08d0c97a0cc415aaa165da840b056f93c997 (diff)
gentoo resync : 20.10.2021
Diffstat (limited to 'dev-python/pyzotero/pyzotero-1.4.25.ebuild')
-rw-r--r--dev-python/pyzotero/pyzotero-1.4.25.ebuild39
1 files changed, 0 insertions, 39 deletions
diff --git a/dev-python/pyzotero/pyzotero-1.4.25.ebuild b/dev-python/pyzotero/pyzotero-1.4.25.ebuild
deleted file mode 100644
index 03077463c22c..000000000000
--- a/dev-python/pyzotero/pyzotero-1.4.25.ebuild
+++ /dev/null
@@ -1,39 +0,0 @@
-# Copyright 1999-2021 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-PYTHON_COMPAT=( python3_{8..9} )
-inherit distutils-r1
-
-DESCRIPTION="A Python client for the Zotero API"
-HOMEPAGE="https://github.com/urschrei/pyzotero"
-SRC_URI="https://github.com/urschrei/pyzotero/archive/v${PV}.tar.gz -> ${P}.tar.gz"
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="~amd64"
-
-RDEPEND="
- app-text/zotero-bin
- dev-python/bibtexparser[${PYTHON_USEDEP}]
- <dev-python/feedparser-6[${PYTHON_USEDEP}]
- dev-python/pytz[${PYTHON_USEDEP}]
- dev-python/requests[${PYTHON_USEDEP}]
-"
-
-BDEPEND="
- test? (
- dev-python/python-dateutil[${PYTHON_USEDEP}]
- dev-python/httpretty[${PYTHON_USEDEP}]
- )"
-
-distutils_enable_sphinx doc --no-autodoc
-distutils_enable_tests pytest
-
-python_prepare_all() {
- # do not install tests
- sed -i "s/find_packages(),/find_packages(exclude=('test*',)),/g" setup.py || die
-
- distutils-r1_python_prepare_all
-}