summaryrefslogtreecommitdiff
path: root/dev-python/pyzmq
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2020-09-16 09:32:48 +0100
committerV3n3RiX <venerix@redcorelinux.org>2020-09-16 09:32:48 +0100
commit9ee6d97c2883d42f204a533a8bc1f4562df778fb (patch)
treeb690ddc0ca30f1472887edbb0b8313629bfcbbb2 /dev-python/pyzmq
parentb17a3ef12038de50228bade1f05502c74e135321 (diff)
gentoo resync : 16.09.2020
Diffstat (limited to 'dev-python/pyzmq')
-rw-r--r--dev-python/pyzmq/Manifest2
-rw-r--r--dev-python/pyzmq/pyzmq-19.0.2.ebuild93
2 files changed, 95 insertions, 0 deletions
diff --git a/dev-python/pyzmq/Manifest b/dev-python/pyzmq/Manifest
index 8b0d6f227f39..f7ec0cc9d72d 100644
--- a/dev-python/pyzmq/Manifest
+++ b/dev-python/pyzmq/Manifest
@@ -1,4 +1,6 @@
AUX pyzmq-19.0.0-tests.patch 6686 BLAKE2B 91ca18b17331f64448b151269c971ce4dec01b753f00623ea5570a2694b5e2dbbb457c420f22772e8471228f1042da656b06ca740f79f7d6b9ef0d18b8176317 SHA512 971ed65fb299f865edc96c7e138f65cecbed9de526ef10f412e4d81a53c4dc4d65512455bc2ca17c0bc24c09d7bfd7b79cc4acd08f93b517f42466e2b1490836
DIST pyzmq-19.0.1_p20200608.tar.gz 390927 BLAKE2B d70a2f615782cc5a53ed2ffab4d5549bc5d15cc1e0e63f640a357fe8575ca327a5976a3e8b11d97c236a31ca17025f37fe423d166b684b5c4aafc139a0941492 SHA512 7f077ed3858c226eb1e3f5e51dfb5d4b517ec94357b37cc66d17cfe2543786b86627ce7eb4c12785a2709a499af998d02642d972c119a637df3cec5201e909d1
+DIST pyzmq-19.0.2.tar.gz 390927 BLAKE2B d70a2f615782cc5a53ed2ffab4d5549bc5d15cc1e0e63f640a357fe8575ca327a5976a3e8b11d97c236a31ca17025f37fe423d166b684b5c4aafc139a0941492 SHA512 7f077ed3858c226eb1e3f5e51dfb5d4b517ec94357b37cc66d17cfe2543786b86627ce7eb4c12785a2709a499af998d02642d972c119a637df3cec5201e909d1
EBUILD pyzmq-19.0.1_p20200608.ebuild 1497 BLAKE2B fea10c8b964a2a0730242c8d45a40135bfc646d217fe67122a95f39503f0b335f7bd9e2df03df9f8eeb43d274e14d2cdbd3b1d151dbe144d94bb75160f5cc7b3 SHA512 88cbb433c1baef81aa3fe2801a93f0f66d7c3874141376f3ca8da86b9e64b4f7377d1a711bf4b0dcfce3f6ea6f329f6193d9ac2fe3271cf6350335d349128355
+EBUILD pyzmq-19.0.2.ebuild 2979 BLAKE2B 687c883bf9003268caff444084df6db512db05e2fa1d920ba206b3a2ec99976cd106bac5678bcf02e56eeac68f8fc9ce12c45cc58de2ff8d1e1fa02e19485afb SHA512 cf031069972cdcfd2e175ace2c069d2f1edc5f73ffa6db07c07c7d480f14afe59e03ee591eaede3730f9bd8c92a05d0f6e5dbf3ff6459409dcb35d13633bc3ac
MISC metadata.xml 390 BLAKE2B bef63f0fd0f88f72fbbdbe6ecbc25572a97dedb5cf17e4a4f99b4698a4e437935970425fc7a32b46059ceb2cf2ea177b25c324a00261e22d881ff4c5d9fd408f SHA512 8b702f02b5ed0233f1b9cd7c7366e108436ad8331082af8606d864145c967f45d1317b7c4f260a0542430397dfc1a5fb18e69bef90f154bb65ff07a4f7132dc7
diff --git a/dev-python/pyzmq/pyzmq-19.0.2.ebuild b/dev-python/pyzmq/pyzmq-19.0.2.ebuild
new file mode 100644
index 000000000000..d484501919b9
--- /dev/null
+++ b/dev-python/pyzmq/pyzmq-19.0.2.ebuild
@@ -0,0 +1,93 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{6..9} )
+PYTHON_REQ_USE="threads(+)"
+
+inherit flag-o-matic distutils-r1 toolchain-funcs
+
+EGIT_COMMIT="dd4dac055152d47c829034224cdecf594c7b3f12"
+DESCRIPTION="Lightweight and super-fast messaging library built on top of the ZeroMQ library"
+HOMEPAGE="
+ https://www.zeromq.org/bindings:python
+ https://pypi.org/project/pyzmq/
+ https://github.com/zeromq/pyzmq/"
+SRC_URI="
+ https://github.com/zeromq/pyzmq/archive/${EGIT_COMMIT}.tar.gz
+ -> ${P}.tar.gz"
+S=${WORKDIR}/${PN}-${EGIT_COMMIT}
+
+LICENSE="LGPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~mips ~ppc ~ppc64 ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos"
+IUSE="+draft"
+
+DEPEND="
+ >=net-libs/zeromq-4.2.2-r2:=[drafts]
+"
+RDEPEND="${DEPEND}
+ dev-python/py[${PYTHON_USEDEP}]
+ dev-python/cffi:=[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ dev-python/cython[${PYTHON_USEDEP}]
+ test? (
+ >=www-servers/tornado-5.0.2[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+distutils_enable_sphinx docs \
+ "dev-python/numpydoc"
+
+python_configure_all() {
+ tc-export CC
+ append-cppflags -DZMQ_BUILD_DRAFT_API=$(usex draft '1' '0')
+}
+
+python_compile() {
+ esetup.py cython --force
+ distutils-r1_python_compile
+}
+
+python_test() {
+ local deselect=(
+ # lore says it sometimes hangs
+ zmq/tests/test_auth.py::TestThreadAuthentication::test_curve
+
+ # broken tests
+ zmq/tests/test_auth.py::TestThreadAuthentication::test_curve_user_id
+ zmq/tests/test_constants.py::TestConstants::test_draft
+ zmq/tests/test_context.py::TestContext::test_mockable
+ zmq/tests/test_draft.py::TestDraftSockets::test_client_server
+ zmq/tests/test_draft.py::TestDraftSockets::test_radio_dish
+ zmq/tests/test_message.py::TestFrame::test_buffer_numpy
+ zmq/tests/test_message.py::TestFrame::test_bytes
+ zmq/tests/test_message.py::TestFrame::test_frame_more
+ zmq/tests/test_message.py::TestFrame::test_lifecycle1
+ zmq/tests/test_message.py::TestFrame::test_lifecycle2
+ zmq/tests/test_message.py::TestFrame::test_memoryview_shape
+ zmq/tests/test_message.py::TestFrame::test_multi_tracker
+ zmq/tests/test_message.py::TestFrame::test_tracker
+ zmq/tests/test_security.py::TestSecurity::test_curve
+ zmq/tests/test_security.py::TestSecurity::test_plain
+ zmq/tests/test_socket.py::TestSocket::test_large_send
+ zmq/tests/test_socket.py::TestSocket::test_tracker
+ zmq/tests/test_socket.py::TestSocketGreen::test_large_send
+
+ # hanging tests
+ zmq/tests/test_socket.py::TestSocketGreen::test_tracker
+ zmq/tests/asyncio/test_asyncio.py::TestAsyncioAuthentication::test_blacklist
+ zmq/tests/asyncio/test_asyncio.py::TestAsyncioAuthentication::test_curve
+ zmq/tests/asyncio/test_asyncio.py::TestAsyncioAuthentication::test_plain
+ )
+ [[ ${EPYTHON} == python3.9 ]] && deselect+=(
+ # crashes python
+ zmq/tests/test_socket.py::TestSocketGreen
+ )
+
+ pytest -vv ${deselect[@]/#/--deselect } ||
+ die "Tests failed with ${EPYTHON}"
+}